Issue 45160 - modal dialogs should activate the unix desktop where they will be created
Summary: modal dialogs should activate the unix desktop where they will be created
Status: CLOSED FIXED
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: 680m85
Hardware: All All
: P3 Trivial (vote)
Target Milestone: OOo 2.0.1
Assignee: wolframgarten
QA Contact: issues@gsl
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-16 10:04 UTC by andreas.schluens
Modified: 2005-10-14 14:26 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description andreas.schluens 2005-03-16 10:04:41 UTC
By fixing the bugtrack task #b4899143# the impress wizard and the template 
wizard dialog was made non modal. But these dialogs (and it's environment) was 
not ready for that. E.g. the dialogs desnt react for an office shutdown ... and the 
office itself doesnt recognize these dialogs as possible reason against an office 
shutdown. As a result of that crashes occured. (see tasks #i45026# and 
#b5017761# for further details)

AS->PL: Would it be possible to activate the right unix desktop automaticly on 
opening a modal dialog ? At least we should try to establish this enhancement for 
the most popular unix window manager as e.g. KDE, GNOME, ...

Please note: This task can be reproduced only after #i45026# was fixed !
Because you need a modal office dialog, which can be triggered via command line 
(or by using our start menu entries).
Comment 1 philipp.lohmann 2005-03-23 16:18:26 UTC
fixed in CWS vcl39

currently for verification one needs to disable the DIALOG_NOPARENT handling in
 vcl/source/window/dialog.cxx; this should be solved after resync to a MWS
containing CWS fwkfinal2
Comment 2 philipp.lohmann 2005-06-14 17:20:53 UTC
please verify in CWS vcl39

re-open issue and reassign to as@openoffice.org
Comment 3 philipp.lohmann 2005-06-14 17:21:01 UTC
reassign to as@openoffice.org
Comment 4 philipp.lohmann 2005-06-14 17:21:07 UTC
reset resolution to FIXED
Comment 5 philipp.lohmann 2005-06-27 09:43:28 UTC
pl->wg: since you verified #b5017761# would you be so kind as to verify this
task also ? Please note that desktop switching will work only with window
managers that support it according to the EWMH spec; either GNOME or KDE should
be fine.

re-open issue and reassign to wg@openoffice.org
Comment 6 philipp.lohmann 2005-06-27 09:43:36 UTC
reassign to wg@openoffice.org
Comment 7 philipp.lohmann 2005-06-27 09:43:41 UTC
reset resolution to FIXED
Comment 8 wolframgarten 2005-09-23 12:55:28 UTC
Verified in CWS.
Comment 9 wolframgarten 2005-10-14 14:26:40 UTC
Tested in master m133. Closed.