Issue 45477 - Uninstall does not remove files and Registry keys
Summary: Uninstall does not remove files and Registry keys
Status: CLOSED FIXED
Alias: None
Product: Installation
Classification: Application
Component: code (show other issues)
Version: 680m79
Hardware: PC Windows XP
: P4 Trivial with 2 votes (vote)
Target Milestone: OOo 2.3
Assignee: Olaf Felka
QA Contact: issues@installation
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2005-03-19 09:58 UTC by Andrea Pescetti
Modified: 2007-04-17 13:26 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Andrea Pescetti 2005-03-19 09:58:03 UTC
The uninstaller of OOo 1.9.79 Italian does not [ask if the user wants to] remove
the OOo directory and the files contained therein.

Moreover, many Windows Registry keys created/modified during installation are
not removed. This is a selection from a long list of leftover keys.

[HKEY_CLASSES_ROOT\CLSID\{67F2A879-82D5-4A6D-8CC5-FFB3C114B69D}]
@="SOActiveX Class"

[HKEY_CLASSES_ROOT\CLSID\{67F2A879-82D5-4A6D-8CC5-FFB3C114B69D}\Control]
[HKEY_CLASSES_ROOT\CLSID\{67F2A879-82D5-4A6D-8CC5-FFB3C114B69D}\EnableFullPage]
[HKEY_CLASSES_ROOT\CLSID\{67F2A879-82D5-4A6D-8CC5-FFB3C114B69D}\EnableFullPage\.odb]
(same for all OOo file extensions)
[HKEY_CLASSES_ROOT\CLSID\{67F2A879-82D5-4A6D-8CC5-FFB3C114B69D}\EnableFullPage\.sxw]

[HKEY_CLASSES_ROOT\Applications\OpenOffice.org 1.9.79\shell\edit]
[HKEY_CLASSES_ROOT\Applications\OpenOffice.org 1.9.79\shell\edit\command]
@="\"C:\\Programmi\\OpenOffice.org 1.9.79\\program\\soffice.exe\" -o \"%1\""

[HKEY_CLASSES_ROOT\Applications\soffice.exe\shell\new]
@="~Nuovo"
[HKEY_CLASSES_ROOT\Applications\soffice.exe\shell\new\command]
@="\"C:\\Programmi\\OpenOffice.org 1.9.79\\program\\soffice.exe\" -n \"%1\""
(same for open and print operations)

[Reported by Paolo during Italian QA tests]
Comment 1 Olaf Felka 2005-03-21 14:39:24 UTC
@ IS: That's what I found after uninstalling SO8m85:
HKEY_CLASSES_ROOT\.htm\OpenWithList\StarOffice 8\shell\edit\command
HKEY_CLASSES_ROOT\Applications\StarOffice 8\shell\edit\command
HKEY_CURRENT_USER\Software\Classes\.htm\OpenWithList\StarOffice 8\shell\edit\command
HKEY_CURRENT_USER\Software\Classes\Applications\StarOffice 8\shell\edit\command
HKEY_USERS\S-1-5-21-348480732-1410218398-1222582537-1260\Software\Classes\.htm\OpenWithList\StarOffice
8\shell\edit\command
HKEY_USERS\S-1-5-21-348480732-1410218398-1222582537-1260\Software\Classes\Applications\StarOffice
8\shell\edit\command
HKEY_USERS\S-1-5-21-348480732-1410218398-1222582537-1260_Classes\.htm\OpenWithList\StarOffice
8\shell\edit\command
HKEY_USERS\S-1-5-21-348480732-1410218398-1222582537-1260_Classes\Applications\StarOffice
8\shell\edit\command
Comment 2 vandan 2005-05-02 00:15:08 UTC
I'd like to weight in on this one as well.
There are a number of ways that paths to OOo binaries can get into the registry.
The installer is just one of them. Users can right-click on a file, and say
"Open With ..." and choose the path to an OOo binary. There are most likely others.

The problem is that with the path changing with each version, a lot of stale
references to uninstalled versions of OOo are left around the place. Clicking on
a file will then result in a dialog saying something along the lines that the
destination file doesn't exist. When I do an OOo upgrade, after I uninstall OOo,
I open regedit, and manually search for all soffice, swriter, and scalc
references and delete them. This is the only way to get a fully functioning system.

So ... not only should the installer have the option of removing registry
entries that a previous installer may have set, but also of removing *ALL*
registry settings that have anything to do with OOo - whether the installer put
them there or not. Without this, users must be adept at registry hacking to make
OOo work properly, especially when clicking on documents from Windows Explorer.
Comment 3 christof.pintaske 2005-05-26 10:46:51 UTC
in the first shot for after 2.0 we will concentrate on the most urgend issues
for the product. Do to lack of ressources we postpone this one to the next major
Comment 4 vandan 2006-01-17 03:37:53 UTC
2.0 has been out for a while now.

Perhaps it is time to consider a way of sanitising the registry when upgrading
OOo to avoid all the issues people will be having now with opening Office
documents since upgrading from 1.x to 2.0?

For those not convinced of the need to address this bug, try the following
simple demonstration.

1) Install OOo-1.1.4 on a clean system, using the default options for everything
2) 'Train' Windows Explorer ( right-click and 'open with...', select OOo ) and
other apps ( eg Thunderbird ) how to open common Office documents.
3) Uninstall OOo-1.1.4.
4) Install OOo-2.0.1, using the default options for everything.
5) Try to open Office documents from Windows Explorer and Thunderbird.

Explorer / Thunderbird try to use the old 1.1.4. They're looking in the
registry. We should make sure that the registry contains valid data while
installing.

I have to manually do the following on 20 or so systems every time I upgrade:

1) Uninstall OOo.
2) Open regedit.exe
3) Search for 'soffice'.
4) Delete all entries found.
5) Search for 'oowriter'.
6) Delete all entries found.
7) Search for 'oocalc'.
8) Delete all entries found.
9) Search for 'ooimpress'.
10) Delete all entries found.
11) Install OOo.
Comment 5 thackert 2006-06-04 08:33:42 UTC
As this issue was reported for OOo 1.9.79 and verified with 2.0, has someone verified this issue with 
OOo 2.0.x versions? Does this issue still exist? Sorry, cannot test it myself here (I am using Debian ...
 ;) ). If this issue is fixed, could someone close this issue, please?
Comment 6 vandan 2006-06-05 00:02:44 UTC
The issue persists.
Comment 7 ingo.schmidt-rosbiegal 2006-10-11 11:14:31 UTC
Accepted
Comment 8 ingo.schmidt-rosbiegal 2006-10-19 09:59:25 UTC
IS -> OF: Can you please update this in a fresh vmware session? Setting target
to 2.2.
Comment 9 ingo.schmidt-rosbiegal 2006-10-19 10:00:08 UTC
.
Comment 10 Olaf Felka 2006-10-19 10:05:44 UTC
of @ is: What has changed that this has to be reconfirmed?
Comment 11 ingo.schmidt-rosbiegal 2006-10-23 10:07:00 UTC
Back to me.
Comment 12 ingo.schmidt-rosbiegal 2006-10-23 10:07:39 UTC
setting started
Comment 13 ingo.schmidt-rosbiegal 2006-12-12 11:09:11 UTC
Not enough time -> shifting target.
Comment 14 ingo.schmidt-rosbiegal 2007-02-12 10:49:29 UTC
IS -> DV: Please have a look.
Comment 15 dirk.voelzke 2007-02-12 11:55:53 UTC
Accepted.
Comment 16 dirk.voelzke 2007-02-21 10:38:25 UTC
Fixed in cws native80
Comment 17 dirk.voelzke 2007-03-14 14:12:33 UTC
Please verify.
Comment 18 Olaf Felka 2007-03-29 12:09:53 UTC
OF: All keys that are written at install time are removed with uninstall. All
other OpenOffice.org keys are not touched by uninstall. This is ok and should
not be removed. E.G: Manually added keys to an soffice.exe wich is not the
installed one should not be removed.
Comment 19 vandan 2007-03-29 12:56:51 UTC
I strongly disagree with the above comment re: not removing keys that weren't
installed by OOo. The reason we're asking for these keys to be removed is for
usability. The bottom line is that if these keys are not removed, then OOo will
not be properly integrated on Windows. Users will go to open a document, and
they'll get a file browser dialog asking them where soffice.exe went. I urge
people to read again the so-called 'proper' method of migrating from one version
of OO to another ( which I posted above, and had to repeat on 30 or so
computers, multiplied by however many beta versions of OOo I ran ... to many
anyway ), which involves manually removing registry keys.

People who take the "we didn't do it ... it's not our problem" attitude are
missing the point completely. Removing these keys is the only way OOo will work
properly on Windows. Users should not have to manually edit the registry to get
OOo to work.
Comment 20 Olaf Felka 2007-03-29 13:03:19 UTC
Where is the usability when the uninstall removes my manually created entries
and my workenvironment doesn't work anylonger?
Further diiscussions should be held on the related mailing list
(dev@installation.openoffice.org).
Comment 21 vandan 2007-03-30 00:14:29 UTC
Similarly, where is the usability when someone upgrades to a newer version of
OOo and it doesn't work because there are registry keys pointing to invalid
locations?

I haven't seen ANY of the naysayers put together a coherent response to this. Do
people actually READ comments and consider them, or is everyone on a
one-track-record?
Comment 22 Olaf Felka 2007-04-17 13:26:10 UTC
OF: Well done in OOo src680m209