Issue 45989 - Cannot use Wizards for new table or forms.
Summary: Cannot use Wizards for new table or forms.
Status: CLOSED DUPLICATE of issue 41296
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: 680m87
Hardware: All All
: P2 Trivial with 1 vote (vote)
Target Milestone: OOo 2.0.1
Assignee: berend.cornelius
QA Contact: issues@dba
URL:
Keywords: needmoreinfo
Depends on:
Blocks:
 
Reported: 2005-03-25 04:41 UTC by dcarrera
Modified: 2006-05-31 14:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description dcarrera 2005-03-25 04:41:43 UTC
Summary:
The new-table wizard doesn't appear.

OS: Solaris 2.8 on SPARC

Steps to reproduce the bug:
===========================
1. File > New > Database
2. Click on "Tables"
3. Click on "User Wizard to Create Table"

Outcome:
========
Nothing.

Nothing happens. Nothing at all. No wizard, no error messae, no crash, nothing.
I tried single click, double click, click and enter, etc. The only thing that
ever happens is that the text "Use Wizard to Create Table" is highlighted, but
that happens when the mouse hovers over the text, not when you click.

This is a loss in basic functionality. Hence, I'm setting the priority to P2.
Comment 1 dcarrera 2005-03-25 06:33:52 UTC
The Forms Wizard doesn't work either. Instead of seeing a wizard, you get a new
Writer document. (WTF?!)

Steps:
======
1. Create a database tables.
2. Right-click on the table.
3. Select "Form Wizard"

Outcome:
========
You get a new (empty) writer document ("Untitled 1"). No form, no wizard,
nothing. I've seen screenshots of how it's supposed to work, and this ain't it.

If you click on "Forms" (left panel) and click on "Use Wizard to Create Form"
the same thing happens.

I'm updating the Summary line.
Comment 2 marc.neumann 2005-03-29 08:10:39 UTC
hi dcarrera,

I can't reproduce this.

Where you have download the openoffice.org packages and which languages do you use?

Have you installed java, because the wizards need java?

Any other information which helps to reproduce this.

Bye Marc
Comment 3 dcarrera 2005-03-29 08:25:21 UTC
:-(

1) I downloaded OOo_1.9.87_SolarisSparc_install.tar.gz using the standard
download page. I can't remember which mirror I picked.

2) Yes, I have Java. There are two installed in this system:

$ java -version 
java version "1.4.2_05"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_05-b04)
Java HotSpot(TM) Client VM (build 1.4.2_05-b04, mixed mode)

$ /usr/bin/java -version 
java version "1.2.2"
Solaris VM (build Solaris_JDK_1.2.2_10, native threads, sunwjit)

Changing the Java version doesn't seem to help.

3) Other wizards seem to run fine (e.g. Letter and 'Document converter').

I guess it must be something to do with my particular setup. But I don't know
what it might be, so I don't know what to test.

Any suggestions?

Thank you for trying.

Cheers,
Daniel.
Comment 4 marc.neumann 2005-04-05 08:38:15 UTC
Hi Daniel,

> Any suggestions?

No, not really :-(

- Do you start the office via the commandline or via a icon on the desktop?

- Please start it from the commandline and execute the following macro.

Sub Main
   o = createUnoService("com.sun.star.wizards.table.CallTableWizard")
   o.trigger("start")
End Sub

Then you should see a NullPointer Exception on the terminal window, then we at
least know that the service can be instanced.

Bye Marc
Comment 5 dcarrera 2005-04-05 09:53:06 UTC
> - Do you start the office via the commandline or via a icon on the desktop?

Command line.

> - Please start it from the commandline and execute the following macro.

Sure. Here's the result:

java.lang.NullPointerException
        at
com.sun.star.wizards.common.Properties.hasPropertyValue(Properties.java:30)
        at com.sun.star.wizards.db.DBMetaData.getConnection(DBMetaData.java:485)
        at
com.sun.star.wizards.db.TableDescriptor.getConnection(TableDescriptor.java:103)
        at
com.sun.star.wizards.table.TableWizard.startTableWizard(TableWizard.java:334)
        at
com.sun.star.wizards.table.CallTableWizard$TableWizardImplementation.trigger(CallTableWizard.java:126)



I see the NullPointer Exception. Otherwise, this output is meaningless to me.
Is it good news or bad news?

Cheers,
Daniel.
Comment 6 marc.neumann 2005-04-05 10:30:34 UTC
Hi Daniel,

> Is it good news or bad news?

Both, the good news is that all works as I expect, the bad news is that I don't
know what's going wrong.

What locale do you use?
What kind of datasource do you use? 
Is it possible to create a table manually?

Has any other community member an idea?

Bye Marc
Comment 7 dcarrera 2005-04-05 10:38:24 UTC
> What locale do you use?

The default "English" download. en-US I guess it is.

> What kind of datasource do you use? 

This happens with both HSQLDB and dBase.

> Is it possible to create a table manually?

Yes. For that matter, it is also possible to make a form manually.

> Has any other community member an idea?

Do the wizards require Java? Should I be looking at problems with Java?
I have 1.4.2_04 and 1.4.2_05 available. I have it set to _05 (though I've tried
with _04 without success).

What's interesting about that is that I didn't know I had _04 anywhere, and
indeed, I don't know where it is. The only other Java I am aware of being here
is 1.2.2_10 (see the note from Mar 29).

:(

Daniel.
Comment 8 marc.neumann 2005-04-08 11:15:28 UTC
> Do the wizards require Java?

Yes, the wizards required a 1.4.2 Java.

Maybe the office doesn't use the 1.4. java, instead it use the 1.2. java.

There is a m91 version available now, can you please test this version. Maybe
the issue is fixed there.

Bye Marc
Comment 9 dcarrera 2005-04-09 16:29:03 UTC
I just tried 1.9.91, no change. When I try to start the Table Wizard nothing
happens.

May I ask, why in the world is OOo using Java for *Wizards* ??
Why should wizards depend on a third-party product? Worse yet, one that can't
even be bundled with OOo. At least if you used Python you could point out that
OOo comes with Python, so it's ok. But OOo doesn't come with Java. So a
significant portion of the functionality is just missing.

Could someone explain to me why this decision was made? As you can see, it's
really causing me a lot of trouble.
Comment 10 Frank Schönheit 2005-04-11 07:50:33 UTC
> Could someone explain to me why this decision was made?

*sigh* Please ask this in the mailing list, where it belongs to. I suggest
users@ooo / discuss@ooo, since it does not only affect DB related wizards.
Comment 11 Martin Hollmichel 2005-04-14 11:48:35 UTC
I can confirm this with jre-1.3.1_14 (Windows) as well.

Daniel, can you please check in the tools-options->OpenOffice.org-Java dialog
what OOo thinks what java version is used ?

set plattform to "all"
Comment 12 marc.neumann 2005-04-18 09:15:39 UTC
because MH can confirm this with a java 1.3, I reassign this to the right developer.

A jre 1.3 doesn't work on my linux ( suse 9.2 ) anymore, because of missing
libraries, So I can't confirm this.

Comment 13 berend.cornelius 2005-05-25 20:08:13 UTC
If this bug is really due to  jre 1.3 incomapatibility it is duplicate to bug
41296 (	Wizard project contains java methods > jdk 1.3.1) that is going to be
fixed with the target OOo 2.0.

*** This issue has been marked as a duplicate of 41296 ***
Comment 14 berend.cornelius 2006-04-07 10:58:41 UTC
bc: verified in src680 m162 master. No Java 1.4 functionality is used in the
wizards anymore