Issue 46038 - Checkbox and option control labels rendered as text when HTNL is saved
Summary: Checkbox and option control labels rendered as text when HTNL is saved
Status: CLOSED DUPLICATE of issue 19690
Alias: None
Product: Writer
Classification: Application
Component: viewing (show other issues)
Version: OOo 2.0 Beta
Hardware: PC Windows ME
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-25 23:52 UTC by tburcham
Modified: 2005-03-28 17:25 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Two partial screenshots showing correctly, and incorrectly rendered checkbox labels (25.20 KB, application/x-compressed)
2005-03-25 23:53 UTC, tburcham
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description tburcham 2005-03-25 23:52:02 UTC
Checkbox and option control labels are rendered as text when HTNL
code is saved. Here's how I duplicated it:

1)  Start a new webpage
2)  Draw three checkboxes. For the screenshots, I put them on
    separate lines.
3)  Save the file
4)  Go to HTML view
5)  Make any harmless change to enable saving, like typing a space
    then deleting it
6)  Save the file
7)  Go back to normal view
8)  The checkbox labels will become plain text appearing past the
    ends of the checkboxes they were assigned to.

In the (soon to be attached) ZIP file:
"ChkBefore.GIF" is the original layout
"ChkAfter.GIF" is the layout after saving the HTML code
Comment 1 tburcham 2005-03-25 23:53:49 UTC
Created attachment 24283 [details]
Two partial screenshots showing correctly, and incorrectly rendered checkbox labels
Comment 2 eric.savary 2005-03-28 17:25:23 UTC
Another duplicate of issue 19690:
in the Writer, checkboxes are 1 element made of:
- 1 check element
- 1 internal name (NAME)
- 1 visible label (LABEL)

In HTML, a check box is made of 2 elements:
- a checkbox INPUT with an internal NAME
- a label, independent from the INPUT which is written as plain text.

So that the export to HTML is correct, only the shared UI Writer/Writer-web
makes the confusion.

*** This issue has been marked as a duplicate of 19690 ***
Comment 3 eric.savary 2005-03-28 17:25:35 UTC
closed