Issue 46085 - Add option to disable OOo font config fallback heuristics and use 'fontconfig' settings only
Summary: Add option to disable OOo font config fallback heuristics and use 'fontconfig...
Status: CLOSED DUPLICATE of issue 54603
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOo 2.0 Beta
Hardware: All Linux, all
: P3 Trivial (vote)
Target Milestone: AOO PleaseHelp
Assignee: philipp.lohmann
QA Contact: issues@gsl
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2005-03-27 11:31 UTC by flibby05
Modified: 2006-11-27 17:25 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description flibby05 2005-03-27 11:31:32 UTC
I suggest implementing an option to use fontconfig settings only.
(Setting a shell-variable will perfectly do..)

As i understand OOo uses complex fallback heuristics for finding the best font
configuration depending on system configuration. At the same time 'fontconfig'
is becoming the de facto font configuration standard for Linux systems (KDE,
Gnome, Mozilla..). 

1. As OOo now uses it's own font fallback heuristics _plus_ fontconfig settings
the average volunteer may struggle heavily to reliably investigate font issues.

2. Having this option to concentrate on fontconfig only would result in easier
communication between QA and reporters for finding workarounds.
Comment 1 mci 2005-03-29 06:51:24 UTC
reassigned to us

mci -> us:
Hi us, please have a look at this and decide further proceeding...
Comment 2 ulf.stroehler 2005-03-29 12:22:36 UTC
Another fontconfig enhancement.

@SSA: pls. discuss with PL and KA how to proceed with fontconfig support. Thanks.

@maxweber: having fontconfig is fine and what we are heading to also, however
there are still some OSes which we support but who lack the support for
fontconfig. I'm not sure whether another environment variable will ease testing
meaning you'll have two possible scenarios to test instead of one.
Comment 3 stephan_schaefer 2005-05-26 10:15:39 UTC
retarget due to limited resources
Comment 4 meywer 2005-11-03 09:14:35 UTC
see also issue 45128
Comment 5 stephan_schaefer 2005-12-05 09:53:52 UTC
ssa: reassign to pl
Comment 6 philipp.lohmann 2006-11-27 17:24:47 UTC
duplicate to patch issue 54603

*** This issue has been marked as a duplicate of 54603 ***
Comment 7 philipp.lohmann 2006-11-27 17:25:20 UTC
closing duplicate