Issue 46097 - Saving not possible if save medium unavailable once
Summary: Saving not possible if save medium unavailable once
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 680m87
Hardware: PC Windows XP
: P3 Trivial with 3 votes (vote)
Target Milestone: AOO Later
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
Depends on:
Reported: 2005-03-27 22:02 UTC by sbbedell
Modified: 2013-02-07 22:01 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Corrupted file created locally by OOo after losing network connection to the file server. (1.50 KB, application/vnd.oasis.opendocument.presentation)
2006-04-13 15:22 UTC, gnustavo
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description sbbedell 2005-03-27 22:02:30 UTC
Writer corrupts files when the files are saved to disk, when the disk is not in
computer, then you insert the disk and save the document again.

Here are the steps that I did.
1. Create New OOo Document.
2. Type something into the body.
3. Save the file to a floppy disk.
4. Remove the floppy disk.
5. Type some more text into the document.
6. Click Save.

This happened on Windows XP SP2
Comment 1 sbbedell 2005-03-27 22:12:10 UTC
Here is the rest of the original post, Assidently hit sumbit midway throught.

in step 6 once you hit save you will recieve an error saying there is no disk in
the drive, please insert a disk.  Hit Cancel, and you recive another 2 messages:
"Error Saving the document Myfile.odt: A:\Myfile.odt is not ready" and "Error
Saving the document Myfile.odt: General Error. General Input/Output error."

7. Hit Save again, without inserting the disk.
  You will recieve 2 of the A:\Myfile.odt is not ready errors and then another
gereral input output error.
8. Insert the disk.
9. Hit Save
 you will get "Error Saving the document Myfile.odt: Object Not Accessable. The
object can not be accessed due to insufficient user rights."  
10. Close down Writer, I Discarded my changes, when asked.
11. Attempt to open the document.  You will get the filter dialog that lets you
select the document type, that you are opening.  I tried a cople of them and
nothing happened after that.  If I tried to click on the file again, the hour
glass appeard for a second and disapeared and nothing else happened.

I could not open the file at all after this.
Comment 2 michael.ruess 2005-04-03 18:24:19 UTC
Framework issue.
Comment 3 thorsten.martens 2005-07-08 10:59:10 UTC
Comment 4 cristobalmiguelo 2005-07-10 20:31:13 UTC
I followed the exact method that sbbedell described with a USB Flash drive and I
got the same result.  After putting the flash drive back in, it wouldn't SAVE. 
I then tried a Save-as and it then saw the flash drive again, but even though it
saw the flash drive, it still gave the general I/O error.  It was not going to
save to the flash drive.  I did not try renaming the file though.

I then did a save-as to a spot on my hard drive and it saved OK.  Then I opened
up the file and it displayed correctly.

hope this helps.
Comment 5 gnustavo 2006-04-12 21:03:59 UTC
I think the same problem occurs when you are editing a file in a file server and
you lose connection to it.

I tested it on a Windows machine with OOo 2.0.2 editing a file on a remote
Windows server via CIFS.  (I don't know if the problem would occur with a NFS
access.)  I openned an existing presentation and disconnected the network cable
from my desktop.  Then, as I went further down the slides at some time (I think
it was at the first slide containing an image) OOo warned that it couldn't read
the file.

Then I tried to save the presentation in my local hard drive and OOo complained
that it couldn't.  But a small file was created anyway.  The file is small and
corrupted.  I'm going to attach it here.

This problem is particularly bad because the people that complained about it to
me told me that when they have network problems in the middle of a big editing
session they lose all their work since they can't save the file even locally.

Comment 6 gnustavo 2006-04-13 15:22:13 UTC
Created attachment 35681 [details]
Corrupted file created locally by OOo after losing network connection to the file server.
Comment 7 lars 2006-04-13 15:42:33 UTC
I can confirm everything except for the corrupted file. The file was in the 
state it was saved in step 3; nevertheless, confirmed with 680_m162 on WinXP Pro 
Comment 8 danielfl 2006-08-14 19:24:05 UTC
People, IMHO, this is a very IMPORTANT issue, because we lost data often at my 
job (with unstable and old network) and when it happens I can't help the 

Daniel FL