Issue 46305 - Type 1 fonts not subsetted, resulting in huge PDFs on Linux
Summary: Type 1 fonts not subsetted, resulting in huge PDFs on Linux
Status: CLOSED DUPLICATE of issue 30202
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: 680m87
Hardware: All Linux, all
: P3 Trivial (vote)
Target Milestone: AOO PleaseHelp
Assignee: philipp.lohmann
QA Contact: issues@gsl
URL: http://olo.org.pl/files/qa/openoffice...
Keywords:
Depends on:
Blocks: 81913
  Show dependency tree
 
Reported: 2005-03-30 15:07 UTC by olo
Modified: 2009-01-06 14:43 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description olo 2005-03-30 15:07:02 UTC
This has been tested with OpenOffice versions: 1.1.4 and 1.97.87 (680m87
snapshot build) on Mandrake Linux 10.2 (development version - "cooker") and
Fedora Core 3 Linux.

Builtin PDF export in OpenOffice fails to subset Type1 fonts (but succeeds with
TrueType), and instead embeds full fonts in PDF files.

With some Unicode fonts, which contain lots of glyphs for various alphabets (e.g
Nimbus Sans L, Nimbus Roman No9 L), this inflates the size of resulting PDF
files up to hundreds of KB, even for small text-only documents!

I've gathered some testcases here: 
http://olo.ab.altkom.pl/domowa/qa/openoffice/huge_pdfs/

And the whole issue has been recently discussed by many users on OOOforum:
http://www.oooforum.org/forum/viewtopic.phtml?t=16029


Contrary to what has been said in issue 20370, Type 1 fonts are definitely
subsettable - e.g. Ghostscript subsets both TrueType and type 1 when generating
PDFs, and you can see an example of a PDF with subsetted Type 1 and TrueType
fonts here (Ghostscript was the generator):

http://olo.ab.altkom.pl/domowa/qa/openoffice/huge_pdfs/Cwiczenie3_ghostscript.pdf

http://olo.ab.altkom.pl/domowa/qa/openoffice/huge_pdfs/oo_1.1.4_mdk10.2_extendedPDF_using_GhostScript.pdf

A workaround is to print to PostScript and use a converter (e.g. ps2pdf) to
generate PDF files. There is an excellent OpenOffice macro library that adds a
GUI for this operation: it's called extendedPDF, available here:
http://www.jdisoftware.co.uk/pages/epdf-home.php

However, having OpenOffice generate nice PDFs natively would be certainly much
better. Even setting up extendedPDF requires some plumbing experience and is
definitely not for majority of users...
Comment 1 stephan_schaefer 2005-03-31 09:04:10 UTC
->pl: you or hdu ?
Comment 2 philipp.lohmann 2005-04-04 12:23:23 UTC
Type1 fonts are not subsettable for OOo at the moment since we simpy don't have
code that can do that. BTW the same is true for OOo's PostScript output.

Changing type to enhancement, target to later
Comment 3 philipp.lohmann 2009-01-06 14:42:42 UTC
duplicate to issue 30202

*** This issue has been marked as a duplicate of 30202 ***
Comment 4 philipp.lohmann 2009-01-06 14:43:11 UTC
closing