Issue 46347 - Clearer Explaination Needed in the File Associations Dialog during Installation
Summary: Clearer Explaination Needed in the File Associations Dialog during Installation
Status: CLOSED FIXED
Alias: None
Product: Installation
Classification: Application
Component: ui (show other issues)
Version: 680m79
Hardware: PC Windows XP
: P3 Trivial with 9 votes (vote)
Target Milestone: OOo 2.0.2
Assignee: Olaf Felka
QA Contact: issues@installation
URL:
Keywords: oooqa
: 46397 (view as issue list)
Depends on:
Blocks:
 
Reported: 2005-03-31 02:57 UTC by mchase
Modified: 2006-01-19 11:29 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Setup dialog - Association to MSO file types (16.92 KB, application/vnd.sun.xml.writer)
2005-03-31 17:52 UTC, ajpursell
no flags Details
FileTypes Mock-up (10.35 KB, image/gif)
2005-12-14 15:24 UTC, christian.jansen
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description mchase 2005-03-31 02:57:32 UTC
The most frequent complaint seen on the users' lists is "Help! Your program has 
taken over my computer!"  Either the description needs to be made more clear, or 
making OOo the default for MSO file types should be defered until runtime.

Suggested wording from Matt Needles in August 2004: "OpenOffice.org can open MS 
Word, Excel and PowerPoint documents.  Another program is currently assigned 
this task on your system.  Do you want OpenOffice.org to be the default program 
to open these files when you open them from Windows Explorer?  If you choose NO,
you may still open these files from within OpenOffice.org."
Comment 1 Olaf Felka 2005-03-31 06:13:02 UTC
I would like to see this in 'Tools Options'.
Comment 2 dcarrera 2005-03-31 17:39:07 UTC
*** Issue 46397 has been marked as a duplicate of this issue. ***
Comment 3 ajpursell 2005-03-31 17:51:01 UTC
*** Issue 46347 has been confirmed by votes. ***
Comment 4 ajpursell 2005-03-31 17:52:07 UTC
Created attachment 24482 [details]
Setup dialog - Association to MSO file types
Comment 5 ajpursell 2005-03-31 17:53:40 UTC
Please see my remarks and suggested rewording of the dialog which are on issue 46397
Comment 6 ecastro 2005-03-31 17:57:26 UTC
May I suggest that explanation of rationale for change is best in issue 46397?

The wording there is better for absolute beginners used only to Windows, the
problematic target with this issue. If possible, I would suggest to follow
Pursell's rewording.

Comment 7 daemoncat 2005-03-31 18:31:42 UTC
Please include the "If you're just trying out OpenOffic.org, you probably DON'T
want to do this."! I am the only "savvy" user in my office, and I don't don't
dare let anybody update OpenOffice.org on their own just for this reason. If at
all possible, change it before 2.0. I realize that I've just grown used to
carefully reading and considering these sorts of things, but most general users
don't. And for all the "ease of use" of Windows, changing the associations back
is a very challanging task for general users. Thanks.
Comment 8 dcarrera 2005-03-31 18:45:13 UTC
I am tentatively setting the target milestone to 2.0.1 on the basis that the
change is just a text string. But I'm probably missing something. If this is a
mistake, please let me know (and why, so I don't repeat it).
Comment 9 cno 2005-03-31 21:40:44 UTC
Little effort, much to win!
Comment 10 peschtra 2005-03-31 21:44:26 UTC
During installation when the default file association is going to be chosen, if
the wording from the first comment is going to be used, I would change the last
line to:

"If you choose NO, you will still be ablt to open these files from within
OpenOffice.org."

There is not /may/ about it.
Comment 11 dcarrera 2005-03-31 21:52:04 UTC
Just a bit of advice:

People, please discuss this among yourselves first. Agree on precisely the new
wording you want. THEN file a comment. We do not want a discussion on IZ.
Furthermore, no action can be taken on this issue until the proposal is clear.
Please use email until you have a concrete proposal you all agree with.

Cheers,
Daniel.
Comment 12 ajpursell 2005-04-03 16:15:43 UTC
Following Daniel's advice this was put back on the discuss and users list.  As a
result of suggestions received, I have revised the suggested wording to:

--------------
OpenOffice.org x.x.x can be set as the default application to automatically open
the following file types.  This means, for instance, that if you double click on
one of these files, OpenOffice.org will open it, not the progam that opens it now. 

... then after the list of file types and check boxes, add ... 

If you are just trying out Open Office.org, you probably don't want this to
happen, so leave the boxes unchecked.  You can always open these files in
OpenOffice.org, by using 'File >> Open' and browsing to the file you want.
---------------

However, it was suggested that a single string to replace the existing string
might be quicker and easier to implement.  If this is the case, use the following:

-----------------
OpenOffice.org x.x.x can be set as the default application to automatically open
the following file types.  This means, for instance, that if you double click on
one of these files, OpenOffice.org will open it, not the progam that opens it now. 

If you are just trying out Open Office.org, you probably don't want this to
happen, so leave the boxes unchecked.  You can always open these files in
OpenOffice.org, by using 'File >> Open' and browsing to the file you want.

... then the list of file types and check boxes. 
-------------------


Comment 13 bettina.haberer 2005-08-15 13:15:29 UTC
We should have a closer look at this dialog and do some rework on it for OOo
2.0.2. Christian, as far as I know, you were involved in the theme installation.
Could you please take over this issue to your ownership for a possible rework?
Thank you.
Comment 14 christian.jansen 2005-12-09 13:11:12 UTC
accepted
Comment 15 christian.jansen 2005-12-14 15:23:12 UTC
In OO.o 2.02 we should revise the description. In OO.o 3.0 we should allow users
to set the file type also in Tools/Options.

CJ -> IS/All:
These are the string which I propose. The example shall explain users the
effects of the settings. I've also attached a mock-up, showing the changes.

GER:
Wählen Sie die Dateitypen aus, die mit %PRODUCTNAME standardmäßig geöffnet
werden sollen.

%PRODUCTNAME kann als Standard-Applikation für die weiter unten aufgelisteten
Dateitypen festgelegt werden.

Zum Beispiel: Sie haben ausgewählt, das Microsoft Word Dateien standardmäßig mit
%PRODUCTNAME geöffnet werden. Wenn Sie eine Microsoft Word Datei in einem Ordner
per Doppelklick öffnen wird diese Microsoft Word Datei in %PRODUCTNAME geöffnet.


EN:
Select the file types for which you want %PRODUCTNAME to be the default application.

%PRODUCTNAME can be set as the default application to open the file types listed
below.

For Example: You have selected Microsoft Word files to be opened by default by
%PRODUCTNAME. When you double-click any Microsoft Word file from a file folder
%PRODUCTNAME will open the file automatically.
 
Comment 16 christian.jansen 2005-12-14 15:24:56 UTC
Created attachment 32399 [details]
FileTypes Mock-up
Comment 17 christian.jansen 2005-12-14 15:25:45 UTC
Reassigned to IS.
Comment 18 ajpursell 2005-12-15 00:29:16 UTC
You have substancially changed the wording I agreed with people on the users and
discuss lists.  As a result, I think it is less clear what the effect of
selections on this screen will be.  In particular, I would say:

1) Not everyone fully understands the implications of the term "default
application".  That is why I put the explanation "This means, for instance, that
if you double click on one of these files, OpenOffice.org will open it, not the
progam that opens it now" immediately after the first sentence.

2) Most of the angry complaints on the users list came from people who were just
trying out OO.o.  That is why the last two sentances, begining "If you are just
trying out Open Office.org..." were included.  You have left this out.  Perhaps
you think it was in some way 'unprofessional' to include it.  Pehaps not
appropriate to Star Office?  I think it is very appropriate to Open Office if we
are not to lose good will from this type of new user.

3) Finally, the wording after 'For instance:' is not good English.  It needs to
be "When you double-click a Microsoft Word file from a file folder,
%PRODUCTNAME will open the file automatically, if you have selected %PRODUCTNAME
 as the default application for Microsoft Word files."
Comment 19 ingo.schmidt-rosbiegal 2005-12-22 13:53:39 UTC
IS -> CJ: This needs probably further discussion.
Comment 20 christian.jansen 2006-01-04 17:26:26 UTC
CJ -> ajpursell: We can go with your version, but I recommend to shorten it.
Please have a look at the new version suggested below. Thanks.

CJ -> IS: I to reassign this issue to you, because I'll not be available in the
next days.

EN:
Select the file types for which you want %PRODUCTNAME to be the default application.

%PRODUCTNAME can be set as the default application to open the following file
types. This means, for instance, that if you double click on one of these files,
OpenOffice.org will open it, not the progam that opens it now.

List of boxes...


If you are just trying out %PRODUCTNAME, you probably don't want this to happen,
so leave the boxes unchecked.

DE:
Wählen Sie die Dateitypen aus, die mit %PRODUCTNAME standardmäßig geöffnet
werden sollen.

%PRODUCTNAME kann als Standard-Program für die unten aufgelisteten Dateitypen
festgelegt werden. Das bedeutet das Dateien dieses Typs, wenn zum Beispiel durch
einen Doppelklick geöffnet, von jetzt an mit %PRODUCTNAME geöffnet werden. 
Falls Sie %Productname ausprobieren, sollten die vorgeschlagenen Einstellungen
nicht verändert werden.

List of boxes...
Comment 21 ajpursell 2006-01-04 21:00:03 UTC
ajpursell -> cj/IS I think your shortened wording fully covers the issues that
the original discussions were about. I am most happy with it.  No doubt, there
will be a few questions on the users list along the lines of 'Now I have got
OOo, how can I open Word files' but that is better than the anger of people who
complain 'OOo has taken over my computer!' I will look forward to the 2.0.2 install.
Comment 22 Olaf Felka 2006-01-05 11:56:19 UTC
For German we have discussed and decided to shorten the text:
DE:
Wählen Sie die Dateitypen aus, die mit %PRODUCTNAME standardmäßig geöffnet
werden sollen.

%PRODUCTNAME kann als Standard-Program für die unten aufgelisteten Dateitypen
festgelegt werden. Das bedeutet, dass Dateien dieses Typs von jetzt an mit
%PRODUCTNAME geöffnet werden. 
Falls Sie %Productname ausprobieren, sollten die vorgeschlagenen Einstellungen
nicht verändert werden.
We know, that this text differs from the english text, but we haven't found a
meaningfull wording that sound fine.
Comment 23 ingo.schmidt-rosbiegal 2006-01-05 14:30:40 UTC
Fixed in cws native35.
Comment 24 ingo.schmidt-rosbiegal 2006-01-05 14:33:19 UTC
IS -> OF: Please verify

re-open issue and reassign to of@openoffice.org
Comment 25 ingo.schmidt-rosbiegal 2006-01-05 14:37:06 UTC
reassign to of@openoffice.org
Comment 26 ingo.schmidt-rosbiegal 2006-01-05 14:39:29 UTC
reset resolution to FIXED
Comment 27 Olaf Felka 2006-01-05 16:03:16 UTC
OF: Verified in cws native35.
Comment 28 Olaf Felka 2006-01-19 11:29:26 UTC
Looks good in m150.