Issue 46680 - Superfluous request of JRE in Tools > Macros
Summary: Superfluous request of JRE in Tools > Macros
Status: CLOSED DUPLICATE of issue 37020
Alias: None
Product: General
Classification: Code
Component: scripting (show other issues)
Version: 680m87
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: OOo 2.0
Assignee: joachim.lingner
QA Contact: issues@framework
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2005-04-05 09:41 UTC by bmarcelly
Modified: 2005-05-31 08:52 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description bmarcelly 2005-04-05 09:41:52 UTC
Steps to reproduce
- Disable JRE in Tools > Options.
- Open Tools > Macros > Run Macros... or Tools > Macros > Organize Macros.
- You receive about 10 - 15 error messages, answer No to each, then the final panel 
opens and you can still launch your Basic or Python macro !

These warning messages should not be displayed at all and Java should not be used if 
the user wants to start or work on Basic or Python macros. If JRE is not enabled you 
are simply unable to find Java, Beanshell, Javascript macros.
(I am surprised that Javascript macros depend on Java ?)
Comment 1 bmarcelly 2005-04-08 14:06:57 UTC
Test with 1.9m91
- Same error messages with Tools > Macros > Run Macros...
- All correct, no error messages with Tools > Macros > Organize Macros

- here is another case (could be present in earlier versions) : 
Customize Toolbars > Add commands > Click on "OpenOffice.org Macros" in left side of 
the panel.
You get 6 consecutive error messages, then you can select a Basic macro.
Comment 2 bmarcelly 2005-04-09 09:44:25 UTC
Just to complete the picture...

- Writer : insert a picture, then click Picture button on the Picture toolbar. Click 
on the Macro tab of the panel. You have to answer 15 times No, then you can assign a 
Basic macro.

- Writer : menu Format > Character. Click on the Hyperlink tab of the panel. You have 
to answer 15 times No, then you can assign a Basic macro.

Tested on 1.9m91.
Comment 3 rvojta 2005-04-23 17:41:13 UTC
Same for Linux, lot of warnings when JRE is disabled.
Comment 4 tony.galmiche.ooo 2005-04-25 16:11:47 UTC
CAN REPRODUCE  with Win NT OS and m95 release.
Comment 5 rvojta 2005-05-06 12:20:01 UTC
It looks like that this Issue is already fixed. I tried this
with m97 and ooo-build (m100) and it works perfectly. No more
warnings ...
Comment 6 bmarcelly 2005-05-06 13:19:42 UTC
No, rvojta.
I just tried with 1.9.100 on Win XP with JRE disabled.
Same warning messages on Tools > Macros > Run macros...
Same warning messages when Customizing toolbar to add a macro
Same warning messages whith Writer > insert a picture > click Picture button on the 
Picture toolbar > Click on the Macro tab of the panel.
  (tests are not exhaustive)
Granted, no more messages for Tools > Macros > Organize Macros > OpenOffice.org Basic..
.
Comment 7 rvojta 2005-05-06 13:36:54 UTC
Hmm, you're right ... I tried again and it doesn't work, dialog
back ...
Comment 8 joachim.lingner 2005-05-09 09:54:51 UTC
The "Run Macro" and "Organize Macros" menu entries use the scripting framework
which is partly implemented in Java. Without it only Basic would work. If you
want the same functionality and do without Java then you need to reimplement the
respective Java services in C++. But if you are just annoyed by the messagebox
popping up again and again then this is a different matter for which there is
already issue  37020.

bmarcelly please decide what exactly is the issue here.
Comment 9 bmarcelly 2005-05-09 14:08:38 UTC
In OOo 1.1 it is not necessary to have the JRE to run OOo Basic macros, or attach 
Basic macros to a picture, or to a Toolbar button, or to an hyperlink.

In OOo 1.9 it is still not necessary to have the JRE to do all this BUT the user will 
be bothered by numerous stupid messages. Even one warning message would not be 
acceptable, because in fact JRE is not necessary even with the current design. Is it 
so difficult to simply squeeze these messages and continue?
The same useless messages appear if the user wants to run a Python macro.

It is not a problem of switching off the JRE option, it is that a lot of users simply 
don't have the JRE and don't want to have it (they have old PC with few memory or they 
can't download JRE or they dislike it).

The fact that, after numerous warning messages, you are nevertheless able to do what 
you want without JRE, could be assimilated to obtrusive popup advertisements from Sun 
marketing.
I prefer to consider this as faulty design.

Even with JRE, the first time you open Tools > Macros > Run Macros the panel show 
after a delay inexistent in OOo 1.1. This is because Java has to be needlessly loaded.

So the bottomline is : it should be possible to run Basic or Python macros without JRE 
and without any JRE warning message. Just like OOo 1.1.
Comment 10 Martin Hollmichel 2005-05-09 14:48:19 UTC
mh->jl: as agreed, we need to reduce ammount of box to one per user action
Comment 11 joachim.lingner 2005-05-19 11:38:31 UTC
.

*** This issue has been marked as a duplicate of 37020 ***
Comment 12 joachim.lingner 2005-05-31 08:52:45 UTC
closing because this is a duplicate issue