Issue 4706 - does not start up if /etc/printcap not found
Summary: does not start up if /etc/printcap not found
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: philipp.lohmann
QA Contact: issues@ui
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-05-09 23:00 UTC by nephros
Modified: 2003-03-12 14:33 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description nephros 2002-05-09 23:00:25 UTC
sorry if I got the wrong category, "ui" was the closest IMO.

I recently upgraded from RedfHat 7.1 to 7.3.
I do not own a printer, so I removed all printing-related packages (except for LPRng, which is 
needed by some other packages.).
Thus, /etc/printcap was renamed by the RPM Package Manager.

OpenOffice.org 1.0 was installed before the upgrade and ran fine, When I started it with the 
file missing, it produced this error:
Read_file_list: cannot stat required or included file '/etc/printcap' - No such file or directory
sh: lpc: command not found
Read_file_list: cannot stat required or included file '/etc/printcap' - No such file or directory

renaming the old printcap.rpmsave to printcap fixes this. Providing an empty file does too.

running /usr/sbin/lpc gives the same error, so it is really a problem with this, but IMO 
OpenOffice should start even if there is no printing service... 

my guess was something in the scripts going wrong, but a fgrep "lpc" only returned matches 
in some binaries, and I know nothing about debugging, so I could not dig deeper. 
It is also not really a big problem, but I submitted it because I think it will seldomly be 
triggered, as there are not much UNIXes without /etc/printcap...

That said, overall this thing is working wonderfully, thanks to all the ppl working on it!
Greets, 
      Peter


my system info, just for the record:

Intel Celeron/700 (clocked after intel specs at 788MHz)
196MB RAM
RedHat 7.3 with minor upgrades from third-party RPMs

OpenOffice.org 1.0 installed from 
http://gd.tuwien.ac.at/office/openoffice/1.0.0/OOo_1.0.0_LinuxIntel_install.tar.gz

/root# uname -s -r
Linux 2.4.18
/root# ldconfig --version
ldconfig (GNU libc) 2.2.5
Copyright (C) 2002 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Andreas Jaeger.
/root# gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.3 2.96-110)
/root# X -version 2>&1 | head -n2
XFree86 Version 4.2.0 (Red Hat Linux release: 4.2.0-8) / X Window System
Comment 1 Oliver Specht 2002-05-13 08:32:59 UTC
Reassigned to PL
Comment 2 philipp.lohmann 2002-05-17 15:58:52 UTC
I can reproduce the behaviour of lpc and lpstat. If i start OOo1.0 the
error message appears on the shell. But it does not hang. Are there
any other circumstances relevant here ?
Comment 3 nephros 2002-05-17 16:36:27 UTC
marked as invalid.

It now works again for me.

I had a older (and unfinished!) installation lying around in 
/usr/local/StarOffice/OpenOffice (sic!), which had a soffice symlink in /usr/local 
bin.

1.0 is installed in my home dir, and is "later" in the $PATH.

My roommate also has root access (it is a server machine), and he tried to intall 
it, but failed. I did not check the version of that old install, and it is removed now.

Sums up to: Bogus install, my fault. 
__Sorry_for_wasting_your_time__
Comment 4 michael.bemmer 2003-03-12 14:14:39 UTC
As mentioned on the qa dev list on March 5th I will close all resolved
<wontfix/duplicate/worksforme/invalid> issues. Please see this posting for
details. First step in IssueZilla is unfortunately to set them to verified.
Comment 5 michael.bemmer 2003-03-12 14:15:09 UTC
As mentioned on the qa dev list on March 5th I will close all resolved
<wontfix/duplicate/worksforme/invalid> issues. Please see this posting for
details. First step in IssueZilla is unfortunately to set them to verified.
Comment 6 michael.bemmer 2003-03-12 14:33:33 UTC
As mentioned on the qa dev list on March 5th I will close all resolved
<wontfix/duplicate/worksforme/invalid> issues. Please see this posting for details.