Issue 47142 - font size 10,5 shown as 10 (in combo box) when selected
Summary: font size 10,5 shown as 10 (in combo box) when selected
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 2.0 Beta
Hardware: All Windows XP
: P3 Trivial with 11 votes (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords: oooqa
: 47208 47849 52155 54466 55465 62451 63185 (view as issue list)
Depends on:
Blocks:
 
Reported: 2005-04-11 11:27 UTC by gonzalez
Modified: 2013-08-07 14:40 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
two lines to improve the font size control (1.43 KB, text/plain)
2006-02-07 09:51 UTC, Oliver Specht
no flags Details
look like of MS (11.67 KB, image/png)
2006-02-10 01:34 UTC, jlcheng
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description gonzalez 2005-04-11 11:27:43 UTC
When you select font size 10,5 this number is not shown in the combo box in the
"Formatting" toolbar; it is shown as font size 10 even if your text is rightly
sized to 10,5.
It is not a big problem but it is very confusing, can lead to errors, and gives
a bad impression about the (actually excellent!!) quality of OpenOffice.
Font size 10,5 is very useful for Times Roman (font and size common in books).
Comment 1 michael.ruess 2005-04-11 14:36:55 UTC
Reassigned to US.
Comment 2 flibby05 2005-05-10 15:52:04 UTC
confirm with m100 on win98 SE
Comment 3 flibby05 2005-05-15 18:25:35 UTC
*** Issue 47208 has been marked as a duplicate of this issue. ***
Comment 4 ulf.stroehler 2005-05-30 13:16:59 UTC
Set target.
Comment 5 lohmaier 2005-07-10 23:52:01 UTC
*** Issue 47849 has been marked as a duplicate of this issue. ***
Comment 6 waustin 2005-07-11 12:38:56 UTC
The bug is that only integer sizes are displayed in the size box.

This can lead to human errors and confusion - it would probably be better to
show integer point sizes as integers and decimal sizes as decimals.

To demonstrate the problem, create a writer document and put a small amount of
text on a line, then make 10 copies of the line for 11 consecutive lines 
containing the same text. Set sizes on these lines at 6, 6.1, 6.2, ..., 6.9, 
and 7 pt type (increment 0.1 pt each line). Finally, blow the whole display up 
to 600%.  (The small text size isso that (a) there can be many characters on a
line, for greater visibility, and (b) because the smaller the base size, the
larger the apparent difference between size [% change]).

Clearly there is a slight stair-step increment in line lenght between most but 
not all of the lines, but it is somewhat irregular and *appears* to depend on 
the font metrics themselves.  For instance with one fonts ("courier new"), the 
6.5pt line actually appears to be shorter than the 6.4pt line.

Printing the pages out is the acid test to verify the above, and with most 
fonts - I tried Times, Times New Roman, Courier, Helvetica, Arial - there is a 
stair stepping effect but typically the stepping is such that there will be 
many pairs of lines with the same printed length, then another pair slightly 
longer, then another pair slightly longer, then ... It really appears to 
depend on font (and printer?) metrics.
Comment 7 serhiykuznyetsov 2005-07-11 16:49:38 UTC
confirmed with 1.9.109 on MandrivaLinux 2005 LE and WinXP SP2
Comment 8 lohmaier 2005-07-20 18:10:53 UTC
*** Issue 52155 has been marked as a duplicate of this issue. ***
Comment 9 gonzalez 2005-08-03 20:42:59 UTC
Now, in OOo 1.9.122 the situation has WORSENED: there is no 10,5 size anymore
but 105 (between 10 and 11)!! And you really get size 105 instead of 10,5!!
Comment 10 gonzalez 2005-08-03 22:02:05 UTC
Here, again: I have restarted OOo and I can see fontsize 10,5 in the combo box
again. So, the defect is  now so as it was earlier (but,I do not understand at
all why fontsize 105 appeared between 10 and 11; I hope it does not hapen again).
Comment 11 johnwhardy 2005-09-04 00:08:33 UTC
You can type "10.5" in the combo box, then hit Enter to apply the size, and the
10.5pt size will be properly applied to your document, but the combo box will
change its displayed size so that only the integer portion of the size ("10") is
shown in the combo box.

But it may be a bit more comlicated than the combo box simply reverting to the
integer-portion display: If you type "5.9" and hit Enter, the combo box will
display "5". If you type "5.99" and hit Enter, the combo box will display "6".
Comment 12 lohmaier 2005-09-12 21:25:55 UTC
*** Issue 54466 has been marked as a duplicate of this issue. ***
Comment 13 lohmaier 2005-10-04 22:22:08 UTC
*** Issue 55465 has been marked as a duplicate of this issue. ***
Comment 14 johnwhardy 2005-10-22 05:02:56 UTC
This issue still exists in the official 2.0 version of OO.

Another variation: Do a right-mouse-button click in Writer and choose the
Character menu item. Then enter a font size of 22.9, then hit Enter (or OK). If
you return to this window, the size will be displayed as 22.8, not 22.9. And
forget about trying a size with TWO digits to the right of the decimal place!

Somebody needs to clean up the Font Size code. This is fundamental and essential
stuff, and it's broken. We need to know EXACTLY what the font size is. Is
anybody  listening?? Hello??
Comment 15 carsten.driesner 2005-11-09 12:34:24 UTC
cd->os: Please take over. You can ask me, if you need help.
Comment 16 pavel 2005-12-23 18:43:47 UTC
this is prio 3 IMO.

os: can you please evaluate how much work it is?
Comment 17 martinkozak 2006-02-06 13:47:38 UTC
OS: What is state of this issue? Can you evaluate, how much work it is, please?
--
Martin Kozák
CS User Support Leader
Comment 18 Oliver Specht 2006-02-07 09:48:46 UTC
It's a two-line-change. 
patch to-be-attached
Comment 19 Oliver Specht 2006-02-07 09:51:25 UTC
Created attachment 33908 [details]
two lines to improve the font size control
Comment 20 pavel 2006-02-08 07:55:31 UTC
os: thanks for it.

I'll add it to community builds so people can verify it. It will be in community
SRC680_m156 for testing.
Comment 21 jlcheng 2006-02-10 01:26:27 UTC
OK, the tbcontrl.diff is very great, and if you see MS Office(zh-CN), the size
of font has L10N name(Chinese). If OOo can do this like MS Office, OOo will be
more great.
Comment 22 jlcheng 2006-02-10 01:34:28 UTC
Created attachment 34030 [details]
look like of MS
Comment 23 gonzalez 2006-02-11 20:27:05 UTC
There is no change in OOo 2 dev - Build 2.0.m156
Comment 24 pavel 2006-02-12 15:26:43 UTC
gonzales: yes, it is not in Sun's m156. I wrote this:

> I'll add it to community builds

So did I and community m156 contains this fix. So it works.

os: thanks!
Comment 25 pavel 2006-02-12 17:02:35 UTC
jlcheng: your problem is different to this one, please file separate issue.
Comment 26 Oliver Specht 2006-03-09 19:35:27 UTC
*** Issue 62451 has been marked as a duplicate of this issue. ***
Comment 27 Oliver Specht 2006-03-10 08:25:01 UTC
Fixed in cws os78 in
svx/source/tbxctrls/tbcontrl.cxx
Comment 28 hwoarang 2006-03-15 01:38:05 UTC
*** Issue 63185 has been marked as a duplicate of this issue. ***
Comment 29 Oliver Specht 2006-03-15 08:39:54 UTC
Reassigned for verification

re-open issue and reassign to hi@openoffice.org
Comment 30 Oliver Specht 2006-03-15 08:40:02 UTC
reassign to hi@openoffice.org
Comment 31 Oliver Specht 2006-03-15 08:40:09 UTC
reset resolution to FIXED
Comment 32 h.ilter 2006-03-21 13:47:12 UTC
Verified with cws os78 = ok
Comment 33 h.ilter 2006-05-11 16:25:40 UTC
Verified with 680m168 = ok