Issue 47252 - table pilot: unable to create "auto value" primary for HSQLDB databases
Summary: table pilot: unable to create "auto value" primary for HSQLDB databases
Status: CLOSED DUPLICATE of issue 48480
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: 680m92
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: OOo 2.0.1
Assignee: berend.cornelius
QA Contact: issues@dba
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-12 13:45 UTC by Frank Schönheit
Modified: 2006-05-31 14:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Frank Schönheit 2005-04-12 13:45:54 UTC
- open an arbitrary HSQLDB database
- create a new table with the table auto pilot
- on the third page of the pilot, let it create a primary key, and check the
"Auto value"
  checkbox
- finish the wizard
=> error message: "Unexpected token: AUTO_INCREMENT in statement [CREATE
   TABLE ..."

fs->bc: please contact oj about how to fix this. I suppose you need to evaluate
a database-specific setting which tells you the exact syntax for creating auto
increment columns.
Comment 1 berend.cornelius 2005-05-27 14:59:55 UTC
BC: According to OJ fixed for OOo 2.01
If the AutoIncrement Statement of the AutoValue field is set to "IDENTITY" it
works well.

*** This issue has been marked as a duplicate of 48480 ***
Comment 2 berend.cornelius 2006-04-07 10:46:59 UTC
bc: verified again in src680 m162 master: Issue is closed