Issue 47688 - Cannot remove last version in versions dialog
Summary: Cannot remove last version in versions dialog
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: 680m90
Hardware: PC All
: P3 Trivial with 9 votes (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords:
: 55623 58037 59865 60423 66883 69908 (view as issue list)
Depends on:
Blocks:
 
Reported: 2005-04-18 22:59 UTC by datel
Modified: 2013-08-07 14:42 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description datel 2005-04-18 22:59:54 UTC
In 1.9.90.1cs (as well as older version) I get a weird behavior on attempt to
remove the last item in versions dialog:

 - if there has been only one version, it remains there and with every attempt
to remove it window title is extended by the titles original value (repeats itself).
 - if there have been more version, all the previously deleted ones reappear.

The only way to get rid of all version from a file seems to be using "Save
As..." and saving under another filename.

This bug(?) actually doesn't seem to be only word processor specific.

With the package size and all conversion work RPM format means to me I was not
able to test and confirm this on many version, different languages. Someone else
may might be able to.
Comment 1 michael.ruess 2005-04-19 07:08:55 UTC
Reassigned to HI.
Comment 2 h.ilter 2005-04-19 11:21:14 UTC
Steps to reproduce:
- New writer doc
- Type some text and save the document
- Menu File -  Versions...
- Enable heck box - "Always save a version on closing"
- Confirm with ok and close document over File menu
- Answer the following question with yes
- Reopen document and go to the Versions... dialog
- Click on delete button
-> Version will not removed and the file name on title will added each time you
click on delete button.
Comment 3 paul.m.nz 2005-05-22 20:30:10 UTC
I've found another bug related to this one where there is no new version created
even though 'create new version on closing' is selected. Will raise new bug.

/paul
Comment 4 Mathias_Bauer 2005-05-23 08:41:54 UTC
But please check issue 30015 before doing this, maybe that's already what you
wanted to report.
Comment 5 Mathias_Bauer 2005-05-23 14:50:56 UTC
We already have too much issues for the next micro release -> set to "Later".
Comment 6 paul.m.nz 2005-05-23 21:15:22 UTC
issue 30015 is the same... ignore my comments
Comment 7 aziem 2005-10-08 04:52:30 UTC
*** Issue 55623 has been marked as a duplicate of this issue. ***
Comment 8 h.ilter 2005-11-17 10:49:19 UTC
*** Issue 58037 has been marked as a duplicate of this issue. ***
Comment 9 h.ilter 2006-01-04 09:54:02 UTC
*** Issue 59865 has been marked as a duplicate of this issue. ***
Comment 10 h.ilter 2006-01-12 15:29:44 UTC
*** Issue 60423 has been marked as a duplicate of this issue. ***
Comment 11 1251234125 2006-01-12 15:46:14 UTC
Bug confirmed with Version 2.0.1 
Comment 12 1251234125 2006-01-12 15:53:40 UTC
Bug confirmed with Version 2.0.1 
Comment 13 h.ilter 2006-07-12 13:37:16 UTC
*** Issue 66883 has been marked as a duplicate of this issue. ***
Comment 14 pb 2006-07-27 14:23:27 UTC
pb: I will take over.
Comment 15 pb 2006-07-27 14:25:16 UTC
pb: will be fixed with a flag on SfxMedium_Impl.
Comment 16 pb 2006-07-27 14:43:08 UTC
pb: fixed in cws pb17.
Files changed:
/sfx2/inc/docfile.hxx 1.51.58.1
/sfx2/source/doc/docfile.cxx 1.181.18.1
/sfx2/source/dialog/versdlg.cxx 1.11.58.1

Comment 17 pb 2006-08-01 12:47:28 UTC
pb: one more fix.
/sfx2/source/doc/docfile.cxx 1.181.18.2
Comment 18 pb 2006-08-02 07:46:40 UTC
pb -> hi: please verify, thx.
Comment 19 h.ilter 2006-08-02 22:23:47 UTC
Verified with cws pb17 = ok
Comment 20 h.ilter 2006-08-16 15:25:55 UTC
Still ok in 680m181.
Comment 21 h.ilter 2006-09-27 12:59:51 UTC
*** Issue 69908 has been marked as a duplicate of this issue. ***