Issue 47763 - html filter asyncronous implementation can lead to crash
Summary: html filter asyncronous implementation can lead to crash
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: 680m93
Hardware: All All
: P3 Trivial (vote)
Target Milestone: OOo 3.0
Assignee: h.ilter
QA Contact: issues@framework
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-19 17:14 UTC by mikhail.voytenko
Modified: 2009-07-20 15:56 UTC (History)
1 user (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Patch for HTML filter in Writer (5.10 KB, text/plain)
2008-06-18 17:10 UTC, Mathias_Bauer
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description mikhail.voytenko 2005-04-19 17:14:17 UTC
The problem is that in case of loading of html document the filter works
asyncronously, so the scrypting for example could dispose the document before it
is loaded completely. Adjusting the implementation of the loading process in the
way that it supports asyncronous loading is questionable since there is only one
such filter. It might make more sence to let the filter work syncronously.
Comment 1 mikhail.voytenko 2005-05-23 16:13:59 UTC
Changing the target.
Comment 2 Mathias_Bauer 2008-06-18 17:07:31 UTC
When checking all HTML related issues I've found this one - I assume it exactly
describes a side effect of the problem you wanted to fix.
Comment 3 Mathias_Bauer 2008-06-18 17:10:59 UTC
Created attachment 54574 [details]
Patch for HTML filter in Writer
Comment 4 tkr 2008-06-20 08:01:29 UTC
patch integrated in cws ab53 - fixed
Comment 5 ab 2008-06-27 08:45:19 UTC
ab->hi: As discussed with tkr, please verify in ab53
Comment 6 h.ilter 2008-07-02 13:37:06 UTC
Verified together with TKR = OK
Comment 7 thorsten.ziehm 2009-07-20 15:56:24 UTC
This issue is closed automatically and wasn't rechecked in a current version of
OOo. The fixed issue should be integrated in OOo since more than half a year. If
you think this issue isn't fixed in a current version (OOo 3.1), please reopen
it and change the field 'Target Milestone' accordingly.

If you want to download a current version of OOo =>
http://download.openoffice.org/index.html
If you want to know more about the handling of fixed/verified issues =>
http://wiki.services.openoffice.org/wiki/Handle_fixed_verified_issues