Issue 48020 - COUNTIF criteria wildcards do not work
Summary: COUNTIF criteria wildcards do not work
Status: CLOSED DUPLICATE of issue 32344
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 2.0 Beta
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-23 16:06 UTC by navvy
Modified: 2005-04-25 10:25 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description navvy 2005-04-23 16:06:58 UTC
Excel allows wildcards to be used as criteria in COUNTIF function.  For 
example, ??* will count any cell with two or more letters.

Open Office gives a zero result, while Excel works correctly.

Fault is still present on version 1.9.93

I need to share files with an Excel user, so I can't just change the formula.
Comment 1 frank 2005-04-23 18:21:43 UTC
This is a double to Issue 32344

*** This issue has been marked as a duplicate of 32344 ***
Comment 2 frank 2005-04-23 18:22:04 UTC
closed double
Comment 3 watersrw 2005-04-23 18:24:19 UTC
No, its not a double - this is what I got on the other issue when I suggested it
was:

Watersrw,

This is not about the "Search & Replace" functionality, but the wildcards that
some spreadsheet  functions may take as arguments, producing different results
when executed in different applications.

Eike
Comment 4 frank 2005-04-25 08:12:19 UTC
If Issue 32344 does not fit, Issue 40024 will.

Frank
Comment 5 navvy 2005-04-25 10:25:32 UTC
Issue 32344 seems more appropriate.  The problem is Excel formulas that do not 
give the correct result in Open Office.  

When I open an Excel spreadsheet in Open Office, I need to either get the 
correct results or to get a message warning that some cells contain formulas 
that cannot be handled correctly.  Open Office does neither.