Issue 48130 - OOo seems to hang on saving, useless progress bar
Summary: OOo seems to hang on saving, useless progress bar
Status: CONFIRMED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 680m95
Hardware: All All
: P4 Trivial (vote)
Target Milestone: AOO Later
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: needmoreinfo, oooqa
Depends on:
Blocks:
 
Reported: 2005-04-25 17:33 UTC by Matthias Basler
Modified: 2013-02-07 21:58 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Matthias Basler 2005-04-25 17:33:27 UTC
I loaded an older OOo1.3 document into OOo1.9.95, my diploma thesis with 96
pages, lots of graphics, images and formulae. (The document behaved quite
"sluggish" for the first minute with lots of processor work going on. But that's
maybe another issue.)
After doing minor changes I tried saving the document to .odt. After having
confirmed the new file name, OOO hangs for about 40 seconds (and I have quite an
up-to-date Centrino1.3 GHz!). Just after that, the progress bar appears, doing
the progress from 0 to 100 in about three seconds. After that OOo hangs for 6
more seconds (writing the file to disk).

My points are:
- Giving no feedback and playing "dead" for over half a minute is not a good
behaviour, no matter how big the documents are.
- Given the above, the progress bar is rather useless. I don't know what it
shows, but it is definitely not an indicator for the remaining time of the
saving process or an activity indicator.
Comment 1 kb0000 2005-05-12 21:41:00 UTC
i can confirm with 1.9.100 on linux (FC3)
running a PIII 900MHz with 512 MB RAM, it took around one minute of disk
read/write before it began to save.

i had a 60 pages document in sxw format that i saved as a in the odt format.
Comment 2 thorsten.martens 2005-07-06 13:27:59 UTC
TM->matthiasbasler: Can you please provide the/a document which causes those
problems ? Are you saving the new doc on the local hard disc or on a network
volume ?
Comment 3 Matthias Basler 2005-07-10 21:11:20 UTC
matthiasbasler->TM:
Can I send you the document personally? I don't want it published here.

The doc is 1.3 MB (as .sxw), and the figures given are the same even without the
images (which are linked to, not inline). I was saving the doc to the local
harddisk. The problem is still the same in OOo1.9.109.
Comment 4 thorsten.martens 2005-07-19 14:16:12 UTC
TM->matthiasbasler: You got mail ;o)
Comment 5 hwoarang 2006-05-17 00:55:24 UTC
This one still in progress ??

Hwoarang
Comment 6 hwoarang 2006-07-01 22:54:40 UTC
Reporter, can you reproduce with newer version ?

Hwoarang
Comment 7 Matthias Basler 2006-07-02 14:25:44 UTC
Yes, with OOo2.0.2 on WinXP SP2 the behaviour is still exactly as desribed.
I'll update the issue's version to reflect this.
Also I'll set this confirmed and OS:All, since kb0000 could obviously reproduce
it under linux.
Comment 8 hwoarang 2006-07-02 16:54:00 UTC
Ok. 
But next time don't change "Version" value. Stay with first version that you
found the problem.

Thank you.

Hwoarang
Comment 9 ace_dent 2008-05-15 00:13:28 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please re-test with one of the latest versions of OOo -
the problem(s) may have already been addressed. Either use the recent stable
version: http://download.openoffice.org/index.html
or consider trying the new OOo 3 BETA (still in testing):
http://download.openoffice.org/3.0beta/

Please report back the outcome so this Issue may be closed or progressed as
necessary - otherwise it may be Resolved as Invalid in the future. You may also
wish to search for (and note) any duplicates of this Issue that may have
advanced further :
http://www.openoffice.org/issues/query.cgi

Many thanks,
Andrew

Cleaning-up and Closing old Issues as part of:
~ The Grand Bug Squash, pre v3 ~
Comment 10 Matthias Basler 2008-05-15 18:39:35 UTC
Retested with OOO2.4.0 (German).
The issue remains unchanged, both for saving to ODT and the old SXW.