Issue 48167 - ppt file shown wrongly in OO1.1.4 and OO1.9.95 -- but differently
Summary: ppt file shown wrongly in OO1.1.4 and OO1.9.95 -- but differently
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Impress
Classification: Application
Component: viewing (show other issues)
Version: OOo 2.0 Beta
Hardware: PC (x86_64) Linux, all
: P3 Trivial with 4 votes (vote)
Target Milestone: ---
Assignee: christian.guenther
QA Contact: issues@graphics
URL: http://www.cs.bham.ac.uk/~axs/phw-gc7...
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-26 09:30 UTC by axs
Modified: 2013-08-07 15:21 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description axs 2005-04-26 09:30:07 UTC
Congratulations on a great product. However....
I have permission to report a fault involving the powerpoint file accessible
here http://www.cs.bham.ac.uk/~axs/phw-gc7-18-04-2005.ppt
but the file should not be used for any other purpose please. It is not mine.

Its owner wants to switch to OO on Linux but is deterred by compatibility
problems, as illustrated in this powerpoint file.

A. Viewing in OO 1.1.4
When displayed (even using the msttcorefonts) in OO 1.1.4 -- the best ever
version of OpenOffice -- the text on the first slide (using Arial Narrow) does
not fit into the viewing area, and other slides are not displayed properly
unless I reduce the font size on that slide by several points. I have to reduce
the header from 54 to 44, and the bottom line from 32 to 28pt.

If I reduce those point sizes on slide 1 the rest of the file seems to work.

However bullets come out as hollow boxes instead of solid diamonds -- a minor flaw.

Why can't the reduction to fit be done automatically when the slide does not
fit? (I have had this sort of problem with some fonts being displayed too large
and screwing up formatting in all previous versions of OO.)

The 'pi' character is not displayed properly on slides 2 and 3 (too small and
colours displaced), though it is better on slide 4. It is generated correctly in
 the PDF version.

I think everything else in this file works in 1.1.4, though I have not checked
every detail.

B. Viewing in OO 1.9.95
Using the OO 2.0 beta (1.9.95) things are much worse -- it is basically unusable.

The slides fit into the viewing area OK, but many of the bullet points simply do
not show up in slideshow mode when I click, even though they show up if I create
a pdf file and view in xpdf. Examples are bullet points 1, 3 and 4 on slide 2:
the bullets show, but not the tex. (They work in OO1.1.4).

The 'pi' character is again not displayed properly on slides 2 and 3 (blue and
black displaced, and character too small) though it's better on slide 4.

Most of the animations seem to work, but there's a problem on slide 41. The
vertical line under 'Gen' on the left (which works in 1.1.4) first appears too
high, overlapping the box, and then slides down. Likewise the dashed diagonal
arrows between the boxes labelled 'cell' and the 'display' box: they appear in
the wrong place then adjust. This is a tolerable flaw but it's not there in
1.1.4, so it should be fixable. I think some of the other slides have similar
problems.

A general problem with OO that would drive me nuts if I used it regularly myself
(I normally use Latex for my own papers and slides) is not being able to type a
number to go directly to a slide. I find it very irritating to have to have use
sliders and mouse, etc. (I am a keyboard person). But I can see how for MS users
you have done a great job, and I have never seen such a large software package
improve so fast.

My tests were done on both a Dell D600 pentium M laptop running RedHat 9, and an
AMD Athlon64 running Fedora Core 3. Both had the msttcore fonts. 

I shall be away in the USA 28thApril to 2nd May (at MIT) but will be happy to
test out any new version after that.

Email me at A.Sloman@cs.bham.ac.uk

thanks.
Aaron
===
www.cs.bham.ac.uk/~axs
Univ. of Birmingham UK
Comment 1 wolframgarten 2005-04-26 09:54:47 UTC
Please have a look. You have a better view of the recently fixed bugs.
Comment 2 axs 2005-05-11 10:26:39 UTC
I have just tried the problem file
   http://www.cs.bham.ac.uk/~axs/phw-gc7-18-04-2005.ppt

in 1.9.100 and the problem of bullet points not showing is still there (the
bullets show, but none of the text except for the last bullet point in each
list), and the graphical problems are still there.

Also the 'pi' character not displaying properly in slides 2 and 3 (in slideshow
mode) is still there. It looks fine in other modes.

Aaron
Comment 3 axs 2005-05-11 11:13:14 UTC
I have found another powerpoint file that works much better (though still
imperfectly) in OO 1.1.4 than in OO 1.9.100 
  http://www.scit.wlv.ac.uk/~in7116/Articles/CRIC2003.ppt

In both 1.1.4 and 1.9.100 the numbered items on slide 2 all come out as
having number 1. (I have seen that in other ppt files shown using OO).

In the newere OO (1.9.100) the items show ok in edit mode but in slideshow mode
they slide in from the left, but the text is truncated on the right. E.g.
instead of 
  Introduction to the
  Wolverhampton
    etc...

you see
  Introduction t
  Wolverhampt
    etc.

with the last 't' cut in half vertically.
(That does not happen in 1.1.4).

In slide 4 there seems to be a left over panel which should not be displayed in
slideshow mode. It is displayed in 1.9.100 but not in 1.1.4

so once again there seem to be mechanisms that worked in 1.1.4  but don't work
in the latest Beta 2.

I have not had time to check out details of the rest of the file, though it
basically seems to display OK. I have never viewed it in powerpoint.

I hope this information is useful.
Comment 4 fbermejo 2005-05-13 14:56:52 UTC
I can reproduce partially on Windows XP with OOo 1.9.100. In particular, I also
have the problem of the missing text in some bullets (e.g. slide 2).
I have no problems with the 'pi' simbol, nor with the animation of slide 41.
Hope this helps.
Comment 5 axs 2005-05-14 13:53:34 UTC
fbermejo wrote about partially verifying the problems on XP (thanks):

> I have no problems with the 'pi' simbol

Presumably because OO on XP uses windows fonts where available -- in this case
MS 'comic sans'?

I have just installed the Fedora Core 3 version of OO (adapted by
redhat from OO 1.1.3). To my surprise it handles the pi symbol better than
either 1.1.4 or 1.9.100.

I also found that in 1.1.3 if I select the 'pi' symbol and change the font size
from the original (48) the symbol grows or shrinks according to the font size
selected, whereas in 1.1.4 and in 1.9.100 the 'pi' symbol shrinks if I go to a
very small size but does not increase with each font size step, and seems to
reach a maximum displayed size at 32 in 1.9.100 and 26 in 1.1.4, although the
black 'highlighted' area around the character grows after that.

This suggests to me that RedHat have fixed a bug in the display of symbol fonts
in OO1.1.3, but their fix has not been included in more recent versions.

> nor with the animation of slide 41.

It's actually quite subtle and easy to miss (I missed it when the owner of the
ppt file asked to see how OpenOffice would display it, but he saw it and drew it
to my attention).

If you start up slide 41, then on click 5 (i.e. the click immediately after the
horizontal red line appears), a vertical red line appears on left.

In OO 1.1.3(fedore core)it appears in the right place but a small light coloured
line spoils the box labelled 'gen'.
In OO 1.1.4 the vertical red line appears in the right place.
In OO 1.9.100 (on my linux machines) it appears with top part overlapping the
box labelled 'gen' and then quickly moves down.

In itself it is not significant: the presentation is not impeded and most people
seeing it will not notice. But it may be a symptom of a problem that could be
much worse in other presentations?

Sorry I don't know enough to do any debugging. 
Comment 6 fbermejo 2005-07-27 22:17:04 UTC
I think some of the problems have disappeared with last versions of OOo. In
particular, the problem of the bullet points not showing or being truncated on
the right, when in slide show mode.
However, I'm not using Linux but Windows, so I'm not sure.
axs, could you please check with latest version of OOo?. Thanks.
Comment 7 axs 2005-07-27 22:52:05 UTC
fbermejo wrote:
  I think some of the problems have disappeared with last versions of OOo.
  Inparticular, the problem of the bullet points not showing or being truncated
  on the right, when in slide show mode.
  However, I'm not using Linux but Windows, so I'm not sure.
  axs, could you please check with latest version of OOo?.

I have tried OO 1.9.118 using this file
   http://www.scit.wlv.ac.uk/~in7116/Articles/CRIC2003.ppt

The bullet points are now shown in full, but they all have the number 1 on slide
2. (I have not seen this displayed in Powerpoint, so I don't know if that also
shows just number 1).

This file: http://www.cs.bham.ac.uk/~axs/phw-gc7-18-04-2005.ppt now works much
better in OO 1.9.118

Checked on a laptop running Fedora Core 3.

Thanks.
Comment 8 christian.guenther 2005-09-01 11:30:45 UTC
Please write only one bug per issue the next time.
when I've a little more time I will compare the file with PPT, OOo on windows
and OOo on linux.
Please tell me which PPT version do you use because the doc looks also different
in different PPT-Versions.
Comment 9 axs 2005-09-01 12:09:02 UTC
cgu wrote: Thu Sep 1 03:30:45 -0700 2005
> Please write only one bug per issue the next time.

Very sorry. I appreciate now that I should have done that. I was not sure
whether the different numbering problems were related.

> when I've a little more time I will compare the file with PPT, OOo on windows
> and OOo on linux.
> Please tell me which PPT version do you use because the doc looks also
> different in different PPT-Versions.

Sorry I can't help with this, as I never use windows or PPT.

(Actually, as a LaTex user, I also don't use OO except to view or print things
produced by other people, for which I am very grateful!)

The original problem arose when I was trying to persuade someone I met at a
conference last April to switch from PPT to OO, so we tested his file on my
linux laptop. He immediately noticed problems, and let me take a copy of his
file to use to report the problems, namely
http://www.cs.bham.ac.uk/~axs/phw-gc7-18-04-2005.ppt
I don't know which version of PPT he was using. That one now seems to display OK
in recent Beta 2.0 versions of OO.

The other file which still has a numbering problem, namely
  http://www.scit.wlv.ac.uk/~in7116/Articles/CRIC2003.ppt
is one I found while using google. I confess that it had not occurred to me that
the file could have a bug that would also stop it working on powerpoint.
I'll write to the author to find out.

Incidentally, I have been very impressed by the speed increases in recent
versions of OO, e.g. 1.9.125
Comment 10 fbermejo 2005-09-01 15:56:21 UTC
I have compared the files with PPT (version 2003 SP1) and OOo (version 1.9.125)
on a Windows XP SP2 machine.
As a result, I think there are basically two problems that persist, while other
problems either have been solved or are very subtle. These two problems are:

- Bullet numbering differs (between OOo and PPT). In OOo, bullets in slide two
of file http://www.scit.wlv.ac.uk/~in7116/Articles/CRIC2003.ppt are all numbered
as 1, while PPT numbers then 1, 2, 3...,6. Probably this problem is described in
a different issue. Maybe cgu knows better.

- (Less important) Bullet marks are also different. In slides 2, 3 of file
http://www.cs.bham.ac.uk/~axs/phw-gc7-18-04-2005.ppt, bullet marks are shown as
solid diamonds by PPT, while OOo shows them as hollow boxes. The cause seems to
be that these marks have been defined using "Monotype Sorts" font.

Hope this helps.
Comment 11 christian.guenther 2005-11-01 19:43:26 UTC
I examine the documents and found the following bugs / enhancements.

1) Several slides: Some text shadows are missing. 
This is an enhancement. The shadow is assigned to the text box and not to the text. 
issue 57145

2) Slide 13-16 and 41-49: Linebreake in OOo but not in PPT
Issue 57146

3) Slide 23: Shape is too big.
Issue 57148

4) Slides 53-56 Gradients in the objects below the arrows looks different.
This is an enhancement. 
Issue 57152

5) The z-order of some objects i nthe running presentation is wrong.
Issue 37778 or issue 54563

6) Numbering in OOo is different to PPT
issue 54716

7) Wrong bullets. Sounds like a missing font. I have the correct font on my
system and see the correct bullets. -> Works for me.

If you finde some more bugs in the document please write new issues for this bugs.

All bugs are now handled in new issues therefore I close this issue as invalid.
Comment 12 christian.guenther 2005-11-01 19:44:25 UTC
I close this issue.