Issue 48994 - Hyperlinks are beheaded by the first character when presentation is saved in PowerPoint format (and opened in PowerPoint)
Summary: Hyperlinks are beheaded by the first character when presentation is saved in ...
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: save-export (show other issues)
Version: 680m100
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: sven.jacobi
QA Contact: issues@graphics
URL:
Keywords:
Depends on:
Blocks: 121425
  Show dependency tree
 
Reported: 2005-05-10 09:21 UTC by haui
Modified: 2013-08-07 15:21 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
OOoffice generated PPT file that displays beheaded links when rendered with PowerPoint. (25.50 KB, application/vnd.ms-powerpoint)
2005-05-10 09:22 UTC, haui
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description haui 2005-05-10 09:21:40 UTC
When inserting a hyperlink labeled "testit" into a presentation's textbox,
saving the document in PPT format and opening it with PowerPoint, the link reads
"estit". 
The problem can only be observed when opening the saved presentation in
PowerPoint. Funniliy, OpenOffice re-imports the (broken?) PPT file "correctly"
and displays the full link labels.

I'll attach a minimal OpenOffice-generated PPT document that is rendered
differently in OpenOffice and PowerPoint regarding link labels.
Comment 1 haui 2005-05-10 09:22:52 UTC
Created attachment 25961 [details]
OOoffice generated PPT file that displays beheaded links when rendered with PowerPoint.
Comment 2 wolframgarten 2005-05-10 09:57:55 UTC
Reproducible.
Comment 3 wolframgarten 2005-05-10 09:58:18 UTC
Reassigned. Please take a look.
Comment 4 sven.jacobi 2005-05-19 12:44:42 UTC
accepted
Comment 5 sven.jacobi 2005-05-24 11:54:26 UTC
Because of a too huge workload I can't fix this issue for OOo 2.01 -> changed
target to OO Later.
Comment 6 pagalmes.lists 2007-04-20 11:08:06 UTC
Any news ?
Comment 7 Rob Weir 2012-11-28 23:54:48 UTC
I am not able to reproduce this with AOO 3.4.1 and Office 2013.  It appears to have already been fixed.

I created a new document with hyperlink in AOO 3.4.1.  It looks fine in AOO and PowerPoint 2013.

Further, I took the old test document from 2005 and loaded it in Office 2013 and verified the error.  But when I took that same document and loaded it and saved it in AOO 3.4.1 the updated document was fine in Office 2013.

So the fix for old documents (presumably malformed PPT files) is to load and resave from within AOO 3.4.1.
Comment 8 binguo 2012-12-06 10:43:28 UTC
Verified on Aoo_Trunk_20121203.1303 Rev.1413470, Open attached ppt file with hyperlink text, the text shows well, no truncation. it is fixed.
Comment 9 binguo 2012-12-06 10:43:51 UTC
close it.