Issue 49284 - crashrep.exe, crash reporting tool crashes
Summary: crashrep.exe, crash reporting tool crashes
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: 680m100
Hardware: PC Windows, all
: P3 Trivial with 1 vote (vote)
Target Milestone: OOo 2.0.2
Assignee: uwe.luebbers
QA Contact: issues@framework
URL:
Keywords: needmoreinfo
: 47377 56604 (view as issue list)
Depends on:
Blocks:
 
Reported: 2005-05-14 14:10 UTC by aggro
Modified: 2006-03-08 17:33 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Screenshot from error dialog after crash. (4.20 KB, image/png)
2005-05-14 14:11 UTC, aggro
no flags Details
primary error message with full details in editor window (15.42 KB, image/gif)
2005-08-07 21:18 UTC, bernhard
no flags Details
error report content (5.76 KB, image/gif)
2005-08-07 21:19 UTC, bernhard
no flags Details
final error message with details (15.13 KB, image/gif)
2005-08-07 21:20 UTC, bernhard
no flags Details
zipped shapes.odg and crashrep screenshot (44.45 KB, application/x-compressed)
2006-01-18 00:12 UTC, drc
no flags Details
The error signature (125.74 KB, image/jpeg)
2006-02-17 15:18 UTC, yossy_takeuchi
no flags Details
crash_report.zip contains crash log(42a8_appcompat.txt) (21.39 KB, application/x-compressed)
2006-02-17 15:21 UTC, yossy_takeuchi
no flags Details
screenshot of same under win98fe (11.11 KB, image/png)
2006-02-22 19:48 UTC, duncan_sf
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description aggro 2005-05-14 14:10:34 UTC
Download corrupted file from here:
http://qa.openoffice.org/issues/show_bug.cgi?id=32227

1. Start Writer and open corrupted file from it's menu.
2. OpenOffice hangs
3. Click x on the corner to close and force close
4. Open OpenOffice again
5. Error reporting tool opens
6. Click "Start recovery"
7. Succesfully recovered
8. Click next
9. Click next

- "Show Report" button shows empty content.
- "Options" have "use system settings" selected
- [x] I allow Sun Micro... is checked
- Valid email address has value: dvice_null@yahoo.com
- "Which type of document..." field is empty
- "How were you using..." field is empty

10. I click "Send" 
11. Error reportin tool crashes (screenshot of error message window will be
attached. It's Finnish, but AFAIK provides no usefull information, but perhaps
you get something out of it)
12. Writer opens with empty document and works fine. 

Windows 2000 + SP4, Finnish.
Comment 1 aggro 2005-05-14 14:11:47 UTC
Created attachment 26146 [details]
Screenshot from error dialog after crash.
Comment 2 Olaf Felka 2005-05-17 08:45:18 UTC
@ aggro: Please tell us which OOo version you are using!
Comment 3 Joost Andrae 2005-05-17 08:56:07 UTC
ja->aggro: within the most recent build I cannot reproduce this. Closing issue
as "worksforme". If you're able to reproduce it in a build which is greater or
equal  than src680m97 then feel free to reopen this issue. Otherwise your
developer snapshot is too old.
Comment 4 Joost Andrae 2005-05-17 08:56:21 UTC
.
Comment 5 aggro 2005-05-17 18:16:02 UTC
Version is 1.9.100. 

Sorry, I thought "current" ment for that since I couldn't find the latest
snapshot from the Version drop down menu when I submitted the bug.

Is there anything I can do to provide you more information? I seem to be able to
reproduce this bug every time I try.
Comment 6 Joost Andrae 2005-07-01 15:01:33 UTC
JA->HRO: please take a look at this. Maybe you have an idea what might happen
with the crashrep.exe binary on his windows 2000 sp4 system. I have no clue what
makes it crash on his system.
Comment 7 aggro 2005-07-01 19:24:38 UTC
1.9.113 still has this problem.
Comment 8 mhx 2005-07-11 12:29:10 UTC
Same here with German m116 using Windows XP SP2. Reproducable every time.
Comment 9 bernhard 2005-08-07 21:16:48 UTC
I have to confirm this issue with m122 on Win98SE.
Using another reproducibly crashing document (issue 52988) I made a lot of
screenshots showing the entire way from the first error message to the final crash.
I'll attach some of them, if you're interested in the others (doc recovery,
"Welcome to ... Error Report", options in "Sending the Error Report") just drop
me a line...

First image (crashrep_primary_error_msg.gif) shows primary Error Message that
starts with:
*CRASHREP* caused an error by an invalid page (german "ungültige Seite") in
modul KERNEL32.DLL ...
I had supposed it should start with "SOFFICE".
I copied the details of the error message in an editor so the can be seen on the
same screenshot.

Second image (crashrep_send-rep-window_show-report.gif) shows the error report
(using the "show report" button in the "Sending the Error Report" window). Here
you can't see anything else than the sentences I entered in the "Sending the
Error Report" window! If I don't write a description the report stays empty at
all (except the lines with equals signs).

Third image (crashrep_final_error_msg.gif) shows the error message I get after
clicking on the "Send" button. It's nearly the same as the first one, just some
differences in register params and batch values (german "Stapelwerte").

I hope this may help to find the problem.

Regards 
Bernhard

PS: There has been another user on users@de.openoffice.org mentioning the
reproducible crashing crashrep with m117 on Win XP pro. If it would help I could
ask him for details.
Comment 10 bernhard 2005-08-07 21:18:49 UTC
Created attachment 28548 [details]
primary error message with full details in editor window
Comment 11 bernhard 2005-08-07 21:19:34 UTC
Created attachment 28549 [details]
error report content
Comment 12 bernhard 2005-08-07 21:20:16 UTC
Created attachment 28550 [details]
final error message with details
Comment 13 materthron 2005-08-18 16:37:21 UTC
I experienced the same under Window 98SE with 19.9.122 (aka: 1.9.m122)
Comment 14 bernhard 2005-09-25 15:03:09 UTC
still same behavior with m125 (Beta2).
This is a regression to OOo1.1.5, where Crashrep does work.

If someone takes over I'd be glad to help with further informations.

Bernhard
Comment 15 andreschnabel 2005-11-27 11:12:19 UTC
confirmed, as the problem still occures in 2.0.1rc1
Comment 16 drc 2006-01-18 00:09:45 UTC
Another reproducible scenario - OOo2.0.1 downloaded today on W98SE
See crasher.zip to be attached.

 1. OOo2.0.1 downloaded today
 2. Open shapes.odg
 3. edit select all
 4. edit copy
 5. file new presentation
 6. Next Next Create
 7. edit paste
 8. insert animated image (Group object is default) 
 9. Click on button to apply obects individually (Frame 11 shows)
11. Play backwards, play forwards
12. create
13. close Animation dialogue
14. delete original group from presentation

No animation visible on working document or slide show.
Close presentation, discard.

repeat 5 to 11 inclusive

15. select bitmap object
16. create
repeat 13, 14
slideshow:

Message - CRASHREP caused an invalid page fault in
module KERNEL32.DLL at 0167:bff7b992.
Registers:
EAX=00000020 CS=0167 EIP=bff7b992 EFLGS=00010202
EBX=00000000 SS=016f ESP=0069e950 EBP=0069e98c
ECX=7c38b4e8 DS=016f ESI=00000020 FS=4807
EDX=006b50dc ES=016f EDI=7c36bb92 GS=0000
Bytes at CS:EIP:
80 3e 04 74 0f 33 c0 50 50 50 68 05 00 00 c0 e8 
Stack dump:
7c34f744 7c34f639 00000020 7c36bba6 00000000 7c36bb92 7c34f744 00000000 00000000
0069e964 0069e780 0069fb48 7c34240d 7c3821f8 ffffffff 0069fb54 

escape closes both OOo applications.

Start programs OOo Impress (Document recovery dialogue)
Start recovery> (success)
Next Next Send (Crashrep crashes)

Message again - CRASHREP caused an invalid page fault in
module KERNEL32.DLL at 0167:bff7b992.
Registers:
EAX=00000020 CS=0167 EIP=bff7b992 EFLGS=00010202
etc - minor differences.


close crashrepcrash report Drawing and empty presentation recovered.  Close both.
Comment 17 drc 2006-01-18 00:12:42 UTC
Created attachment 33318 [details]
zipped shapes.odg and crashrep screenshot
Comment 18 hwoarang 2006-01-19 15:01:41 UTC
*** Issue 47377 has been marked as a duplicate of this issue. ***
Comment 19 hwoarang 2006-01-19 15:03:17 UTC
Still reproducible with OOo-dev m150 Win98SE.

Hwoarang
Comment 20 hwoarang 2006-01-19 15:05:33 UTC
*** Issue 56604 has been marked as a duplicate of this issue. ***
Comment 21 hwoarang 2006-02-09 17:59:15 UTC
Hi there!
any news about this issue?

I'm using OOo-devm156 and I'm getting a lot of crashes here, but can't send the
stacktrace.

Hwoarang
Comment 22 hennes.rohling 2006-02-15 09:06:10 UTC
@hwoaran: Guess I found another reason for a possible crash of crashrep.exe. If 
soffice.bin process was terminated without an exception (f.e. killing the process via 
task manager) the report files are missing.

Was does it mean: "I can't send crashreports" ? Does crashrep.exe crash or are 
there some other reasons why you can't send reports ?
Comment 23 hwoarang 2006-02-15 11:10:42 UTC
HRO: Hi. I meant that everytime that I got a crash I cant send the stacktrace
(because there's no stacktrace to send).
And if I try to send the crashreporter.exe crash too.

This not happens only with me. All my LAN (using win98se) have the same problem.

Sometimes, in my home (with WinXP), OOo can get some stacktrace to send, but is
not always.

Thank you.
Hwoarang
Comment 24 yossy_takeuchi 2006-02-17 15:17:05 UTC
In the reappearance of issue 62088,
when trying to send a crash report, crashrep.exe freezes.

Environment:
- Windows XP Home Edition SP2 (Ja)
- OpenOffice.org 2.0.2rc1 (ja_wJRE)

Comment 25 yossy_takeuchi 2006-02-17 15:18:33 UTC
Created attachment 34249 [details]
The error signature
Comment 26 yossy_takeuchi 2006-02-17 15:21:54 UTC
Created attachment 34250 [details]
crash_report.zip contains crash log(42a8_appcompat.txt)
Comment 27 duncan_sf 2006-02-22 19:48:26 UTC
Created attachment 34384 [details]
screenshot of same under win98fe
Comment 28 duncan_sf 2006-02-22 20:06:54 UTC
I observed what looks like the same thing today under Win98fe.  OoO asked me 
about recovering a document when it started then stopped responding when I 
pushed the "send report" button.  Same again on the second try.  On the third 
try, after a reboot, I pressed "view report" before "send" and the text box was 
empty.  As before it froze when I pressed send.  On the fourth try I pressed do 
not send and the document loaded.

Help/About says I'm running version 2.0 with no sub-sub-version.

crashrep.exe doesn't seem to have any version information but Filealyzer says it 
has size:458752, CRC-32:4A3D9C03, MD5:08C652D1E6BD3B10105491C3C327A069, SHA1:
20171043717066DB68F012B74EEBB4AA72908CC8
Comment 29 hennes.rohling 2006-02-22 20:12:06 UTC
Yep, there's a reproducable problem if crash report data wasn't created (for 
unknown reasons) after a crash and on restart the crash reporter tries to send just 
nothing.

@duncan_sf : Nice picture ;-) Regarding what you wrote into the edit field I'm 
assuming that after crashrep.exe crashed the crash report dialog comes up on 
every start of soffice.exe. This sounds strange because what I can reproduce is 
that crashrep.exe crashes but after that the soffice.bin process continues running.

It's not about that crashrep.exe crashes when there's no data to send but what did 
you do to that there's no data to send. The crash of crashrep.exe can be fixed but 
would result in just not sending "nothing".

And what's the behaviour of the soffice process when crashrep.exe crashes ? Are 
the report files missing after you experienced a crash of soffice.bin and 
crashrep.exe crashes too ?

In your user directory f.e. C:\Documents and Settings\hr93777\Application 
Data\OpenOffice.org1.9.xxx\user there should resist a subdirectory "crashdata" 
which after a crash should at least contain 3 files:

crashdat.dmp
crashdat.stk
crashdata.chk
Comment 30 hennes.rohling 2006-02-23 15:05:47 UTC
Test for availability of crash report data before showing additional pages of wizard. 
Crash report data may miss f.e. if soffice.bin was killed via task manager.
This case was already handled if only the crashreporter was shown but not in 
conjunction with the auto recovery.

Changed target. Fixed in CWS pngmagic
Comment 31 uwe.luebbers 2006-02-23 17:35:47 UTC
assigned to me

re-open issue and reassign to ul@openoffice.org
Comment 32 uwe.luebbers 2006-02-23 17:35:55 UTC
reassign to ul@openoffice.org
Comment 33 uwe.luebbers 2006-02-23 17:36:00 UTC
reset resolution to FIXED
Comment 34 uwe.luebbers 2006-02-23 17:36:42 UTC
reassign to ul@openoffice.org
Comment 35 uwe.luebbers 2006-02-23 17:36:47 UTC
reset resolution to FIXED
Comment 36 hennes.rohling 2006-02-23 17:37:59 UTC
.

re-open issue and reassign to ul@openoffice.org
Comment 37 hennes.rohling 2006-02-23 17:38:04 UTC
reassign to ul@openoffice.org
Comment 38 hennes.rohling 2006-02-23 17:38:09 UTC
reset resolution to FIXED
Comment 39 uwe.luebbers 2006-02-23 17:40:44 UTC
ok in CWS pngmagic
Comment 40 hwoarang 2006-02-24 12:45:31 UTC
[begin quoting HRO]
Crash report data may miss f.e. if soffice.bin was killed via task manager.
[end quoting HRO]

Do you know that this is not the only case, right?
With me, Crash Reporter Tool can't find report data in every crash, including
those caused by errors.

As I can see the Crash Reporter Tool will show up only if report data exists
right? But the goal was not to fix the "no crash report data to send" ?

Just to fully understand.

Thank you.
Comment 41 uwe.luebbers 2006-03-08 17:33:42 UTC
the goal was to fix the crashing crashrep.exe, so this bug is fixed in 2.0.2