Issue 49405 - Installation of a new version of OOo
Summary: Installation of a new version of OOo
Status: CLOSED DUPLICATE of issue 33449
Alias: None
Product: Installation
Classification: Application
Component: ui (show other issues)
Version: 680m100
Hardware: PC Windows XP
: P3 Trivial with 4 votes (vote)
Target Milestone: ---
Assignee: requirements
QA Contact: issues@installation
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-17 17:32 UTC by computerhotline
Modified: 2007-05-06 15:55 UTC (History)
4 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description computerhotline 2005-05-17 17:32:16 UTC
Hello
The end-user should be able to update OOo without uninstall the old version.
Comment 1 Olaf Felka 2005-05-17 18:36:37 UTC
reassigned
Comment 2 kami911 2005-06-21 08:38:32 UTC
Yes, Easy update should be in 2.0. MSI style installers can do it.
Comment 3 kami911 2005-06-21 08:39:47 UTC
pjanik: What is your opinion about this?
Comment 4 kami911 2005-06-21 08:40:25 UTC
pjanik: What is your opinion about this?
Comment 5 pavel 2005-06-21 08:42:40 UTC
When you "update", you have to do something with the old version.

You simply want end-user to be able to install new version along the old one, right?

And it isn't possible?
Comment 6 thookerov 2005-07-20 21:27:32 UTC
Not sure if i'm on the right track here from the original post, but it would be
a lot more convenient and less complicated if, when trying to install a new
version of OOo (say updating the beta versions), you didn't have to uninstall
the older version before installing the newer. Otherwise, you end up with
multiple entries in Add/Remove Programs, and shortcuts from the older version
become broken when trying to run the new.

i use a custom Windows toolbar with OOo shortcuts in it. i've installed several
beta versions and each time i have to replace old shortcuts in that toolbar with
the shortcuts created in my Start Menu because the older ones are "broken".

i think the idea here is to install a newer version OVER a previous, not
alongside. If i choose to install to the same path with the same options, i
still get the multiple A/R Program entries and dead shortcuts. This happens on
both of my WinXP machines.

Lastly, because i have to manually uninstall in order to update, i also have to
go through all the Welcome info entry stuff every time. Can't that be stored, or
at least an option be offered during uninstall to keep or drop the information?

Sorry, long-winded, but i hadn't seen much else on these items and this seemed
relevant. If i'm way off, my apologies.
Comment 7 jgeldman 2005-08-05 21:08:56 UTC
A comment from one user who has had unintential troubles from leftover spoor of
previous versions - I believe the default behaviour should be to replace the
existing installed version. It is a safe mode for most non-geek users.

Options for multiple versions are fine, but seem to have surprising complexities
- the window 98 registry spoor for 1.9.100 (after 1.9.104 installation after
1.9.118 installation), which I had to clean by hand, was over two thousand entries. 

In each OS (and OS version), and in each version of OO, I'd like to see the
ability to hunt for previous spoor and remove it (i.e. from the installation of
Z, notice that spoor of Y and X versions are there and ask if they should be
cleaned up). This makes it "mom" safe.

I understand the need and desire to support multiple versions in a production
environment. In 'nix, it isn't unusual for a user to develop scripts to change
the man, lib and executable paths to support a given version of a tool. But with
the number of multimedia & hooks that OO offers, it is a huge task for an
end-user to manage.

So while I support the need/desire, I also want the simple behavior to just work
for the 95% who just want it to work. Watching the users mail list, there are a
lot of unsophisticated users of OO who will hurt themselves.

To support this, it would be nice if there was were appropriate de-configure and
configure (not remove) scripts/tools to enable this capability. But keep it out
of the default installation sequence!

Just one non-developers/victims view. 8-)
Comment 8 thookerov 2005-08-09 13:47:08 UTC
Following up to previous ...complaining, i guess, i've noticed another obstacle.
Not only can i not install a newer version over an older version, but i am
actually prevented from selecting the same folder the older version is in:

i have not uninstalled A. i choose Custom install of B so i can control the
destination directory, then select A's directory. The beta B installer locks and
crashes.

i agree with the jgeldman comment, that default behavior should be for new
versions to replace older ones. i'm not interested in running or housing 30
versions of the same application. i want to use one version. So why not
introduce that option (replace or side-by-side) in the installer? At least for
beta testing purposes, though i would suggest it be removed for final release.
Comment 9 lemiel 2005-08-18 09:04:31 UTC
Installation of new version over old one would be easier when there will be no
version number in default directory name, like it looks in my installation
(Windows):
D:\Program Files\OpenOffice.org 1.9.95\

This shorter form should be enough:
D:\Program Files\OpenOffice.org\

I think it is the reason of broken custom shortcuts.

Same in Folder name in Windows Menu Start.
Comment 10 thookerov 2005-08-18 12:47:47 UTC
You can alter the directory name OOo installs to by choosing Custom Install.
However, every time i've attempted that, and have changed the directory to the
one where a version is currently installed, the installer freezes, essentially
crashing. It won't permit that operation. i'm led to believe that simply making
that the default option won't correct the behavior, as it would then crash when
installing to the default OpenOffice.org directory. There's some kind of bug in
the installer itself causing the crash when it points to an existing installation.
Comment 11 kpalagin 2007-05-06 15:49:44 UTC
Seems to be dup of http://qa.openoffice.org/issues/show_bug.cgi?id=33449.
Resolving as such.

*** This issue has been marked as a duplicate of 33449 ***
Comment 12 kpalagin 2007-05-06 15:55:24 UTC
and closing.
Please transfer votes to 33449.