Issue 49410 - unable to save document after access denied
Summary: unable to save document after access denied
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 680m100
Hardware: PC Windows, all
: P3 Trivial with 6 votes (vote)
Target Milestone: AOO Later
Assignee: mikhail.voytenko
QA Contact: issues@framework
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-17 19:48 UTC by lcombe
Modified: 2010-10-23 15:45 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description lcombe 2005-05-17 19:48:59 UTC
Under particular conditions,
we are unable to save a Writer document and 
we have a data loss because all the created files
generated when saving are empty files (0 bytes)

How to reproduce the issue :
****************************
1.Open a new Writer Document
2.type something in the document by exemple "aaa"
3.save the file in native format "aaa.odt"
4.save the file in Word format "aaa.doc"
5.close Writer application

6. Now open "aaa.doc" with another software (i.e MS Word)
7. keep MS Word open (don't close it, i know it's difficult)

8. Open "aaa.odt" with OOo Writer
9. Modify the file, inserting "bbb"
10. Try to save this file in Word format as "aaa.doc"
We have an error message because of
access denied on the already opened (by Word) file
this is normal

BUT now we are _unable_ to _save_ this file in any format
and whatever the name we choose
with following message "General Error, General I/O error"
by example if we try save in native format as "aaa.odt"
we have the error message and on the disk "aaa.odt" is an empty file.
Comment 1 michael.ruess 2005-05-18 06:27:39 UTC
Framework issue.
Comment 2 loic.breilloux 2005-05-18 08:39:22 UTC
*** Issue 49410 has been confirmed by votes. ***
Comment 3 loic.breilloux 2005-05-18 17:58:20 UTC
The problem is worse then that : in step 10 (trying to save aaa.odt after being
denied aaa.doc), OOo erases all the data in aaa.odt (->0 bytes). OOo does not
inform the user of that loss. The user will probably quit OOo and hence loose
it's last chance to save his document (by copy + paste).

Should the summary be modified to reflect this ?
Comment 4 thorsten.martens 2005-07-01 11:56:40 UTC
Behaviour has changed in a m113 build. Now, after step 10 I get no "General
Error, General I/O error" but a "could not create backup" - message. The
original file is left untouched. So no data loss occurs but some kind of
locking. Please investigate, thanks !
Comment 5 mikhail.voytenko 2008-01-29 08:44:41 UTC
Locking is correct in this situation, MSWord locks the file, so the backup can
not be created.
Comment 6 mikhail.voytenko 2008-01-29 08:52:16 UTC
.
Comment 7 cuodenumyp 2010-10-23 15:45:14 UTC
Created attachment 72678