Issue 4976 - poor html conversion
Summary: poor html conversion
Status: CLOSED DUPLICATE of issue 19666
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: PC Linux, all
: P3 Trivial with 10 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2002-05-17 10:18 UTC by Unknown
Modified: 2019-02-03 16:58 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2002-05-17 10:18:50 UTC
I create a document and save as web page.  The <body LANG="de-DE"
TEXT="#000000"> tag should have LANG=en-US, the other tags have it correct.  The
html is pretty poor, almost unusable for the following reasons:

1) as has been mentioned in other reports, the standerd should be 4.01 with at
least css1

2) every tag has the LANG= attribute

3) every formating tag includes STYLE= various margins indents, etc.  I
understand that it must be difficult to code this type of conversion, but, would
it be possible to evaluate the document to determine a better set of CSS
elements for whole blocks of text.

4) the line spacing is way to much on the converted page.


I am willing to provide an example if needed.
Comment 1 prgmgr 2002-07-11 05:51:55 UTC
Steve, thanks for your suggestions.

Please attach a sample file to this issue that demonstrates how your
suggestions should be applied.

Unable to duplicate issue with LANG tag.  Running RedHat 7.3, Gnome,
OO 1.0.
Comment 2 stefan.baltzer 2002-07-15 19:06:38 UTC
Reassigned to Christian.
Comment 3 christian.jansen 2003-03-24 07:51:55 UTC
Reassiged to Bettina.
Comment 4 sforbes 2003-08-26 08:40:09 UTC
>Unable to duplicate issue with LANG tag.

I am getting lang for every element- ,probably since my local is
Hebrew and not western.
1.1RC on windows
Comment 5 raiten 2008-01-21 19:11:22 UTC
In a perfect world, output has to be valid html4 or xhtml1.1. (validator.w3.org)
a possible tool would be an extension which support tidy
(http://tidy.sourceforge.net/)
Comment 6 bettina.haberer 2010-05-21 15:05:35 UTC
To grep the issues easier via "requirements" I put the issues currently lying on
my owner to the owner "requirements". 
Comment 7 Peter 2019-02-02 14:17:11 UTC
This is about not beeing able to write clean html4 document. Mergining into one Issue.

*** This issue has been marked as a duplicate of issue 19666 ***