Issue 49895 - Spelling Change All does not account for capitalization of word
Summary: Spelling Change All does not account for capitalization of word
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 2.0 Beta
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-26 11:17 UTC by ftack
Modified: 2013-08-07 14:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description ftack 2005-05-26 11:17:24 UTC
Writer 1.9.104 on Windows XP sp2.

When replacing a faulty spelled word, capitalization is accounted for in an
inconsistent way.

To reproduce the error:
Open a blank document with language setting to English (USA) (other languages
have similar issues).

Enter following lines of text

Jook I am herw.
Jook I am herw again.
Jook am herw.
Jook l am herw...
Jook Herw l am.
Here I am, jook.

Run spell check using F7. Jook is not found. It should read Look.

Possibility one: click the suggestion "look", then change All.
All instances of Jook are changed to look with lower case. THE LAST INSTANCE ON
LINE 5 IS CHANGED TO "nook"! (Did't notice that one before!).

Possibility two: Edit the red highlighted Jook to read Look, then click Change
All. Now, OOo will not change all occurrences, but ask again on each next one.

This is a severe issue as it introduces errors that can't be corrected but by
detailled proofreading.

There remain several issues with the current spellchecking. Considering "one
problem, one issue" I will post these in defferent "issues.
Comment 1 michael.ruess 2005-05-26 11:28:17 UTC
Reassigned to SBA.
Comment 2 jack.warchold 2005-05-26 15:33:21 UTC
i can confirm this on OOo1.9.106
set to new
Comment 3 jack.warchold 2005-05-26 15:35:43 UTC
changed target.
as discused this issue may be a duplicate
Comment 4 jack.warchold 2005-07-21 15:24:48 UTC
confirmed in src680_m119

kevin is this yours
Comment 5 ftack 2005-12-07 15:33:40 UTC
Target milestone must probably be adjusted? I do not see this issue addressed in
OOo 2.01 RC 2.
Comment 6 pavel 2005-12-14 12:59:27 UTC
Daniel: can you please evaluate this issue?
Comment 7 stefan.baltzer 2005-12-16 15:47:00 UTC
SBA: I am currently evaluating CWS Hunspell (that will replace Myspell). 
After its integration, several issues about spell checking must have a second look.

Within this CWS, I can see some "new behavior" concerning capitalisation.

This very issue does not occur any more because "Look" is now coming up as a
suggestion for "Jook". 

Selecting "Look" and clicking "Change all" replaces all "Jook" while "jook" will
not be touched.

When first replacing "jook" with "look", then the capitalized "Jook" will not be
touched.
This looks like a "Worksforme". But I cant set this before CWS Hunspell is
integrated so that this can be seen by all stake holders.
Comment 8 ooolist2007 2006-01-03 21:38:36 UTC
pjanik: As sba said, we should wait for hunspell to be integrated before 
spending time on this. 
 
Comment 9 tahouri 2007-01-30 08:47:27 UTC
Configuration: Windows XP professional SP2

Build: OpenOffice.org 2.1

I was able to reproduce the error and interestingly I noticed different 
behavior from the spell checker for different input.
While working with different input, I also observed another error related to 
spell checking which I will mention shortly.
Let’s go through one example.
I entered the following few lines to open office writer.

This boy is very goom	
this goom man does not work here.
We picked a very goom flower.
Then I right-clicked on the underlined words (here is “goom”) and select 
spelling (you could alternatively press F7). 
From the “Suggestions” list I chose “good”. 
Next, I pressed “Change All”.
The result was as I expected. In other words all the “goom” in all three lines 
are now replaced with “good”. 
In another test, I entered the above three lines with a minor difference.
That is, I changed some of the letter to capital in the word “goom”. Everything 
else is unchanged. Here is my input:

This boy is very goom	
this Goom man does not work here.
We picked a very gOoM flower.
Similar as above, I right-clicked on the underlined words (they are “goom”, 
Goom and gOoM) and select spelling (again, you could alternatively press F7). 
From the “Suggestions” list I chose “good”. 
Next, I pressed “Change All”.
This time the result was not as I expected. This time, pressing “Change All” , 
changes the first occurrences of the underlined word i.e.  “goom” is replaced 
by “good”. The rest of the underlined words remain untouched.
 If I wish to correct all the underlined words, then for every one of them, I 
have to press “Change All” (or just press Change”). Therefore the spell 
checking mechanism differentiates between words that are the same but differ 
only in capitalized letter. In other words “goom” and “Goom” is totally two 
different words.
 When we press “Change All” replacement is done only on exact matches of the 
word.
 For example suppose we have three sentence such that the first and the second 
one contains “goom” and the third sentence contains “gooM”. If we press “Change 
All” in spell checking, only the first and second line which contains exact 
match, are affected.  
Also note that every time that we press “Change All”, “Suggestion” list changes 
its suggestions. Therefore if we just keep pressing “Change All” (without 
looking at the suggested word) we might end up with different word. This is the 
case I think that happened for original person who wrote the first comment, 
where in the last line he got a totally different word. Because he has “jook” 
in the last line but on the other lines he has “Jook”. He probably got a 
different suggestion for “jook” and without looking at the “Suggestion list” he 
pressed “Change All” continually, so he ended up with “nook” for “jook”.
Another related error:
I entered the following sentences:
 The old gumzy man was very happy.
 Gumzy man decided to leave afterward.
I noticed that the word “gumzy” is underlined to indicate spelling error. 
Suppose I wish that this word to be recognized by the open office writer 
dictionary. I only need to add one word to the dictionary which is “gumzy”. On 
the second sentence the first letter of the word “gumzy’ is capitalized because 
here it happens to be the first word in the sentence. So we know they are the 
same.
Add the word “gumzy” to the dictionary by pressing “F7” and then pressing the 
button
” Add to Dictionary”. 
I expect that now both words (“gumzy” and “Gumzy”) Not to be underlined. 
However I observed only the first “gumzy” is recognized (not underlined) and I 
have to do another adding to dictionary to the second “Gumzy”. 
It seems that open office writer can not recognize the same word when on of it 
letters is capitalized.
This error does not happen in Ms-2003.
Comment 10 ooolist2007 2010-08-18 19:49:40 UTC
Assigning code bugs to me doesn't make sense
Comment 11 michael.ruess 2010-08-19 08:17:25 UTC
Closing issue as fixed, at least in 3.2.1 capitalization is taken into account
by spell check.
Comment 12 michael.ruess 2010-08-19 08:19:03 UTC
Closed.