Issue 49989 - Embedded flash doesn't work
Summary: Embedded flash doesn't work
Alias: None
Product: Impress
Classification: Application
Component: viewing (show other issues)
Version: OOo 2.0.1
Hardware: PC Windows, all
: P3 Trivial with 8 votes (vote)
Target Milestone: OOo 3.0.1
Assignee: wolframgarten
QA Contact: issues@graphics
Keywords: needmoreinfo, oooqa, regression
: 62264 83296 84061 84585 85300 93244 (view as issue list)
Depends on:
Reported: 2005-05-28 14:37 UTC by jmbarbier
Modified: 2009-09-29 13:08 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

minimal swf file for embedding in presentation (2.00 KB, application/octet-stream)
2005-12-22 09:40 UTC, harald.schilly
no flags Details
test presentation which needs example-swf in the same directory (10.70 KB, application/vnd.sun.xml.impress)
2005-12-22 09:41 UTC, harald.schilly
no flags Details
test presentation which needs example-swf in the same directory (10.70 KB, application/vnd.oasis.opendocument.presentation)
2005-12-22 09:41 UTC, harald.schilly
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jmbarbier 2005-05-28 14:37:03 UTC
With 680m104, if you insert a flash animation in a slideshow (Insert > Plugin), 
the animation plays well on compose page, but when you try to play the 
slideshow, the flash displays as the generic plugin yellow image.
(Fails on windows 2K & linux (debian), with mozilla & flash player installed.)

With 1.1.3 from debian unstable / testing, inserting a flash movie makes oo 

With 1.1.4 on WinXP, everything works...

I'll try 1.1.4 on Win2K & Linux
Comment 1 wolframgarten 2005-05-30 08:30:58 UTC
Comment 2 wolframgarten 2005-05-30 08:31:13 UTC
Comment 3 harald.schilly 2005-09-22 10:48:48 UTC
i can confirm this for beta2 m125 (de) on WinXP sp2.

flash works in preview, but OOo shows only the plugin-icon when playing
the presentation.
Comment 4 harald.schilly 2005-12-11 11:00:52 UTC
this works with the 1.x.x versions and in writer 2.0, but not in impress 2.0 when 
starting the presentation. -> therefore keyword regression

somebody should check this with the RC builds after 2.0.0 please, too.
Comment 5 harald.schilly 2005-12-22 09:40:10 UTC
Created attachment 32645 [details]
minimal swf file for embedding in presentation
Comment 6 harald.schilly 2005-12-22 09:41:22 UTC
Created attachment 32646 [details]
test presentation which needs example-swf in the same directory
Comment 7 harald.schilly 2005-12-22 09:41:35 UTC
Created attachment 32647 [details]
test presentation which needs example-swf in the same directory
Comment 8 harald.schilly 2005-12-22 09:44:04 UTC
regression still exists in 2.0.1
Comment 9 michael.ruess 2006-02-23 13:39:21 UTC
*** Issue 62264 has been marked as a duplicate of this issue. ***
Comment 10 lohmaier 2006-02-24 00:30:42 UTC

*** This issue has been marked as a duplicate of 49357 ***
Comment 11 lohmaier 2006-02-24 00:30:57 UTC
closing dupe.
Comment 12 christian.guenther 2008-02-13 11:33:51 UTC
I reopen the issue.
Plugins are working in the meantime but playing flash files is still broken.
Comment 13 christian.guenther 2008-02-13 11:40:01 UTC
*** Issue 81649 has been marked as a duplicate of this issue. ***
Comment 14 christian.guenther 2008-02-13 11:42:25 UTC
*** Issue 83296 has been marked as a duplicate of this issue. ***
Comment 15 christian.guenther 2008-02-13 11:43:25 UTC
*** Issue 84061 has been marked as a duplicate of this issue. ***
Comment 16 christian.guenther 2008-02-13 11:44:50 UTC
*** Issue 84584 has been marked as a duplicate of this issue. ***
Comment 17 christian.guenther 2008-02-13 11:46:07 UTC
*** Issue 85300 has been marked as a duplicate of this issue. ***
Comment 18 flecher 2008-02-13 22:42:22 UTC
I report my votes from issue 83296.
problem with ubuntu 7.10, XP and vista with OO0 2.3

Comment 19 interele 2008-05-08 09:58:30 UTC
Tried OO 3 Beta 20080429 on XP pro and it still does not support embedded
flash in a ppt presentation.
Comment 20 discoleo 2008-05-18 12:06:29 UTC
While I try to insert some .flv and .swf files into the presentation, Impress
reports an error: 'The format of the selected file is not supported.'

Considering that >90% of web movies and vector-graphics are one of those 2
formats, it is rather an unfortunate event that OOo does not support them.

If I lack some codec/plugin, than a more comprehensive error message explaining
what went wrong and how to resolve it would be welcome.
Comment 21 interele 2008-06-24 16:14:32 UTC
Tried 23Jun2008 snapshot and this still doesn't work
Is there any news on this bug as it is a big issue 
for us. Will it be fixed for 3.0 ?

Comment 22 interele 2008-07-07 14:07:15 UTC
1st July snapshot - It still doesn't work
( Windows ) - any new on this ????

Comment 23 interele 2008-07-07 14:07:16 UTC
1st July snapshot - It still doesn't work
( Windows ) - any new on this ????

Comment 24 interele 2008-07-09 14:43:22 UTC
Still doesn't work in 7th July snapshot 

If someone could tell me if/when it is
worth trying a build that would be great

I have hundreds of ppt with embedded flash
that currently don't work so this is really
really important to me

Comment 25 clippka 2008-07-09 16:28:21 UTC
cl->interele: as long as this issue is not marked fixed, chances are low that it
is fixed in one of the snapshots. Also the target milestone of OOo Later means
that it is not planned for any release son. I will re target it to 3.x and see
if some other developer has time.

cl->pl: Please have a look, a fix for 3.0 would be desired
Comment 26 philipp.lohmann 2008-07-09 16:32:56 UTC
pl->cl: as would be a solution for world hunger, but from "OOo Later" to "3.0
showstopper" with just 2 clicks isn't going to happen.
Comment 27 interele 2008-07-09 19:47:19 UTC
A heck of a lot of UK schools use 'BoardWorks'
for their interactive whiteboard presentations.
Nearly all of these have embedded flash in them
If we could wave goodbye to MS Office it would 
save us a five figure sum, which is a fortune to
a school not to mention the exposure OO would
receive. Just because you haven't had schools 
breaking down your door to fix this doesn't mean it's 
not important. Schools generally don't have the time 
or money to experiment with new things. They will see
embedded flash not working and silently go back to MS Office. 
With the educational market slightly on hold following BECTAs 
report that Office 2007 has no compelling features 
we are now in limbo. Students can no longer buy Office 
2003 and have to buy 2007 for home use. MS presumably  
hope that once enough students have 2007 we will be
forced to upgrade the school or face a compatibility 
nightmare. This is your chance to take a huge chunk out
of MS Office's market and a big chunk out of their 
future users.
Comment 28 michael.ruess 2008-08-29 14:15:44 UTC
*** Issue 93244 has been marked as a duplicate of this issue. ***
Comment 29 interele 2008-09-09 11:23:02 UTC
I just thought I'd add that this bug is still in the release candidate :-(

Comment 30 philipp.lohmann 2008-10-07 12:20:16 UTC
On windows it seems to work after adding yet another search method for the SWF
plugin; it seems mozilla changed the search algorithm yet again.
Comment 31 jm-pierre-79 2008-10-07 13:04:39 UTC
In Windows XP, you can make it working by copying the dll npswf32.dll in the
plugin repertory :
ProgramFiles > OOo 2.x > program > plugin
If you want to test ...
Comment 32 philipp.lohmann 2008-10-07 14:37:37 UTC
taking this issue for windows, linux is a different matter, see issue 84584
Comment 33 interele 2008-10-08 09:23:33 UTC

Is this true for 3.0 ?

I don't have a plugin directory in ProgramFiles > OOo 3.x > program > ????

I made one and put the dll there and nothing happened


Comment 34 flecher 2008-10-08 18:08:39 UTC
I don't understand
This issue is for all OS ? For linux the issue is 84854 ?

Excuse for bad English
Comment 35 flecher 2008-10-08 18:15:55 UTC

This issue is close !!!
in 'My votes", the issue is "close" !!!!
Comment 36 philipp.lohmann 2008-10-09 09:58:40 UTC
The Shockwave/Flash plugin does not work in OOo on multiple platforms (Windows,
Linux, Mac), but for different reasons. On Windows - which I'll handle in this
issue - the plugin is simply not found these days, the place where to find it is
handled differently in the windows registry than before. On Linux the plugin
works, but not the newer version 9 plugin, because that newer plugin relies on
gtk instead of the Xt toolkit (which was the used in older versions of

I hope that explains it a little.
Comment 37 interele 2008-10-09 20:29:52 UTC
Actually no,

I understand why the Linux one fails but I didn't understand the Windows
problem - as per my post above - what do I have to do to get Windows OO
working ? I did what was suggested in the post by jmpierre and made a 
directory  put the dll there - and it didn't work -  do I have to fiddle 
in the registry?

If the Windows version works I can get people using OO on Windows and then
once they are comfortable with that, sneak Linux in while they are not looking
;-) ( assuming that at some point in the future OO and Flash can have a meeting
of minds and get it working ???? )


Comment 38 philipp.lohmann 2008-10-10 10:17:54 UTC
The most simple way would be to wait for 3.0.1 which will contain this fix.
Alterenatively you can create a plugin subdirectory in <office>\program for
OOo2.4 or <office>\ 3\Basis\program for OOo3.0 and copy the flash
plugin to it where it will be found. The flash plugin is called NPSWF32.dll and
can be found e.g. in the WINDOWS\system32\Macromed\Flash\ directory (at least
that is where it was installed on my system).

Hope that helps.
Comment 39 interele 2008-10-13 09:15:57 UTC
Will 3.0.1 have the fix in the Linux version or just Windows ?


Comment 40 philipp.lohmann 2008-10-13 09:25:02 UTC
Please see my comments above. The linux issue has a different root cause and
will be handled in issue 84584. The plan is to have it in 3.0.1 also, but it is
not fixed yet.
Comment 41 interele 2008-10-13 09:34:00 UTC
Yes, I did read the post - the implication was that the Windows fix
was 'relatively' trivial, in that, OO just has to find the plugin, whereas
in Linux you have to re write a lot as flash expects a lot of stuff
that might not be there - hence a .0.1 release seemed very quick to do 
all that.    

BTW I have done what you said ( in XP ) and it still doesn't work for me 
Would you like me to send you the offending powerpoint file so you can
see the problem.



Comment 42 philipp.lohmann 2008-10-13 09:51:12 UTC
If the already attached SWFinODP.odb and exampleSWF.swf work for you but your
.ppt not, then it could help. If they also do not work for you, then the plugin
is still not found.
Comment 43 interele 2008-10-13 10:03:05 UTC
Forget it ... I am being an idiot 
We are now cooking with gas ... :-)


Comment 44 philipp.lohmann 2008-10-16 10:19:12 UTC
interele: assuming that was you sending me a ppt, I tried to answer, but you
mail server rejects my address.

The flash in the ppt indeed do not show; I have not confirmed yet why. I suspect
something goes wrong when importing it, but am not yet sure. Just for
confirmation: the ppt contains the flash files, not only references to them, right ?
Comment 45 philipp.lohmann 2008-10-24 14:29:55 UTC
please verify in CWS swffixes
Comment 46 wolframgarten 2008-10-29 13:55:52 UTC
Verified in CWS.
Comment 47 andreschnabel 2008-10-29 14:00:08 UTC
*** Issue 84585 has been marked as a duplicate of this issue. ***
Comment 48 interele 2009-01-15 11:40:24 UTC
This still doesn't work for me.
I am trying 3.0.1 RC2 on XP
I have opened a Powerpoint presentation ( in the same 
series as the one I sent you ) and all I get is a big 
X where the Flash game should be. 

Should it have worked ?


Comment 49 wolframgarten 2009-01-15 12:36:03 UTC
Yes it should;-) You need to have a flash player plugin installed (for example
Comment 50 interele 2009-01-15 13:02:21 UTC
Then I must be doing something wrong as it doesn't :-(

I uninstalled the older versions of OO - installed RC2 -
I have Flash installed - I am using FF so I installed the 
exe that you get from Adobe - Flash works fine in FF

I can send you a screenshot or the presentation if that 
would help ... or alternatively if you can suggest how
I've managed to break it ;-) The presentation is a 
BoardWorks one ( like the one I sent to pl )


Comment 51 wolframgarten 2009-01-16 09:08:28 UTC
When you open Insert/Object/Plugin/Browse do you have in "Files of type"
Shockwave Flash .swf listed? Then the plugin is installed correctly and should
work. Please have a look. And is your RC2 really a OOO300-m15? Thanks in advance.
Comment 52 interele 2009-01-16 18:50:13 UTC
I am at home so I have done this all from scrath
Install XP Pro
Install FF
Install Flash  ( Youtube works fine )
Install OO RC2 OOO300-m15
Checked Insert/Object/Plugin/Browse - OK
Got my collegue to email me the powerpoints from work
OO imports them OK except for the flash animations
Install MS Office 2003 just to check that the presentation does contain 
the flash and it's not a link to somewhere else  - Powerpoint shows 
embedded flash OK ( Incidentally one thing I did try was
using the powerpoint viewer and they don't work in that ) 

These are 'bought' powerpoints from UK educational company ( are you in UK ? )
I spoke to them a while ago when I first started moaning about this :-)
They say they are not doing anything clever, they are just embedded flash

Can I just email one of these presentations to you so you can have a look ?
They are about 2-3M - then you can see if a) I am bonkers or b) the powerpoints
are not as simple as the company say or c) 3.0.1 is still not well



Comment 53 interele 2009-01-29 12:58:30 UTC
<broken record>
Doesn't work in the released version of 3.0.1

</broken record>
Comment 54 wolframgarten 2009-02-06 14:07:15 UTC
Tested in m41. Closed.
Comment 55 interele 2009-02-06 21:24:56 UTC
No it isn't :-(

Please, give me an email or somewhere  that I can send you one
of these powerpoint presentations. If you can make it work I 
will go away and never return. I cannot get them to work properly

I have tried the m41 that is on the site and it still doesn't work

best wishes

Comment 56 interele 2009-02-25 09:18:07 UTC
I have done some more experimenting

If you take these particular ppt presentations and open them in OO ( 310_m2 )
the embedded flash doesn't work.

If you open them in powerpoint and drag the flash object out of them to a
'scrap' file then run them through flashextractor to get the swf file then
open the ppt in Impress and replace the embedded flash with the extracted
swf they work perfectly

So I would agree that embedded flash does work - it's just the importing
that doesn't  


Comment 57 wolframgarten 2009-07-29 13:49:36 UTC
In DEV300-m53 exampleSWF.swf works for me here on WinXP and Linux . Also
SWFinODP.odp works.
This issue has changed from a general "flash does not work" to "flash in PPT
files gets not imported".
Flash in general works. you can easily check this by inserting a swf file from
\windows\help\Tours\mmtour into a document and play: it works.
Not working flash in PPT import is something different. I have setup a new issue
for this: i103876
Comment 58 sthibaul 2009-09-18 13:19:23 UTC
This seems to be broken again

In 3.1.1 OOO310m19 (Build:9420), debian package
1:3.1.1-1, I only get a grey square. In the terminal where I ran office
I'm getting

** (soffice:5519): WARNING **: Inhibit method failed

** (soffice:5519): WARNING **: Inhibit problem : The name org.gnome.ScreenSaver was not provided by any .service files
Not GTK2 toolkit (got 0).

This is really a blocker for us, reverting to using MSOffice
Comment 59 interele 2009-09-29 13:08:43 UTC
If you are following this please see 105442 
The ppt that I am trying to open now crashes 
Impress instead of just not working ( so I
did a new bug report )