Issue 50215 - Curved connector in presentation loses some curves in odp to ppt export
Summary: Curved connector in presentation loses some curves in odp to ppt export
Status: CLOSED DUPLICATE of issue 13026
Alias: None
Product: Impress
Classification: Application
Component: code (show other issues)
Version: OOo 2.0 Beta
Hardware: All Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: sven.jacobi
QA Contact: issues@graphics
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-01 21:41 UTC by t35t0r
Modified: 2013-08-07 15:21 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
odp presentation file with curved connector (11.10 KB, application/vnd.oasis.opendocument.presentation)
2005-06-01 21:42 UTC, t35t0r
no flags Details
curved connector ppt file produced from ppt export (154.50 KB, application/vnd.ms-powerpoint)
2005-06-01 21:42 UTC, t35t0r
no flags Details
png file showing the difference between the odp and the exported ppt (136.31 KB, image/png)
2005-06-01 21:43 UTC, t35t0r
no flags Details
curved connector sxi presentation file (10.62 KB, application/vnd.sun.xml.impress)
2005-06-01 21:48 UTC, t35t0r
no flags Details
curved connector ppt file produced from sxi to ppt export (151.50 KB, application/vnd.ms-powerpoint)
2005-06-01 21:49 UTC, t35t0r
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description t35t0r 2005-06-01 21:41:20 UTC
1) Make two objects, and orient them in such a way that a curved connector will
become curved when you try to connect the two objects. 2) Create a curved
connector with connectors on both ends. 3) Attach the two objects with the
curved connector so that there are multiple "curves" or "kinks" in the line. 4)
Optionally take off one of the arrow heads so the line goes in one direction. 5)
Save the file in ODP presentation format. 6) Save the file in MS Office PPT
format. 7) Load ppt in office 2000, 2003, or older.

You will see that the curved connector in the PPT loses some of its "curves" or
"kinks".
Comment 1 t35t0r 2005-06-01 21:42:07 UTC
Created attachment 26814 [details]
odp presentation file with curved connector
Comment 2 t35t0r 2005-06-01 21:42:43 UTC
Created attachment 26815 [details]
curved connector ppt file produced from ppt export
Comment 3 t35t0r 2005-06-01 21:43:07 UTC
Created attachment 26816 [details]
png file showing the difference between the odp and the exported ppt
Comment 4 t35t0r 2005-06-01 21:47:55 UTC
This same error occurs if you save the presentation as SXI and then import it
into PPT.
Comment 5 t35t0r 2005-06-01 21:48:55 UTC
Created attachment 26817 [details]
curved connector sxi presentation file
Comment 6 t35t0r 2005-06-01 21:49:29 UTC
Created attachment 26818 [details]
curved connector ppt file produced from sxi to ppt export
Comment 7 t35t0r 2005-06-01 21:54:14 UTC
I'm using version 1.9.104.
Comment 8 wolframgarten 2005-06-02 08:19:07 UTC
Reproducible.
Comment 9 wolframgarten 2005-06-02 08:19:26 UTC
Reassigned.
Comment 10 sven.jacobi 2005-06-02 10:18:18 UTC
Yes, we are having some problems with connector objects. In general the
import/export of connectors needs to be reworked completely. Therefore we
already have issue 13026.

*** This issue has been marked as a duplicate of 13026 ***
Comment 11 wolframgarten 2005-06-02 10:32:47 UTC
Ok, closed.