Issue 50379 - graphical artifacts when scrolling during graphic selection
Summary: graphical artifacts when scrolling during graphic selection
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0
Hardware: PC All
: P4 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-06 14:37 UTC by tuxedo
Modified: 2017-05-20 11:26 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
The file where those artifacts happen, the grafic shown in the screenshot is on the second page (13.12 KB, application/vnd.sun.xml.writer)
2005-06-06 14:39 UTC, tuxedo
no flags Details
shows how the artifacts look like, the horizontal lines are artifacts or the selection tool they have not been drawed ;-) (32.71 KB, image/jpeg)
2005-06-06 14:41 UTC, tuxedo
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description tuxedo 2005-06-06 14:37:45 UTC
OO has a feature I would call "selection auto scroll", if you select something
and you came to the top or bottom of the screen OO automatically scrolls to
allow the user to select withought stopping the select action.

If the user selects the graphical selection tool (its icon looks like a mouse
cursor),tries to select a graphic then OO shows the bounding-box of the
selection tool. If OO performs its autoscrolling, there are still parts of old
bounding boxes visible, where the box has been before scrolling happens.
These artifacts are corrected if you force OO to repaint the document-canvas
(window-move, ...).

I think its not really problematic its just one of those ugly things
word-processors must have ;)
Comment 1 tuxedo 2005-06-06 14:39:03 UTC
Created attachment 26948 [details]
The file where those artifacts happen, the grafic shown in the screenshot is on the second page
Comment 2 tuxedo 2005-06-06 14:41:15 UTC
Created attachment 26949 [details]
shows how the artifacts look like, the horizontal lines are artifacts or the selection tool they have not been drawed ;-)
Comment 3 tuxedo 2005-06-06 14:41:47 UTC
btw I was able to reproduce this on OO2_100 and OO-1.1.3
Comment 4 michael.ruess 2005-06-07 10:01:37 UTC
MRU->OD: the paint problem when using the selection tool for drawings. Take this
in favor for internal #117772.
The "artifacts" can be cleared by using Ctrl-Shift-R (manual screen refresh of
Writer document).
Comment 5 Marcus 2017-05-20 11:24:52 UTC
Reset assigne to the default "issues@openoffice.apache.org".
Comment 6 Marcus 2017-05-20 11:26:03 UTC
Reset assigne to the default "issues@openoffice.apache.org".