Issue 50449 - Tables of contents configured using "Additional Styles" do not display as hyperlinks correctly
Summary: Tables of contents configured using "Additional Styles" do not display as hyp...
Status: CLOSED DUPLICATE of issue 3356
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: 680m107
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: eric.savary
QA Contact: issues@sw
URL: http://62.3.99.93/ooofiles
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-07 21:46 UTC by bert64
Modified: 2005-06-08 09:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Demonstrates the lack of hyperlinks when using "Additional Styles" tables of contents (422.92 KB, application/vnd.sun.xml.writer)
2005-06-07 21:49 UTC, bert64
no flags Details
Demonstrates the lack of hyperlinks when using "Additional Styles" tables of contents (422.92 KB, application/vnd.oasis.opendocument.text)
2005-06-07 21:50 UTC, bert64
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description bert64 2005-06-07 21:46:28 UTC
Tested on:
OpenOffice.org m680 m107 (MacOSX)
OpenOffice.org m680 m104 (Linux)

When inserting a table of contents into a document and selection "Additional
Styles" for the creation of the TOC and then moving to the Entries tab and
trying to define hyperlinks the hyperlinks will not be created.
If you create the table of contents using Create from "Outline" the hyperlinks
are correctly created. 
If you use a mixed table of contents then the ones created from the outline will
hyperlink correctly while the ones created from the additional styles will not.

An example document showing this behavior is available from:
http://62.3.99.93/ooofiles/brokentable.odt

This file has 2 table of contents added at the top. The first one uses
"additional styles" and the hyperlinking does not work.. The second one uses
"Outline" and the hyperlinking works as expected
Comment 1 bert64 2005-06-07 21:49:41 UTC
Created attachment 27001 [details]
Demonstrates the lack of hyperlinks when using "Additional Styles" tables of contents
Comment 2 bert64 2005-06-07 21:50:02 UTC
Created attachment 27002 [details]
Demonstrates the lack of hyperlinks when using "Additional Styles" tables of contents
Comment 3 michael.ruess 2005-06-08 08:25:08 UTC
Reassigned to ES.
Comment 4 eric.savary 2005-06-08 09:21:52 UTC
duplicate

*** This issue has been marked as a duplicate of 3356 ***
Comment 5 eric.savary 2005-06-08 09:22:04 UTC
closed