Issue 50481 - A short cut Ctrl-A works, but Edit - Select All is disable.
Summary: A short cut Ctrl-A works, but Edit - Select All is disable.
Status: RESOLVED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: 680m104
Hardware: All Windows, all
: P4 Trivial (vote)
Target Milestone: 4.1.0
Assignee: ab
QA Contact:
URL:
Keywords: oooqa
: 52430 (view as issue list)
Depends on:
Blocks:
 
Reported: 2005-06-08 12:57 UTC by tora3
Modified: 2014-01-22 08:14 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description tora3 2005-06-08 12:57:38 UTC
Reproduction:
  1. Tools - Macros - Organize Macros - OpenOffice.org Basic
  2. Attempt to do the "Select All" from the menu in the IDE.
     You would not be able to choose it because of being disable.
  3. Try to do that by typing Ctrl-A.
     Surprisingly, you would make it.

Expectation:
  "Select All" under the Edit menu can be enable any time.
Comment 1 Oliver Specht 2005-06-08 13:01:56 UTC
.
Comment 2 christianjunker 2005-09-28 15:16:37 UTC
wrong component. I guess framework is better suited here, changing..
Comment 3 thomas.benisch 2005-12-07 15:30:23 UTC
TBE->AB: As discussed to you.
Comment 4 ab 2006-05-17 12:22:48 UTC
P4, STARTED
Comment 5 joerg.skottke 2006-08-31 07:14:22 UTC
*** Issue 52430 has been marked as a duplicate of this issue. ***
Comment 6 joerg.skottke 2006-08-31 07:17:10 UTC
This causes massive warnings and errormessages for automated testing.
Created a workaround in framework/tools/inc/basicide_tools.inc.
Comment 7 SVN Robot 2014-01-22 07:47:19 UTC
"hanya" committed SVN revision 1560270 into trunk:
#i50481# make Select All command working through the main menu of Basic IDE
Comment 8 hanya 2014-01-22 08:14:42 UTC
Fixed on trunk.
The part of the dialog editor does not support Select All, so if the window 
is switched to the dialog editor, Select All command is disabled in the main menu, 
until Select All command is implemented for the DialogWindow class.