Issue 50867 - insert Horizontal ruler jumps me to end of document
Summary: insert Horizontal ruler jumps me to end of document
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0
Hardware: All All
: P3 Trivial with 3 votes (vote)
Target Milestone: 4.2.0
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 50861 69956 (view as issue list)
Depends on:
Blocks:
 
Reported: 2005-06-16 22:13 UTC by watersrw
Modified: 2017-05-20 10:35 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
jump_to_beginning_or_end_of_file.odt: sample document with frames (43.81 KB, application/vnd.oasis.opendocument.text)
2012-12-18 21:24 UTC, stfhell
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description watersrw 2005-06-16 22:13:32 UTC
get any multi-page document or create one
go somewhere near beginning in m104
do insert menu | Horizontal ruler ...
see that whilst ruler is inserted, you are magically transported to the end of
the document
Comment 1 michael.ruess 2005-06-17 09:13:00 UTC
MRU->OS: the "Horizontal ruler" will be inserted in the correct place, but the
cursor will blink in last position of the document after this.
Comment 2 michael.ruess 2005-06-17 12:28:41 UTC
*** Issue 50861 has been marked as a duplicate of this issue. ***
Comment 3 lo_alison 2006-01-26 03:26:44 UTC
A multi-page document isn't necessary to demonstrate the bug:

STEPS
- From the FILE menu, navigate to the NEW submenu to create a new TEXT DOCUMENT
- Enter text on a couple of lines
- Move the cursor higher up in the document
- From the INSERT menu, select HORIZONTAL RULER and choose a style
- The horizontal line will be inserted but the cursor will be positioned at the
end of the document

EXPECTED BEHAVIOUR: the cursor position remains where it was prior to the
insertion of the horizontal line

This problem occurs on both Windows and Linux platforms (Windows XP, Fedora Core
3, Red Hat Linux 7.3) using Open Office 2.0.

This bug can be quite annoying when the distance between the end of the document
and the newly inserted horizontal line is large, but it is hardly noticeable
when the two appear on the same screen view, allowing the cursor to be quickly
positioned with a single mouse click and without scrolling.
Comment 4 michael.ruess 2006-09-29 08:18:47 UTC
*** Issue 69956 has been marked as a duplicate of this issue. ***
Comment 5 stfhell 2012-12-18 21:24:26 UTC
Created attachment 80046 [details]
jump_to_beginning_or_end_of_file.odt: sample document with frames

This bug is really much more versatile and is not limited to horizontal rulers. When editing frames or images, Writer often jumps the view position to the beginning or the end of the file. This can be triggered
- by insertion of an image or a frame
- by changing the anchor type of a frame
- by pasting oder undoing a frame
(This is just a summary of what I have observed; very likely not complete.)

I'm attaching a sample document. Tests have been done on AOO 3.4.1 and snapshot AOO350m1(Build:9611) Rev. 1420743/2012-12-13 under Ubuntu 12.04/AMD64.
- Open file "jump_to_beginning_or_end_of_file.odt".
- Use Navigator and go to chapter "Copy and paste a frame!". Mark first frame in margin, copy it (Ctrl-C) and paste it into verious paragraphs (Ctrl-V). For AOO35 it takes while, but after some 30 pastes the view jumps to start of file. 
- Mark any of the frames, delete it and undo this via Ctrl-Z. View jumps to beginning of file.
- Insert a ruler (menu Insert/Horizontal ruler); or drag/insert an image (JPEG, PNG, EPS, TIF) somewhere. View jumps to end of file.
- Take one of the inserted images and change the anchoring type a few times. Eventually the view jumps to end of file.
Comment 6 Oliver-Rainer Wittmann 2012-12-19 08:08:56 UTC
CC myself
Comment 7 rgb 2013-01-04 14:01:08 UTC
I've seen this on a couple of long documents (I cannot share them, sorry). It seems that only the view point jumps, not the cursor position: if after the jump I press ESC the view point moves again below the inserted/modified frame so it seems that the frame remains selected.
Comment 8 rauer 2013-07-31 15:41:07 UTC
please see
https://issues.apache.org/ooo/show_bug.cgi?id=121219
Comment 9 Ariel Constenla-Haile 2013-09-04 20:35:16 UTC
Resetting assignee
Comment 10 Oliver-Rainer Wittmann 2014-07-15 12:47:26 UTC
fixed by changes made for issue 121443