Issue 50959 - OOo crashes when opening an odt-document
Summary: OOo crashes when opening an odt-document
Alias: None
Product: Writer
Classification: Application
Component: viewing (show other issues)
Version: 680m109
Hardware: All All
: P3 Trivial with 4 votes (vote)
Target Milestone: ---
Assignee: openoffice
QA Contact: issues@sw
Depends on:
Reported: 2005-06-19 18:55 UTC by sigrid.carrera
Modified: 2013-08-07 14:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

The first document with the opening-error. (19.93 KB, application/vnd.oasis.opendocument.text)
2005-06-19 18:58 UTC, sigrid.carrera
no flags Details
Second document with the same opening-error (23.20 KB, application/vnd.oasis.opendocument.text)
2005-06-19 18:59 UTC, sigrid.carrera
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description sigrid.carrera 2005-06-19 18:55:56 UTC

I have the following problem: I've started to translate an installation guide
from German into French. The originial document was saved as an odt-file, so the
new version was also an odt-file. 

I closed OOo, saved all my changes, shutdown my PC. When I tried to open the
document today, OOo crashes, and sent an automatic error-report.

I have this problem with two different files, which I will add immediately. 

I'm using Linux (Mandriva Official 10.1), with 1.9.109.

I hope you can solve this problem. 


Comment 1 sigrid.carrera 2005-06-19 18:58:04 UTC
Created attachment 27315 [details]
The first document with the opening-error.
Comment 2 sigrid.carrera 2005-06-19 18:59:39 UTC
Created attachment 27316 [details]
Second document with the same opening-error
Comment 3 sigrid.carrera 2005-06-19 21:21:14 UTC
I'm not sure, if it's necessary/important, but I have recorded my changes. 

And I heard from an other user, that he can open the files without any problems
after downloading from the issue. When he save the files on his own hard disk
and try to reopen, than he has the same problems. 

Comment 4 michael.ruess 2005-06-20 08:49:16 UTC
MRU->FME: pls have a look. There happens a loop right at the beginning of
reformatting process. Also the Assertions "Element nicht im Block" comes up.
Comment 5 frank.meies 2005-06-20 09:24:13 UTC
FME->HBRINK: No loop, crashes in UpdateOutlineNode(), Assertion is also
numbering related. Please have a look.
Comment 6 shchepetov 2005-06-23 17:18:51 UTC
Have almost same trouble. After opening an .odt document (text with a lot of 
images, 30pages, 4MBytes) it works for some seconds, then crashes (uses the 
processor for 100% and doesn't do anything, I have to terminate the task). 
Tried in versions 1.9.104 and 1.9.109.
Tried to increase dedicated memory (up to 200MB for OpenOffice, up to 50MB for 
I think it happens while text/images reformatting..
Comment 7 openoffice 2005-08-03 14:06:50 UTC
Comment 8 openoffice 2005-08-24 15:07:23 UTC
fixed in swnumtree
Comment 9 Mathias_Bauer 2007-02-05 13:57:43 UTC
going to close ancient issues
Comment 10 Mathias_Bauer 2007-02-05 14:10:53 UTC
closing ancient issues