Issue 50998 - inserting nested frames hangs writer
Summary: inserting nested frames hangs writer
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 680m109
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
: 54298 (view as issue list)
Depends on:
Blocks: 54298
  Show dependency tree
 
Reported: 2005-06-20 15:28 UTC by mhosken
Modified: 2013-08-07 14:42 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Take this to reproduce... ;-) (6.14 KB, application/vnd.oasis.opendocument.text)
2005-06-21 12:57 UTC, michael.ruess
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description mhosken 2005-06-20 15:28:03 UTC
When creating frames within frames, writer can hang. The following procedure
shows this:

Insert/Frame...
 . width = 2.00cm (default)
 . width automatic
 . anchor as character
 . borders tab - no borders

Into this frame type: antidisestablishmentarianism and <Enter> to make a blank
line in the frame

at the start of this blank line within the frame:

Insert/Frame...
 . width 1.00cm
 . width automatic
 . anchor as character
 . borders - no borders

Into this box type:
   anti-
   against

click the cursor to be after the frame just inserted while still inside the
outer frame

Insert/Frame...
 . width 1.00cm
 . width automatic
 . anchor as character
 . borders - no borders

clicking OK may well hang writer, if not, into this frame type:
  dis-
  remove

click after this box (all still within the outer frame)
Insert/Frame...
 . width 1.00cm
 . width automatic
 . anchor as character
 . borders - no border

click OK and writer will hang. If not keep going seeing how many glosses of the
morphemes of anti-dis-establish-ment-arian-ism you can fill in :)

As you can see this is a very powerful mechanism for the display of interlinear
text as used by linguists. It would be very helpful to many people around the
world for this bug to be fixed.
Comment 1 michael.ruess 2005-06-21 12:57:40 UTC
Created attachment 27370 [details]
Take this to reproduce... ;-)
Comment 2 michael.ruess 2005-06-21 13:08:15 UTC
MRU->OD: take the attachment to reproduce. Just open it, place cursor left of
inner frame and via dialog insert a frame with :
- width 1.00cm
- width automatic
- anchor as character
- borders - no borders

This will loop Writer.
Comment 3 Oliver-Rainer Wittmann 2005-07-29 09:19:57 UTC
first investigation reveals that the autowidth attribute of the frames makes
trouble - too much invalidations are performed for autowidth frames.
Comment 4 Oliver-Rainer Wittmann 2005-07-29 10:01:08 UTC
fixed in cws swqbf35 - changed file:
/sw/source/core/layout/frmtool.cxx, 1.80.94.1

solution:
no invalidation of the position of an upper autowidth fly frame, because it's
not needed and causes layout loops.
Comment 5 Oliver-Rainer Wittmann 2005-08-22 09:55:19 UTC
OD->MRU:
Checked in internal installation set of cws swqbf35 - please verify.

re-open issue and reassign to mru@openoffice.org
Comment 6 Oliver-Rainer Wittmann 2005-08-22 09:55:33 UTC
reassign to mru@openoffice.org
Comment 7 Oliver-Rainer Wittmann 2005-08-22 09:55:42 UTC
reset resolution to FIXED
Comment 8 michael.ruess 2005-08-24 10:36:57 UTC
Verified fix in CWS swqbf35.
Comment 9 Oliver-Rainer Wittmann 2005-09-07 07:27:05 UTC
*** Issue 54298 has been marked as a duplicate of this issue. ***
Comment 10 michael.ruess 2005-10-06 10:31:27 UTC
Checked fix in build 680m132.