Issue 51068 - Count should ignore errors
Summary: Count should ignore errors
Status: CLOSED DUPLICATE of issue 86643
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 2.0 Beta
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: ooo
QA Contact: issues@sc
URL:
Keywords: ms_interoperability
Depends on:
Blocks:
 
Reported: 2005-06-21 20:48 UTC by navvy
Modified: 2013-08-07 15:12 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description navvy 2005-06-21 20:48:13 UTC
When Excel counts a range using =COUNT(D4:D191) the result is the number of 
valid numbers only.  Any cells that contain calculation errors, and display 
#N/A are ignored.  The result is a number.

Open Office Calc recognises the errors and shows an error in its own result.  
Count is supposed to show the number of valid numbers.  Errors are not valid 
numbers, and therefore should be ignored.
Comment 1 frank 2005-06-30 12:12:14 UTC
Hi Niklas,

possible for 2.0.1 ?

If not please adjust target.

Frank
Comment 2 niklas.nebel 2005-07-05 09:31:34 UTC
Compatibility issue, but certainly nothing for 2.0.1.
Comment 3 ooo 2005-07-05 12:43:35 UTC
Accepted. Though for interoperability there would be more to be excluded than
just error values, for example logical values. Changing the behavior may of
course also produce different results for already existing documents. Not to be
changed silently.
Comment 4 navvy 2005-07-05 14:26:41 UTC
I'm sure this won't be the only case where fixing a bug causes spreadsheets to 
give different results in oo1.4 and oo2.0.  In this case it's perhaps more of 
a difference of interpretation over what should be counted.  Both 
interpretations might be correct if they match what is described in the 
program documentation, but the important thing for Open Office to be accepted 
by former Excel users is that OO should give the same results as Excel without 
the user having to fiddle with any settings.

Having several modes, where formulas either follow Excel rules or oo1.0 or 
oo2.0 rules, would not be sensible.  The journalists who write magazine 
reviews would have a field day!

Excel 2003 has started putting green blobs on any cells that it thinks look 
odd, such as numbers that are text, or formulas that are different from the 
adjacent formulas.  A text message like a tooltip is displayed to show what 
might be wrong.  This technique might be a possible way for Open Office to 
warn the user about ambiguous functions.

In this particular case, I can see that Open Office has a safer approach in 
that an error will be propagated, whereas Excel may hide the error from the 
user.  In my case the error was unimportant so I preferred Excel's approach, 
but that might not always be the case.
Comment 5 ooo 2009-01-29 11:51:38 UTC
Fixed with issue 86643 in OOo3.0

*** This issue has been marked as a duplicate of 86643 ***
Comment 6 ooo 2009-01-29 11:51:59 UTC
Closing.