Issue 51359 - Can't add text frame to MailMeerge document
Summary: Can't add text frame to MailMeerge document
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: 680m111
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-29 12:24 UTC by gkocur
Modified: 2013-08-07 14:42 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Source document (6.09 KB, application/vnd.oasis.opendocument.text)
2005-06-29 20:38 UTC, gkocur
no flags Details
Merged document (6.44 KB, application/vnd.oasis.opendocument.text)
2005-06-29 20:44 UTC, gkocur
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description gkocur 2005-06-29 12:24:43 UTC
When creating MailMerge document(s) based on text document with text frame this
frame "disappears" in target document.

My steps:
- New text document
- Insert - Frame
- Tools - Mail Merge Wizard
- Use current document
- Next wizard steps

There is no frame on resultant document.
Comment 1 michael.ruess 2005-06-29 12:54:50 UTC
Reassigned to HI.
Comment 2 h.ilter 2005-06-29 15:48:31 UTC
Please provide a sample to evaluate.
Comment 3 gkocur 2005-06-29 20:38:40 UTC
Created attachment 27569 [details]
Source document
Comment 4 gkocur 2005-06-29 20:44:20 UTC
Created attachment 27570 [details]
Merged document
Comment 5 gkocur 2005-06-29 20:47:16 UTC
I open file frame1, choose Tools - Mail Merge Wizard, select Use current document.
In all steps I use defaults.

Same effect if I edit document in step 6 and add text frame - this frame
disappears on merged document.
Comment 6 h.ilter 2005-06-30 13:46:31 UTC
I can't reproduce it, nor with your sample. So where is the trick.
HI->OS: Do you have any idea what could it be.
Comment 7 gkocur 2005-07-01 03:56:06 UTC
I have checked it now with m113 on Windows, works as expected. I will check
tomorrow on Linux.
Previously I used m111 on Linux and m104 on Windows.
Comment 8 gkocur 2005-07-02 11:19:02 UTC
Sorry, in m133 the same problem.
I use following procedure:

- Start Writer
- Insert > Frame > OK (all default)
- Tools > Mail Merge Wizard...
- Use the current document > Next
- Letter > Next
- This document shall contain an address block > Next 
- Uncheck "This document shall contain salutation" > Next
- (defaults) > Next
- (defaults) > Next
- (defaults) > Next
I think here is the trick:
- Save merged document, Save as single document > Save Documens > some_file_name
> Save
- Finish
- Open
- some_file_name,odt > Open

There is only one text frame (address block) in some_file_name.odt file.
Checked on m113 (Sun's build), Windows2k

Hope this helps.

Comment 9 h.ilter 2005-07-08 13:57:50 UTC
Ok, I got it.
The trick is step4 (disabled salutation)

HI-OS: Run Mailmerge like the last description from gkocur once with enabled and
once with disabled salutation. You will see the difference at step7.
Strange: When you go back from step7 to step6, the frame is also back and will
disappear again on step7.

HI->gkocur: Man, that was very tricky. Thanks for your effort :)
Comment 10 Oliver Specht 2005-08-23 14:45:55 UTC
Fixed in cws os64 in 
sw/source/ui/dbui/dbmgr.cxx
Comment 11 Oliver Specht 2005-09-01 15:14:43 UTC
Reassigned for verification

re-open issue and reassign to hi@openoffice.org
Comment 12 Oliver Specht 2005-09-01 15:15:01 UTC
reassign to hi@openoffice.org
Comment 13 Oliver Specht 2005-09-01 15:15:43 UTC
reset resolution to FIXED
Comment 14 h.ilter 2005-09-09 10:31:09 UTC
Verified with cws os63 = ok
Comment 15 h.ilter 2005-11-01 14:20:47 UTC
Still ok in master 680m137_8972.