Issue 51551 - creating a key field
Summary: creating a key field
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Native-Lang
Classification: NLC
Component: www (show other issues)
Version: OOo 2.0
Hardware: Other Other OS
: P3 Trivial
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-04 17:22 UTC by cjgarcia
Modified: 2020-03-27 11:50 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description cjgarcia 2005-07-04 17:22:45 UTC
I'm using Ooo 2.0 Beta on a Fedora Core 4 (Intel Platform). The Ooo Base 
application crash every time with this process:
- Create a table with some fields without a primary key, save and close it.
- Edit this table and create a primary key in some of this fields.
- Close and save the changes. Then the program crash and you give this message:
   S1000 General error java.lang.NullPointerException in statement [ALTER 
TABLE "cd" ADD PRIMARY KEY ("b")]
Comment 1 oooforum (fr) 2020-03-27 08:39:53 UTC
Well, you have an explicit warning when you try to save at step 1: a primary key is necessary

However, I was not able to reproduce with AOO 4.1.7 and Windows 10 x64 Pro.