Issue 51702 - current character styles not showing in toolbar
Summary: current character styles not showing in toolbar
Status: CLOSED DUPLICATE of issue 29364
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: 680m113
Hardware: PC Windows XP
: P2 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: needmoreinfo, oooqa
Depends on:
Blocks:
 
Reported: 2005-07-07 20:25 UTC by anupkshah
Modified: 2005-07-08 07:28 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description anupkshah 2005-07-07 20:25:25 UTC
I downloaded the latest Open Office build yesterday (1.9.113)

In the word processor, I
1) type in some text
2) highlight a word or more, and select a Character Style from the Styles and
Formatting (e.g. Quotations)

Observed:
1) As expected: I get the style applied
2) NOT as expected: The "Apply Styles" drop down list in the "Formatting"
toolbar does not change; it continues to describe the current style as Default.

Having repeatedly tried this with various character styles, and custom styles, I
believe this is a problem whereby only the Paragraph Style is being shown for
the text where the cursor is.

The reason I say this is a defect, rather than an enhancement request, is that I
believe for people who rely on this styling information, this product is very
hard to use when having to maintain, edit, change character styles.

Example usage:
I use the Quotation style, rather than a simple Ctrl-i for italics, because
semantically speaking I may have text that is a quotation. When I convert this
to XHTML (using my own XSL rather than the in-built one, so I have more
control), I can tell that I need to use a <q> tag, rather than an <em> or <i> or
any other tag that can create a similar VISUAL effect. Doing so makes the
resulting HTML far more accessible, as the document semantics are far richer.

OpenOffice is potentially a great tool for people to write documents in a word
processed environment and have that converted not only to a validating XHTML
page, but also an accessible one.

I therefore place this issue as a defect with a higher priority.

Sincere apologies if this is a duplicate (I am a newbee to OpenOffice, and have
tried to search for existing issues and not found any).
Comment 1 Regina Henschel 2005-07-07 20:43:40 UTC
Please read issue 49766 and tell us, if the "silver" theme causes your error too.
Comment 2 anupkshah 2005-07-07 21:51:50 UTC
Regina,

I had a look at the issue you pointed to. I do indeed have a modified version of
the silver theme. I updated it as per that defect, and it does now highlight in
the style and formatting area.

However, that is not my main concern. I feel that the "Apply Styles" drop down
in the "Formatting" toolbar also needs to show this.

The reason is that when you are highlighting a text, if you only rely on the
Styles and Formatting area, then you have to know to select the character styles
first, and then switch to the Paragraph Styles, which is cumbersome.

I think the drop down in the toolbar should reflect the most accurate style, not
just the paragraph style. This immediately gives a lot of feedback to the user,
without any additional actions. I hope this can be done easily.

I don't know if I used the correct terms everywhere, so I saw this GIF in the
issue you pointed me to:
http://www.openoffice.org/nonav/issues/showattachment.cgi/10498/screenshot.gif

In that screenshot, the issuer highlights three areas in red, and numbers them.
It is number 2 that I am referring to.

Hope that helps.
Comment 3 anupkshah 2005-07-07 22:02:44 UTC
Regina,

Sorry for extra comment, but just had a thought about a workaround:

One could look at the "Available Styles" drop down, and always look at the
"Character Styles" list in the Styles and Formatting area. This way you can
always see which character style the current text is at.

I will try to therefore mark this issue as an enhancement request, but I think
the priority is just as high, as I think we still have some usability issues
here. For example, a user has to

- Rely on the above workaround means a user has to know about two areas of the
screen, the Styles and Formatting area, and the Available Styles drop down.
- Somehow have to know that the Available Styles drop down will only show
paragraph styles, not character styles.
- Figure out that the Styles and Formatting area is best used by selecting the
Character Styles

And so, for example, selecting a new paragraph style for their text, should they
toggle to the Paragraph Styles in Styles and Formatting or use that Available
Styles drop down?

Maybe most will go for the latter, but the point is that this is more user
effort than needed.

Maybe the Available Styles drop down has to change somehow to either:
- Indicate that these are only paragraph styles, and the user should use the
Styles and Formatting for other styles, such as Character Styles
- Or, in the Toolbar there should be another drop down next to the Available
Styles (but this could lead to clutter and more confusion)
- Maybe in the drop down for Available Styles, make it look like a
tree/hierarchy of options (similar to how <optgroup> works in HTML for <select>
tags.

Or maybe there is another option.

Not sure!
Comment 4 Regina Henschel 2005-07-07 22:23:39 UTC
Yes, now I understand you. Such a wish has been mentioned before in issue 29364.
If it is importend for you, you can vote for that issue.

The "Priority" of an issue doesn't meen, how importend it is for you, but how
importend it is for the whole project. Click on the word "Priority:" above to
see a description.

To get better search results with the "quick search", you should use the field
"Description contains:" and check "include closed issues".

*** This issue has been marked as a duplicate of 29364 ***
Comment 5 michael.ruess 2005-07-08 07:28:45 UTC
Closing duplicate.