Issue 51868 - WIN requires WORD 2000 components before OOo can open Powerpoint presentation
Summary: WIN requires WORD 2000 components before OOo can open Powerpoint presentation
Alias: None
Product: Impress
Classification: Application
Component: open-import (show other issues)
Version: 680m113
Hardware: PC Windows XP
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2005-07-13 05:12 UTC by Rainer Bielefeld
Modified: 2013-11-15 00:22 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

PP-Presentation to reproduce the bug (59.00 KB, application/
2005-07-13 05:16 UTC, Rainer Bielefeld
no flags Details
screenshot with error message (54.68 KB, image/png)
2005-07-13 05:17 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Rainer Bielefeld 2005-07-13 05:12:43 UTC
I checked with 2.0 (1.9.m113) German version WIN XP: [680m113(Build8930)] and
also have WORD 2000 on my PC (I believe that that is assumption to reproduce
that bug).

When I try to open attached .ppt, I get a message that WORD 2000 components must
be installed from cd. I get a nearby endless loop of "discard" and new
installation attempt. After app 5 times the message disappears OOo finishes to
open the installation. It seems that the presentation will be shown without

I also saw that problem when I made my tests for issue 51188
Comment 1 Rainer Bielefeld 2005-07-13 05:16:07 UTC
Created attachment 27867 [details]
PP-Presentation to reproduce the bug
Comment 2 Rainer Bielefeld 2005-07-13 05:17:07 UTC
Created attachment 27868 [details]
screenshot with error message
Comment 3 Rainer Bielefeld 2005-07-13 05:29:07 UTC
Forgot to say: that is new in 2.0, never waw that with 1.x.x
Comment 4 wolframgarten 2005-07-13 07:46:01 UTC
Comment 5 wolframgarten 2005-07-13 07:46:17 UTC
Comment 6 wolframgarten 2005-07-13 08:41:12 UTC
Sorry, wrong owner.
Comment 7 sven.jacobi 2005-07-20 11:31:09 UTC
sj->mav: I think it is the same problem as in issue 51574
Comment 8 mikhail.voytenko 2005-07-20 13:39:24 UTC
Indeed, this is a duplicate to the issue 51574.

*** This issue has been marked as a duplicate of 51574 ***
Comment 9 mikhail.voytenko 2005-07-20 13:45:32 UTC
Reopening to send to verification.
Comment 10 mikhail.voytenko 2005-07-20 13:48:53 UTC
MAV->MRU: This issue seems to be easier for verification than the issue 51574
since this one does not need fotoshop installation. So I send it to you as
discussed and the issue 51574 can be closed as a duplicate of this one.

I have checked the scenario on m117 and it worked well for me.
Comment 11 michael.ruess 2005-07-21 10:30:05 UTC
MRU->WG: I didn't encounter the problem on my MS-Office-less WInXP at home. But
to be sure, I would ask you to cross-check this on your machine, because from
the comments above I can see you were able to reproduce this. Thanks a lot ;-)
Comment 12 wolframgarten 2005-07-21 10:39:47 UTC
Opening the file with m118, m119 still the Microsoft Office XP installer comes
up asking for the installation source.
Comment 13 fbax 2007-02-12 23:29:51 UTC
The problem occurs (for me) only if some components of MS-Office 2000 are
installed.  I tried three different WinXP systems.
1) OOo201 with no MS-Office 2000 components - document opens.
2) OOo201 and MS-Office 2000 Word & Excel & Powerpoint - document asks for MS
install media.
3) OOo201 and MS-Office 2000 Word & Excel & NOT Powerpoint - document STILL asks
for MS install media.
Comment 14 Rainer Bielefeld 2007-02-13 06:45:56 UTC
I observe the same: on my current PC no WORD components are installed, and I
never see that message.
Comment 15 mikhail.voytenko 2007-02-13 10:08:03 UTC
Changing the target.
Comment 16 fbax 2007-02-13 15:54:50 UTC
Not every PPT document triggers the error.  I tried to open 12 PPT documents
which contained lecture notes (not sure if license/copyright allows these to be
shared).  One of them did manage to open without error on system where the other
11 all produced prompt for install media.  Are we already aware of what element
in document is triggering this behaviour, or do we need more details?
Comment 17 mikhail.voytenko 2007-03-15 15:13:51 UTC
I have just tried the scenario in SRC680/m202 build and can not reproduce the
problem. There is no try to activate any of the objects during the loading. If
the problem had appeared because the object had no size after the import, then
the problem is definitely fixed already.

MAV->WG: Could you please verify the issue.
Comment 18 wolframgarten 2007-03-19 10:01:35 UTC
Reassigned. Please handle.
Comment 19 christian.guenther 2007-04-27 14:21:51 UTC
I tested the issue several times and can't reproduce it.
Please tell me if the bug still occures in the latest stable version (OOo 2.2) 
Comment 20 christian.guenther 2007-05-11 12:46:35 UTC
I close the issue as works for me.
Please reopen it if you can still reproduce the bug with the latest OOo (2.2)
Comment 21 fbax 2007-05-14 18:25:21 UTC
OOo2.2 does not fix issue for me.  Do not miss the fact that MS-Word must be
installed to reproduce problem.
Comment 22 fbax 2007-07-09 14:09:48 UTC
Still a problem for me in 2.2.1 - I can't figure out how to reopen this issue -
can someone please assist?
Comment 23 christian.guenther 2007-08-17 12:15:12 UTC
I reopen the issue for but but nevertheless I can't reproduce it.
I don't get the error massage when I open the file and I don't get a 'word-Task'
in the task manager.
Therefore Word doesn't start when I load the file.
Maybe you made some settings e.g. in tools options?
Comment 24 christian.guenther 2007-08-17 12:18:22 UTC
I chage the target to Office later because I can't reproduce the bug.
Comment 25 christian.guenther 2007-09-21 09:52:05 UTC
I still can't reproduce the bug.
Please have a look in the latest version again and attach another bugdoc to
reproduce the bug if you can still reproduce the bug.
Comment 26 presidentloveth 2013-11-15 00:11:14 UTC
I can't replicate this bug when I used win 8. Perhaps you can try to reopen this again.
Comment 27 presidentloveth 2013-11-15 00:18:52 UTC
This bug can't replicate when win 8 was used. Perhaps the reporter can try to reopen this again.
Comment 28 presidentloveth 2013-11-15 00:19:37 UTC
This bug can't replicate when win 8 was used. Perhaps the reporter can try to reopen this again.
Comment 29 presidentloveth 2013-11-15 00:22:23 UTC
This bug can't replicate when win 8 was used. Perhaps the reporter can try to reopen this again.