Issue 52127 - OpenDocument <text:numbered-paragraph> element not supported on OpenDocument import
OpenDocument <text:numbered-paragraph> element not supported on OpenDocument...
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: open-import
OOo 2.0 Beta
All All
: P3 Trivial with 2 votes (vote)
: ---
Assigned To: michael.ruess
issues@sw
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-18 18:04 UTC by flr
Modified: 2013-08-07 14:43 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
testcase (5.80 KB, application/vnd.oasis.opendocument.text)
2005-09-28 13:15 UTC, dfaure
no flags Details
Another testcase (5.01 KB, application/vnd.oasis.opendocument.text)
2005-09-28 13:19 UTC, dfaure
no flags Details
another numbered-paragraph testcase (ODF1.0, KOffice 1.5) (5.34 KB, application/vnd.oasis.opendocument.text)
2008-07-30 10:51 UTC, mst.ooo
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description flr 2005-07-18 18:04:45 UTC
The <numbered-paragraph> element specified by the OpenDocument specification is
not implemented in to OpenDocument import filter.
Comment 1 dfaure 2005-09-28 13:15:00 UTC
Created attachment 29961 [details]
testcase
Comment 2 dfaure 2005-09-28 13:19:29 UTC
Created attachment 29963 [details]
Another testcase
Comment 3 dfaure 2005-09-28 13:30:40 UTC
I cannot stress enough how important it is that OpenOffice implements support  
for text:numbered-paragraph soon (before 2.0!), the whole point of the 
OpenDocument standard falls apart if KOffice and OpenOffice can't even exchange 
simple documents with numbered lists or bullets. 
 
I have attached two test documents, in the first one you should see 3 lines 
reading like  
1 	Firstname name	Parent1 & parent2	Address #	Zip	Place	
Tel#	11-22-2000 
between the first and the last paragraph. 
 
The second test document is self-explanatory. 
Comment 4 flr 2005-10-05 17:37:32 UTC
flr: Set to next available milestone. Sorry -- I've overseen the bug.
Comment 5 flr 2005-11-08 17:16:25 UTC
flr:
since we must have a clarifying discussion in the OpenDocument TC regarding the
semantic of <numbered-paragraph> I just implemented it in a way, such that
<numbered-paragraph> are imported without the number.
As soon as the TC clarified the correct semantic, a full implementation will
take place.
Comment 6 flr 2005-11-09 07:43:38 UTC
flr->es:
Could you please make a regression test and --- additionally --- test the
attached KWord documents. On import the <numbered-paragraph>s should appear
without a number.

After test, could you please reopen the issue and assign it to me with a PP2
target, such that I can implement the correct numbering for PP2 as soon as the
OpenDocument TC has clarified the correct semantic.
Comment 7 flr 2005-11-09 07:44:47 UTC
flr->es: As requested above. Thanks.

re-open issue and reassign to es@openoffice.org
Comment 8 flr 2005-11-09 07:44:54 UTC
reassign to es@openoffice.org
Comment 9 flr 2005-11-09 07:44:59 UTC
reset resolution to FIXED
Comment 10 eric.savary 2005-11-11 13:23:32 UTC
Verified in CWS knumber
Comment 11 flr 2005-11-14 09:01:29 UTC
flr: Modified files in CWS knumber:
Checking in core/xmltoken.cxx;
/cvs/xml/xmloff/source/core/xmltoken.cxx,v  <--  xmltoken.cxx
new revision: 1.95.44.1; previous revision: 1.95
done
Checking in text/txtimp.cxx;
/cvs/xml/xmloff/source/text/txtimp.cxx,v  <--  txtimp.cxx
new revision: 1.117.40.1; previous revision: 1.117
done
Checking in text/txtparai.cxx;
/cvs/xml/xmloff/source/text/txtparai.cxx,v  <--  txtparai.cxx
new revision: 1.52.42.1; previous revision: 1.52
done
Checking in text/txtparai.hxx;
/cvs/xml/xmloff/source/text/txtparai.hxx,v  <--  txtparai.hxx
new revision: 1.6.42.1; previous revision: 1.6
done
Checking in txtimp.hxx;
/cvs/xml/xmloff/inc/txtimp.hxx,v  <--  txtimp.hxx
new revision: 1.88.44.1; previous revision: 1.88
done
Checking in xmltoken.hxx;
/cvs/xml/xmloff/inc/xmltoken.hxx,v  <--  xmltoken.hxx
new revision: 1.90.44.1; previous revision: 1.90
done
Comment 12 eric.savary 2005-11-15 11:49:02 UTC
Ok in src680m140
Comment 13 flameeyes 2005-12-21 23:06:44 UTC
I just updated openoffice from gentoo to 2.0.1 (binary version, so the 
official release). Either a sample document created with KWord or the 
testcases here attached does not load correctly. 
 
Was this postponed to another version, or there was a regression before 
release? 
Comment 14 Mathias_Bauer 2006-02-15 12:56:58 UTC
Waiting for full implementation
Comment 15 Mathias_Bauer 2006-02-15 12:57:50 UTC
Targetting next release
Comment 16 Mathias_Bauer 2006-05-11 08:26:20 UTC
adjusting target
Comment 17 Mathias_Bauer 2006-12-08 10:26:06 UTC
changing component to "Word Processor" as this is the place where the work will
happen
Comment 18 Mathias_Bauer 2006-12-08 12:13:21 UTC
Andreas, please verify if the issue is fixed or if we still have a problem
Comment 19 andreas.martens 2007-04-13 08:54:41 UTC
Status: in former OOo versions we lost the _content_ of numbered paragraphs
created by KOffice. This problem has been fixed.
Open is the problem of numbering, we still do not import the numbering of
<text:numbered-paragraph> tags. The clarifying discussion in the TC results into
proposals for ODF 1.2. When such a proposal will be accepted we will be able to
fix this issues completely.
Comment 20 Martin Hollmichel 2007-09-10 13:52:57 UTC
move to 3.x accroding http://wiki.services.openoffice.org/wiki/Target_3x
Comment 21 mst.ooo 2008-07-07 11:36:40 UTC
@ama:
please assign to mst
Comment 22 andreas.martens 2008-07-30 10:38:09 UTC
Reassigned.
Comment 23 mst.ooo 2008-07-30 10:51:38 UTC
Created attachment 55444 [details]
another numbered-paragraph testcase (ODF1.0, KOffice 1.5)
Comment 24 mst.ooo 2008-07-30 10:58:12 UTC
fixed in CWS swlists02:

CWS swlists02 adds support for importing lists in numbered-paragraph representation.
Export is not necessary: we always export text:list/text:list-item.

KOffice 2.0 alpha 8 does not export lists correctly (just plain paragraphs)
KOffice 1.5 seems to work (see attached testcase)
Comment 25 mst.ooo 2008-07-30 11:00:12 UTC
assign to QA
Comment 26 michael.ruess 2008-09-15 16:32:52 UTC
Verified in CWS swlists02.
Comment 27 smith77 2009-03-27 23:12:56 UTC
verified in master version - 3.1- works fine!
Comment 28 gatis 2009-03-28 04:30:24 UTC
verified in master version 3.1.
Comment 29 sgautier.ooo 2009-03-28 11:40:25 UTC
Verified in master so closing - Sophie