Issue 5266 - Formula not resizable
Summary: Formula not resizable
Status: CONFIRMED
Alias: None
Product: Draw
Classification: Application
Component: formatting (show other issues)
Version: OOo 1.0.0
Hardware: PC Windows XP
: P4 Trivial with 24 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: ms_interoperability
: 8881 12615 17469 17470 22476 23910 28813 53487 61834 84646 (view as issue list)
Depends on:
Blocks:
 
Reported: 2002-05-25 04:57 UTC by rheavy
Modified: 2017-05-04 14:33 UTC (History)
9 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description rheavy 2002-05-25 04:57:00 UTC
1. In Drawing insert any formula, such as %omega_2

2. Select the formula, right-click, select Position and Size, Size tab. Both 
Keep Ratio and Protect are checked by default.

3. Uncheck Protect (Keep Ratio remains checked) and press OK.

4. Resize formula using any handle. The formula can resize without keeping the 
ratio the same. This appears incorrect since Keep Ratio should keep the 
proportions the same.

5. After resizing once, it is not possible to resize again. One must repeat the 
process and uncheck Protect again. This may not be a bug but I wonder if the 
design is intentional. It would be more consistent for the user if the Protect 
remained unchecked unless explicitly re-checked.
Comment 1 rheavy 2002-05-25 05:26:57 UTC
Addendum: Also drew a graphic object (rectangle) and checking Keep 
Ratio did not prevent changing the ratio, so maybe this is not a 
formula issue.

However for the rectangle, Protect is unchecked by default and 
remains that way after resizing. I think formula objects should work 
this way also so that all objects are consistent unless there is a 
good reason otherwise. Looks like the formulas are the exception.
Comment 2 Joost Andrae 2002-06-07 15:11:41 UTC
Joost: Resize of the formula is disabled by default. The ability to
activate resizing it is a bug.
JA->ES: reassigned to you... (you mentioned this already has been
fixed in 642...)
Comment 3 rheavy 2002-06-13 15:40:40 UTC
Yowch! I need to keep my big mouth shut next time!!

Please DO NOT remove the "bug" which allows resizing of formulas. 
It's not hurting anything, is it? If anything, just change the resize 
defaults and operation to make it similar to the way other graphic 
objects are handled in Drawing or Presentation. 

Resizing formulas is extremely useful for technical drawings where it 
is necessary to resize components so things "look right" and make 
formulas readable. I'm not a great artist and it would be difficult 
for me to make professional looking figures without it. 

Microsoft Office DOES allow resizing of formulas. Why shouldn't OO? 
If for no other reason, at least it maintains a feature consistency.

Thanks for listening.
Comment 4 caolanm 2002-06-13 15:50:04 UTC
I'd like it to be possible to resize formulas as well and have it
simply scale the graphical view of the object to fill the new size. It
would indeed improve compatability with word and how it operates. 
Comment 5 eric.savary 2002-06-27 01:43:47 UTC
ES->LHO: I recently closed a task disabeling ANY possibility to 
resize Math object in Writer. Do you realy think we follow the needs 
of the user?
Comment 6 lutz.hoeger 2002-06-27 12:47:04 UTC
LHO->FT: Please take over.
Comment 7 falko.tesch 2003-01-24 13:52:14 UTC
??? I cannot find any(!) possibility to resize math objects in MS
Offfice (XP). Therefore I do not think we should change our behaviour!
Comment 8 caolanm 2003-01-24 15:09:07 UTC
You certainly can. e.g. insert->object->ms equation editor. Stick in
some text and then format->object->size and change the height/width.
Or grab the object outline and stretch it.
Comment 9 falko.tesch 2003-01-27 15:58:55 UTC
Hi Andreas, Caolon is right :o(
So what do you think? I think we need to address this issue.
1) we just import it the size it is but do not allow to change its
size (as we do it now) 
or
2) we also allow to change its size and to im/export this feature.

After all in the long run we must have this feature anyway (INHO)
Comment 10 Oliver-Rainer Wittmann 2003-02-25 10:24:06 UTC
OD->FT (25.02.2003):
Please take over again.
The described defect changed to an enhancement request. Please resolve
this issue and setup an new issue for the enhancement.
Comment 11 falko.tesch 2003-02-25 13:04:59 UTC
FT->BH: Changed from defect to enhancement.
Re-assigned to BH for further evaluation.
Comment 12 bettina.haberer 2003-04-14 12:52:59 UTC
It makes no sense for a user not to be able to resize a formula. And 
it is also not obvious, why that works for other objects. We should 
get able to resize formula and scale text to get a result, which is 
comparable with MS.
Comment 13 bettina.haberer 2003-04-14 12:55:42 UTC
*** Issue 8881 has been marked as a duplicate of this issue. ***
Comment 14 michael.bemmer 2003-05-06 16:00:54 UTC
Too late for beta2, re-targeted to 1.1 RC.
Comment 15 bettina.haberer 2003-05-13 13:14:50 UTC
I changed the milestone target for this larger implementation to OOo 2.0.
Comment 16 bettina.haberer 2003-07-08 15:09:24 UTC
8881 has been closed as duplicate to this issue.
Comment 17 bettina.haberer 2004-04-08 18:07:37 UTC
Hello Thomas, did you make some changings in the meantime with this issue? Is it
possible to get then in in Q?
Comment 18 thomas.lange 2004-04-13 08:37:39 UTC
No I did no make any changes and it is unlikely to get into Q.

Also I'd like to get some comments on this by FL. A long time ago we discussed
about this issue since it pops up every now and then.
Until now we always decided against it...

TL->FL: Anything new about this matter?
Comment 19 Oliver-Rainer Wittmann 2004-04-22 10:19:42 UTC
remove OD from CC-list
Comment 20 lohmaier 2005-01-29 22:45:23 UTC
*** Issue 23910 has been marked as a duplicate of this issue. ***
Comment 21 eric.savary 2005-08-22 11:44:40 UTC
*** Issue 53487 has been marked as a duplicate of this issue. ***
Comment 22 lohmaier 2006-02-09 20:48:10 UTC
*** Issue 61834 has been marked as a duplicate of this issue. ***
Comment 23 kpalagin 2008-01-07 13:44:15 UTC
*** Issue 84646 has been marked as a duplicate of this issue. ***
Comment 24 kpalagin 2008-01-07 13:46:49 UTC
*** Issue 17470 has been marked as a duplicate of this issue. ***
Comment 25 kpalagin 2008-01-07 13:50:40 UTC
*** Issue 17469 has been marked as a duplicate of this issue. ***
Comment 26 kpalagin 2008-01-07 13:52:11 UTC
*** Issue 22476 has been marked as a duplicate of this issue. ***
Comment 27 kpalagin 2008-01-07 13:56:11 UTC
*** Issue 28813 has been marked as a duplicate of this issue. ***
Comment 28 kpalagin 2008-01-07 14:04:33 UTC
*** Issue 12615 has been marked as a duplicate of this issue. ***
Comment 29 samtygier 2008-01-08 17:06:19 UTC
Seems odd that that ja thinks it is a bug to be able to resize formula.

For doing scientific presentations its rather useful to be able to make an
equation large. It sounds like no extra code would be needed to make this
possible, just remove the bit of code that tries to stop you resizing things.
Comment 30 meywer 2008-06-16 15:35:12 UTC
Formulas should be resized relative to text when changing font-size for a text
„containing“ formulas.

Especially when putting text with formulas from writer to impress, where you
need larger fonts it's ennoying, that the formulas stay small!!!
Comment 31 meywer 2008-06-16 15:35:31 UTC
Formulas should be resized relative to text when changing font-size for a text
„containing“ formulas.

Especially when putting text with formulas from writer to impress, where you
need larger fonts it's ennoying, that the formulas stay small!!!
Comment 32 kpalagin 2009-05-10 07:47:19 UTC
Thomas,
please consider this issue for 3.x.
Thanks a lot.
WBR,
KP.
Comment 33 thomas.lange 2009-05-11 07:50:49 UTC
TL->FL: it seems we are missing a statement about this for quite some time.
Please take over.
Comment 34 meywer 2009-11-02 20:50:50 UTC
See issue 26446 too.
Comment 35 stretzyda 2015-06-09 03:52:50 UTC
Is allowing manual resizing breaking something elsewhere and that just hasn't been mentioned in this thread?
It's odd how you seem to be going out of your way to reduce functionality, especially since this bug has been here for 13 years.
Manually resizing through size/position is simple, but for some reason you default to protecting size even after that protection is removed by the user.
The formula renders correctly in the new size so it's curious to say the least.
Would it be possible to get an explanation of what errors allowing manual resizing would cause to stem the confusion?
Latency issues perhaps?
Comment 36 Matthew Slyman 2017-04-30 13:32:29 UTC
I have a degree in computer science, and I just spent about 1 hour converting a formula into SVG graphic format.
This required approximately the following procedure:
* Open LibreOffice Math
* Write formula
* Could not find a way to "export to Draw", "export to SVG", etc.
* Open LibreOffice Draw
* Menu: Insert/ Object/ Formula
* Manually edit the formula (paste in formula code)
* Format/ Font size/ make the text incredibly tiny with 5 point text, so that the entire formula would be shown inside the tiny, rigid, NON-RESIZEABLE box thata Insert/Object had placed it inside (the formula was internally overflowing, and being clipped) — of course this NON-RESIZEABLE box was NOT automatically resizing itself to the formula contained inside it…
* Context menu: Convert to profile (initially attempted convert to curve, but this resulted in resizing & clipping so had to try another option)
* Manually resize resulting formula-profile to width of page.
* Manually resize page to vertical size of object
* Export as SVG

I'm running LO 5.2.3.3 x64 — it baffles me how anyone thinks this procedure is acceptable in 2017. Perhaps with Windows 3.1 in 1992, I would have thought this about normal, but these days, this is well below my expectations for how software should work! Anyone who thinks that being inside this strait-jacket is a "feature" is frankly an idiot. Sorry for the undiplomatic language!
Comment 37 Matthew Slyman 2017-04-30 13:34:35 UTC
Possibly related to:
https://bugs.documentfoundation.org/show_bug.cgi?id=49614

Can anyone explain how these two bugzilla databases are related to each other?
Comment 38 Marcus 2017-04-30 14:19:51 UTC
(In reply to Matthew Slyman from comment #37)
> Can anyone explain how these two bugzilla databases are related to each
> other?

Simply read whyat you are writing to: This is the issue tracker of OpenOffice and *not* LibreOffice. It's another program. If you have a problem their software please go there. As I can see you know the link already. ;-)
Comment 39 Matthew Slyman 2017-04-30 15:24:07 UTC
OK, thanks — I must have just presumed they were linked somehow, given that LO came from OOO and so I thought any old OOO bugs that were still in current LO must somehow be managed here. Excuse me.

Can you confirm that this problem does not exist in OOO? If so, that might give me some leverage with LO…
Comment 40 Regina Henschel 2017-04-30 20:37:11 UTC
(In reply to Matthew Slyman from comment #36)
> I have a degree in computer science, and I just spent about 1 hour
> converting a formula into SVG graphic format.

Open Draw, Insert > Object > Formula. Write the formula or import it. Click outside to finish edit mode.
If not still selected, select the Formula, so it has green handles. File > Export. Make sure you have "Selection" checked. Choose type "SVG", give it a file name. OK. Thats all. Less than 5 minutes.

But that is irrelevant for this issue. Use mailing list or forum to get assistance in using Apache OpenOffice.
Comment 41 Marcus 2017-04-30 20:50:53 UTC
(In reply to Matthew Slyman from comment #39)
> OK, thanks — I must have just presumed they were linked somehow, given that
> LO came from OOO and so I thought any old OOO bugs that were still in
> current LO must somehow be managed here. Excuse me.
> 
> Can you confirm that this problem does not exist in OOO? If so, that might
> give me some leverage with LO…

I hope that the reply from Regina has helped. Otherwise I would suggest that you try yourself as the options layout has changed since version 1.0.0
Comment 42 Matthew Slyman 2017-04-30 21:21:19 UTC
Thank you, although, with all due respect, I followed a similar procedure for inserting the equation last time, and Draw gave me a formula window much smaller than the size of my formula — as originally explained, the formula was clipped at about 10% of the width of the formula, clipping off 90% of the formula — and the green handles stubbornly refused to move! I also encountered the other problems I have described. The box simply remained at its default size, except when I converted the formula to a curve, when the box suddenly shrank vertically, causing vertical clipping as well as horizontal clipping.
(Naturally, as is often the case when an expert gets involved; after you advised me, the problem disappeared — although I do know that the problem is there, and has not been fully resolved, because I have not updated my software in the mean-time.)
So with all due respect to you, I believe there is an intermittent fault in the code that is supposed to automatically resize the box with the green handles, according to the size of the contained formula. This intermittent fault is clearly causing significant (very irritating) problems for a small minority of users, in a minority of occasions.

ALSO: I have now followed your recommendations completely, and the result was: a blank formula displayed in Chrome/ Inkscape (they couldn't display the SVG that Draw exported directly from the formula: it had to be converted into a path/ contour/ curve first, to work around this issue. Only then did it produce output that was visible in my other software. I believe this is probably an issue with management of fonts in Windows — most non-technical users wouldn't guess this, but then, most non-technical users probably wouldn't try this procedure either.

I've used a variety of vector drawing programs, on a variety of platforms, over several decades; and the fact that I'm finding this aspect of Draw (which is generally quite good software) to be counter-intuitive (and had to read various online help forums before coming here), is probably a sign that ideally, this feature set should be improved.
Comment 43 rheavy 2017-05-04 01:21:17 UTC
I originally posted this some 17 years ago and the developer response has been absolutely absurd - worthy of Through the Looking Glass or responding through a psychedelic delirium. 

Remember the resizing ability originally existed and I suggested a small logical change to make it function consistent with MS Office - I would certainly call it a bug fix. The result? Remove the feature, and when others object and call for its restoration label it a feature enhancement! Quite simply, idiotic beyond the pale.

Maybe it should never be fixed and I could claim to have the longest open unresolved issue (I don't know if that's really true but it's probably close.)

I understand a lot of this development is done without compensation, but this is really so ridiculous and probably could have been originally resolved with a minimum of effort. 

I guess I check back in other 17 ....
Comment 44 rheavy 2017-05-04 14:33:08 UTC
I originally posted this some 17 years ago and the developer response has been absolutely absurd - worthy of Through the Looking Glass or responding through a psychedelic delirium. 

Remember the resizing ability originally existed and I suggested a small logical change to make it function consistent with MS Office - I would certainly call it a bug fix. The result? Remove the feature, and when others object and call for its restoration label it a feature enhancement! Quite simply, idiotic beyond the pale.

Maybe it should never be fixed and I could claim to have the longest open unresolved issue (I don't know if that's really true but it's probably close.)

I understand a lot of this development is done without compensation, but this is really so ridiculous and probably could have been originally resolved with a minimum of effort. 

I guess I'll check back in other 17 ....