Issue 52718 - No top table border shown after page break
Summary: No top table border shown after page break
Status: CLOSED DUPLICATE of issue 9860
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: 680m122
Hardware: All All
: P3 Trivial with 3 votes (vote)
Target Milestone: ---
Assignee: frank.loehmann
QA Contact: issues@sw
URL:
Keywords:
: 56106 (view as issue list)
Depends on:
Blocks:
 
Reported: 2005-08-01 11:05 UTC by michael.ruess
Modified: 2013-08-07 14:38 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description michael.ruess 2005-08-01 11:05:26 UTC
In Writer, when a table (without headings repeated) is forced to break across
pages, there will no top border be shown on the second page.

MRU->OD/FME: please state, why it is not so easy to implement and we need a
decision what to do. Thanks!
Comment 1 frank.meies 2005-08-01 11:19:07 UTC
FME->FL: We must define which border attributes to use for the table cells at
the top of the second page.
Comment 2 Oliver-Rainer Wittmann 2005-08-01 11:22:52 UTC
OD->FL: FME is right, especially this information is needed, if the row on the
second page differs from the last row on the previous page.
Comment 3 frank.loehmann 2005-08-24 17:01:32 UTC
I have talked with AMA about this issue. Conclusion is to shift this issue to
OOo 3.0, because we need to change the general border behavior for tables. This
would results in a bad export experience into OOo 1.0 format due to a then
different behavior.

Regardless that OOo 1.0 and 2.0 are both able to make unique borders for every
single table cell, but OOo 1.0 would show doubled borders on those double
bordered cells. OOo 2.0 introduces a new flag to merge equal borders to suppress
this behavior because it is required to have those single borders for each cell
when importing Microsoft Word files.

The following has to be accomplished:
  1. Cell border after break copies all border attributes from last border of
previous page (exceptions  from this rule?)
  2. Latest attribute wins (i.e. red square in table wins over bold, black
lines) Therefore we have to assign the attribute to all 4 cells _and_ to all
borders of the surrounding cells.
Comment 4 michael.ruess 2005-10-17 11:49:12 UTC
*** Issue 56106 has been marked as a duplicate of this issue. ***
Comment 5 frank.loehmann 2005-11-10 13:44:02 UTC
FL: Set correct target, since target is know available.
Comment 6 frank.loehmann 2006-07-13 16:38:40 UTC
set target to OOo 2.x
Comment 7 modax 2007-05-12 08:14:32 UTC
It would be great to have this bug finally fixed. Such table breaks are kind 
of frequent situation and I'm forced to repeat headers just to get the upper 
border on the next page...
Comment 8 frank.loehmann 2007-09-07 10:44:23 UTC
Set target to OOo later.
Comment 9 ooouser20070909 2007-09-09 20:10:25 UTC
This issue is closely related to issue 61410 (When a table's row breaks, it
appears like two rows). There should be either two borders or no border. If it
is easier to omit the bottom border on the first page than to add the top border
on the second page, I would suggest to solve issue 61410 first. The version with
two borders could be added as an option later. 
Comment 10 hagar_de_lest 2007-09-21 21:28:56 UTC
Isn'it a duplicate of Issue 9860 ?
Comment 11 kpalagin 2007-09-23 19:37:08 UTC
Seems like dupe of 9860.
Resolving as such.



*** This issue has been marked as a duplicate of 9860 ***
Comment 12 kpalagin 2007-09-23 19:39:02 UTC
and closing.

Please transfer yout votes to 9860.

hagar_de_lest,
thanks a lot.