Issue 52988 - Undo after cutting picture causes Writer to crash
Summary: Undo after cutting picture causes Writer to crash
Status: CLOSED DUPLICATE of issue 52987
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 1.1.5
Hardware: PC Windows 98
: P3 Trivial (vote)
Target Milestone: ---
Assignee: openoffice
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-07 01:21 UTC by bernhard
Modified: 2013-08-07 14:43 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
testdoc to reproduce crash (cut&paste of picture) (13.99 KB, application/vnd.oasis.opendocument.text)
2005-08-07 01:22 UTC, bernhard
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description bernhard 2005-08-07 01:21:03 UTC
With testdoc from issue 52987 (cut&paste duplicates picture) OOo (m122) crushes
on some computers reproducible, others seem not to have any problems.

Follow instruction in testdoc (attached here as well) to get the second picture
(scenario 3 from i52987) and try to undo your steps back to the beginning.

After the first UNDO *both* pictures are gone, a second UNDO causes the crash
with crashrep on Windows98SE, on Linux (SuSE9.3) freezes OOo.

With OOo1.1.5rc scenario 2 from i52987 (include CR of preceding paragraph in
selection for cut&paste) causes a similar crash on Win98SE, the picture
disappears here as well after the first UNDO, the second UNDO leads to the crashrep.

I'll mention this issue within the crashreports.

Regards

Bernhard
Comment 1 bernhard 2005-08-07 01:22:19 UTC
Created attachment 28541 [details]
testdoc to reproduce crash (cut&paste of picture)
Comment 2 bernhard 2005-08-07 21:25:43 UTC
In my m122 (win98SE) crashrep crashes itself, so I wasn't able to send the
crashrep I mentioned above. Screenshots of the crash can be found attached to
issue 49284.

Bernhard
Comment 3 michael.ruess 2005-08-08 11:20:52 UTC
MRU->HBRINKM: open the attached document and select text from the beginning of
paragraph "After..." to somewhere in the following paragraph. Cut selection and
insert immediately. Click Undo two times -> crash.
Maybe it is a successive problem of issue 52987, where the inconsistency of the
"Cut" process is handled (graphic remains though its paragraph will be cut).
Comment 4 openoffice 2005-08-10 10:47:20 UTC
duplicate

*** This issue has been marked as a duplicate of 52987 ***
Comment 5 Mathias_Bauer 2007-02-05 13:57:27 UTC
going to close ancient issues
Comment 6 Mathias_Bauer 2007-02-05 14:10:35 UTC
closing ancient issues