Issue 53266 - Only part of OLE DRAW Object is visible after "Insert - create from file"
Summary: Only part of OLE DRAW Object is visible after "Insert - create from file"
Status: CLOSED DUPLICATE of issue 52817
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 680m122
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: thorsten.martens
QA Contact: issues@framework
URL:
Keywords: oooqa
Depends on: 20643
Blocks:
  Show dependency tree
 
Reported: 2005-08-12 22:18 UTC by rjahn1
Modified: 2008-09-04 10:43 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
OO 1.9.122 drawing (9.77 KB, application/vnd.sun.xml.draw)
2005-08-12 22:20 UTC, rjahn1
no flags Details
OO 1.9.122 Impress presentation (16.14 KB, application/vnd.sun.xml.impress)
2005-08-12 22:21 UTC, rjahn1
no flags Details
OO 1.9.122 Writer (13.74 KB, application/vnd.sun.xml.writer)
2005-08-12 22:22 UTC, rjahn1
no flags Details
MS Office XP Word (22.50 KB, application/msword)
2005-08-12 22:23 UTC, rjahn1
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description rjahn1 2005-08-12 22:18:29 UTC
OS: MS Windows XP
OO: 1.9.122

The content of OO Drawing imported into the following applications is truncated.
* OO Writer
* OO Impress
* MS Office XP Word

The test with MS Word is to check whether the problem is specific to OO Writer
and Impress or the problem is related to MS OLE implementation in OO.

Example files are attached.

Ray
Comment 1 rjahn1 2005-08-12 22:20:52 UTC
Created attachment 28713 [details]
OO 1.9.122 drawing
Comment 2 rjahn1 2005-08-12 22:21:56 UTC
Created attachment 28714 [details]
OO 1.9.122 Impress presentation
Comment 3 rjahn1 2005-08-12 22:22:33 UTC
Created attachment 28715 [details]
OO 1.9.122 Writer
Comment 4 rjahn1 2005-08-12 22:23:06 UTC
Created attachment 28716 [details]
MS Office XP Word
Comment 5 Regina Henschel 2005-08-13 00:44:45 UTC
If I select all and copy&paste it to a new writer or impress document, the
drawing is not cropped. How have you "imported" the drawing?
I haven't got Word XP, so I cannot test it there.
Comment 6 Rainer Bielefeld 2005-08-14 08:00:10 UTC
I tried to copy from 1.1.4 (German) WIN XP: [645m52 (Build 8824)] to 2.0
(1.9.m122) German version WIN XP: [680m122(Build8941)] by copy - paste: WFM as
per comments from regina Fri Aug 12 16:44:45 -0700 2005 
Comment 7 wolframgarten 2005-08-15 08:26:55 UTC
Sorry, could not reproduce this. Please add a detailed description: are you
copying and pasting or how do you import? Can you attach a writer or impress
file with the truncated import and a screenshot? Thanks in advance.
Comment 8 rjahn1 2005-08-15 15:04:07 UTC
OS: MS Windows XP
OO: 1.9.122

Not sure about what additional file attachments that wq@openoffice.org needs. 
Do you need attachments different from the previous submission?  In what way? 
Please specify.

Questions:

* Has anyone verified that the OO drawing content in previously submitted OO
files was cropped and not changeable?

* I mentioned OLE object insertion, not copy-paste, in the original issue
submission.
Past comments all referred to copy-paste UI path.
Has anyone tested the OLE UI path?
In both 1.1.4 (old, still official at writing time) and 1.9.122 (future, open
ducument) formats?

* Please reopen the issue when the description is verified.
Copy-paste is not a substitute for OLE object insertion.

Details about symptom duplication, all in OO 1.9.122.

* drawing creation

new drawing
(do whatever to create a large content)
save in 1.1.4 format (sxd)
save and close file

* import to OO Writer
new text document
insert – object – OLE object – create from file – (specify the sxd drawing file)
– no link – OK
content is truncated
uncropping operation could not retrieve the content outside the border

* import to OO Presentation Impress
new presentation
(the rest operation is the same as the OO Writer)
Comment 9 Rainer Bielefeld 2005-08-15 15:51:57 UTC
I can confirm that problem.

Steps to reproduce:
0. Save Attachment 'truncate.sxd' on your harddisk
1. Open new OOo writer document
2. Menu: Insert - Object - OLE-Object - Create from File
3. Search for attached 'truncate.sxd' and insert
   expected: complete drawing should be visible
   actual: only a central area of the drawing is visible, rest truncated.
           That can be solved by resizing the frame of the inserted OLE-Object,
           but that's exhausting

This might be at least related to issue 20643, I believe: Duplicate.

I checked with 1.1.4 (German) WIN XP: [645m52 (Build 8824)], 
2.0 (1.9.m122) German version WIN XP: [680m122(Build8941)],
2.0 (1.9.m122) German version WIN XP: [680m122(Build8941)]
all with same (bad) result.

During my tests the problem also occured in CALC
Comment 10 Rainer Bielefeld 2005-08-15 15:52:46 UTC
.
Comment 11 wolframgarten 2005-08-16 08:10:07 UTC
Sorry, OLE object insertion was not mentioned in the first issue submission. You
said "content of OO Drawing imported ..." Thats why I asked for a detailed
description.
This one is duplicate.

*** This issue has been marked as a duplicate of 52817 ***
Comment 12 wolframgarten 2005-08-16 08:10:52 UTC
Thanks for your help to all. Closed.
Comment 13 lllbutcher 2008-09-04 10:43:04 UTC
This same bug has been reported many times.
16156:  Aug 2003, OO 1.1
20643:  Oct 2003, OO 1.1
28046:  Apr 2004
50398:  Jun 2005, OO 2.0 beta
53266:  Aug 2005, 680m122
72879:  Dec 2006, OO 2.1
73343:  Jan 2007, OO 2.1
81143:  Aug 2007, OO 2.2.1
82873:  Oct 2007, OO 2.3
93426:  Sep 2008, OO 2.4.1 and OOO300m4

If the author of this Issue is still online, please consider the contents of
16156 and 93426.

If the solution addresses your issue, please vote 2 for 16156.