Issue 53399 - Poor performance with Oracle JDBC
Summary: Poor performance with Oracle JDBC
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: 680m122
Hardware: All Linux, all
: P3 Trivial with 3 votes (vote)
Target Milestone: ---
Assignee: dbaneedsconfirm
QA Contact: issues@dba
URL:
Keywords: needmoreinfo, oooqa
Depends on:
Blocks:
 
Reported: 2005-08-16 14:49 UTC by nephila
Modified: 2008-05-07 11:48 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description nephila 2005-08-16 14:49:15 UTC
I'm connecting to an Oracle database with a large number of tables (~1000) using the Oracle JDBC driver in 
Base and there are a number of times that the application stops responding.

1. Selecting the Tables button on the main screen and entering the user name and password
2. Opening a table by double-clicking on a table in the Tables list

Editing the entries in an opened table is fast, as is running a query. The problem doesn't appear to be 
merely a slow connection to the database. Is it possible that at the times the application is waiting that it 
is retrieving a list of all the tables and the meta-data that goes with it?
Comment 1 christoph.lukasiak 2005-09-12 12:08:47 UTC
clu->fs: fits in our performance improvement task
Comment 2 Frank Schönheit 2006-11-15 06:54:52 UTC
back into pool

fs->clu: Can you confirm the behaviour described here?
Comment 3 christoph.lukasiak 2006-11-20 16:32:42 UTC
change owner
Comment 4 christoph.lukasiak 2007-04-25 16:17:22 UTC
works fine for me with around 100 tables - may try it on a current version (2.2
or newer)

1. how long does it take approx?
2. what jdbc driver do you use?
3. do you have the possibility to take an other driver?
4. do you habe the possibility to connect a 'smaller' database?

thx
Comment 5 nephila 2007-04-27 10:32:45 UTC
Since I filed this report I've changed jobs and now have a different database,
it's still Oracle only now it's ~4000 tables in the schema I've logged into!
Unfortunately I'm still experiencing performance issues. The database server
itself is running on a fast SPARC/Solaris machine and performance in other JDBC
applications (Oracle SQL Developer) with the same driver is sadly much better
than OOo. My previous workstation was much slower, but it's still dragging along
on this one. The database is Oracle 10g Release 2, whereas previously I was
using Oracle 9i Release 2.

This time I'm running the tests from WinXP using the 2.3 developer snapshot m210.

To answer you questions:
1. It's been 10 minutes to get a table list.
2. Oracle's ojdbc14 driver version 9.0.2.0.0 oracle.jdbc.driver.OracleDriver
3. I'll try the 10g instant client driver (version 10.2.0.2.0)
3.1 This time it took 27 minutes.
4. Unfortunately I don't have a smaller DB to connect to.
Comment 6 kaluscha 2007-08-07 16:14:04 UTC
I'm experiencing similiar problems (OO 2.2.1, Oracle 10g, ojdbc14.jar for
10.2.0.3). After entering name and password, OO starts to get the list of tables
which takes aprox. 3 minutes. The user itself only has a few tables, but also a
large number of system tables is included in the list, which makes progress slow. 

Both client and server are fast machines, system load on the server is
neglectible, system load on the client varies between 20 and 100%. There's
continous network traffic on port 1521 between client and server so network
timeouts shouldn't be an issue.

Another annoyance is that number fields are still displayed as currency. This is
an old but still not resolved issue
(http://www.openoffice.org/issues/show_bug.cgi?id=11746).
Comment 7 kaluscha 2007-08-07 17:53:11 UTC
A quick and dirty workaround could be to exclude tables and views of user who
are called *sys. 

Better would be to include another level in the tree (tables/user/tablename)
instead of table/user.tablename) which would provide a better overview.

Thus, the list of users would be fetched first (should be quick) and the list of
tables after an user entry is chosen.
Comment 8 brian1830 2007-10-18 21:32:36 UTC
can someone provide a link to a virtual machine which has oracle preinstalled??
i suppose more people would be trying to reproduce this issue if they would just
have to install openoffice into the appliance and would also be provided with
scripts for creation of dummy tables and data.
regards, brian
Comment 9 Mechtilde 2008-05-06 14:03:57 UTC
does it also happen with the latest version?
Comment 10 kaluscha 2008-05-06 14:20:45 UTC
Performance has very much improved in my case (OO2.4, ojdbc14.jar for Oracle
10.2.0.3). Opening the list of tables used to take 3 minutes, now it takes 10
seconds. Thnx.
Comment 11 christoph.lukasiak 2008-05-07 11:46:34 UTC
=> so i see this one as fixed (at least the basic problem) - for any further
stuff (specially speed problems in a current version) please write a new issue

thx
Comment 12 christoph.lukasiak 2008-05-07 11:48:05 UTC
=> close