Issue 53447 - Page setup: preview misses a repaint
Summary: Page setup: preview misses a repaint
Status: CLOSED FIXED
Alias: None
Product: Draw
Classification: Application
Component: ui (show other issues)
Version: 680m124
Hardware: All All
: P3 Trivial (vote)
Target Milestone: 4.2.0
Assignee: groucho266
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-17 12:55 UTC by wolframgarten
Modified: 2017-05-20 10:35 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Patch to update size value of the preview at the tab page activation (401 bytes, patch)
2014-02-03 16:12 UTC, hanya
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description wolframgarten 2005-08-17 12:55:24 UTC
When changing the layout from landscape to portrait under format/page/page there
seems to be a repaint missing. The landscape is still in the back then.
Comment 1 mantis02 2007-07-06 11:55:48 UTC
OpenOffice 2.2.1 (Windows)

The issue still exists, however, I would like to rephrase it.

The 'Page Setup' dialog box displays an invalid preview when displayed for the
first time.

To reproduce the the issue:
1. use a default installation of OpenOffice or use the margins 1.00cm for the
four borders (Format > Page...);
2. Observe the preview drawing;
3. Select the Landscape then Portrait orientation;
4. You should notice a difference in the preview drawing.

However, if you change the margins, close the window, and open it again, you'll
notice that the preview somehow updated.

It look like there is a 1.00cm gap between the initial preview and the
'refreshed' one!
Comment 2 oooforum (fr) 2014-02-03 10:01:32 UTC
Up
Still not solved in 4.0.1
Comment 3 hanya 2014-02-03 15:17:43 UTC
When the dialog is opened, SvxPageDescPage::InitHeadFoot_Impl method is 
called from Reset method and then ActivatePage method. 
SID_ATTR_PAGE_SIZE value of taken from the argument SfxItemSet type of InitHeadFoot_Impl is 
different between the calls.
So when I push Reset button after the dialog is shown, the preview is ok. 
But when I change to Background tab once and return back to the Page tab, 
ActivatePage method is called and bad(?) page size is set and the preview 
is bad.
Comment 4 hanya 2014-02-03 15:59:49 UTC
(In reply to hanya from comment #3)
> So when I push Reset button after the dialog is shown, the preview is ok. 
> But when I change to Background tab once and return back to the Page tab, 
> ActivatePage method is called and bad(?) page size is set and the preview 
> is bad.
This is incorrect. Both page size are the same.
In Reset method, SvxPageDescPage::UpdateExample_Impl method is called after 
calling InitHeadFoot_Impl method and it overwrite the size of the preview 
in TWIP.
Comment 5 hanya 2014-02-03 16:12:06 UTC
Created attachment 82482 [details]
Patch to update size value of the preview at the tab page activation

UpdateExample_Impl method should be called after calling InitHeadFoot_Impl method. 
Because size value of the preview window is updated by the real page size. 
UpdateExample_Impl method update size value of the preview in calculated twips.
Comment 6 SVN Robot 2014-05-17 07:06:56 UTC
"hanya" committed SVN revision 1595429 into trunk:
#i53447# update example view for Draw during the activation of the tab page
Comment 7 hanya 2014-05-19 18:57:38 UTC
Fixed on trunk.