Issue 53448 - base form wizard crashes
Summary: base form wizard crashes
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 2.0 Beta
Hardware: PC Windows XP
: P2 Trivial (vote)
Target Milestone: ---
Assignee: christoph.lukasiak
QA Contact: issues@dba
URL:
Keywords: needmoreinfo
Depends on: 51116
Blocks:
  Show dependency tree
 
Reported: 2005-08-17 13:09 UTC by ivoth
Modified: 2006-05-31 14:29 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
tablewrong (21.83 KB, image/png)
2005-12-15 14:54 UTC, Mechtilde
no flags Details
tableright (20.19 KB, image/png)
2005-12-15 14:55 UTC, Mechtilde
no flags Details
mysql dump (1.36 KB, text/plain)
2005-12-15 14:56 UTC, Mechtilde
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description ivoth 2005-08-17 13:09:28 UTC
Unsure about version: 1.9.122

1 Imported MS access database
2 Use wizard to create form
3 step 8: work with form, pushed Finish, nothing happens
4 pushed 2nd time: nothing happens
5 pushed 3rd time: application closes
6 restart base: document recorvery seems ok, sending report fails
Comment 1 ivoth 2005-08-17 18:33:00 UTC
All clear now, the database wasn't copied but linked. One can't create a
Access-form with OOo, but a crach wasn't needed ;-). Unfortunately it wasn't
clear at first, so I ruined mij Access database. I got a backup.
Comment 2 christoph.lukasiak 2005-09-12 12:03:16 UTC
change owner
Comment 3 christoph.lukasiak 2005-09-13 10:16:50 UTC
clu->ivoth: a crash is always critical, so i am interested in how to reproduce
your case - what means: database wasn't copied but linked? how can you connect
to a link?
Comment 4 ivoth 2005-09-13 18:32:55 UTC
I thought that by opening the MS database, I would automatically made a OOo
copy. As I do when opening a MS Word document. I saw that the filesize was about
3 kb so I presumed that I only linked to the MS database instead of copying it.
Thus I presumed that since I didn't make an OOo database, it seems logical that
I couldn't make forms.
Now I tried to reproduce the error, but I can't even look into the tables
anymore. OOo can't connect to the database probably an error in the device
driver. Deleted OOo and reinstalled didn't solve this problem.
Comment 5 christoph.lukasiak 2005-09-14 11:19:39 UTC
clu->ivoth: anyway it is neither reproducable (a bug must be reproducable) nor
it seems to be a bug in office (because it does not work after reinstall, too) -
your problem seems to be a special case - if you can reproduce your bug with a
fresh access database, we can try to investigate it further, else i would
suggest you to search help in one of the many newsgroups

thx
Comment 6 christoph.lukasiak 2005-10-11 09:52:51 UTC
no further hints, so the chance to repro goes in direction zero -> close
Comment 7 Mechtilde 2005-12-06 10:43:15 UTC
I want to reopen this Issue.

I had the same problem and  I found one reason for this.

If the database table isn't defined correct OOo crashed without any information.

In my case the mistake was a row defined as "datetime" instead of "date". I
think it's better that nobody can define a row as "datetime"if OO can handle it.

I use MySQl 4.1.11 via ODBc 3.51.09 and OOo many milestones. The last one is
m143. under Debian Sarge

So it seems to be similar to Issue 56867.

Comment 8 Frank Schönheit 2005-12-15 12:06:53 UTC
mechthilde, if your table structure provides a reliable way to reproduce the
crash, do you mind attaching it (as SQL dump, probably)?
Comment 9 Mechtilde 2005-12-15 14:54:11 UTC
Created attachment 32459 [details]
tablewrong
Comment 10 Mechtilde 2005-12-15 14:55:44 UTC
Created attachment 32461 [details]
tableright
Comment 11 Mechtilde 2005-12-15 14:56:51 UTC
Created attachment 32462 [details]
mysql dump
Comment 12 Mechtilde 2005-12-15 15:00:21 UTC
I use debian/sarge m145 =2.0.1 RC4

I know that the definition of the row is different between the picture
"tablewrong" and the mysql dump but it's from the same database.

I reduce the dump to the essential part.
Comment 13 Mechtilde 2005-12-15 16:01:02 UTC
This is also an Issue with a crash of a form wizard
Comment 14 alnapier 2006-03-17 17:34:36 UTC
from version 2.02 it does not crash any more and seems to work on windows 
version. 
On Linux oo version 2.0.2-1(debian unstable) the wizard blocks on the final 
step(8). The only option left is to cancel.
Comment 15 alnapier 2006-03-17 17:49:47 UTC
The crash on the final step of the form wizard with os Linux Debian unstable 
was with Mysql 5.0.18 and occured with both odbc (libmyodbc 3.51.11-5) and 
jdbc (libmysql-java 3.1.11-1) connectors