Issue 53510 - border 'merge with next paragraph' ignored on HTML save/load
Summary: border 'merge with next paragraph' ignored on HTML save/load
Status: CLOSED DUPLICATE of issue 19690
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: OOo 2.0 Beta
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: eric.savary
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-18 17:00 UTC by koinov
Modified: 2005-08-19 09:50 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
The example .odt file (6.44 KB, application/vnd.oasis.opendocument.text)
2005-08-18 17:05 UTC, koinov
no flags Details
the HTML export of the .odt file (1.96 KB, text/html)
2005-08-18 17:06 UTC, koinov
no flags Details
this is the corrected HTML to make paragraphs look the same way as in the .odt file (2.10 KB, text/html)
2005-08-18 17:07 UTC, koinov
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description koinov 2005-08-18 17:00:08 UTC
If I define a paragraph with borders and have 'merge with next paragraph'
checked, a group of the paragraphs will have a merged border.

If this file is saved as HTML, each paragraph is saved with individual border.

If an HTML file is loaded, the paragraph borders are merged, regardless of how
they were in the HTML file.

I have an example .odt file with example of saved .html and a corrected .html
(correction is to the styles to make the paragraphs merged in html), but cannot
figure out how to attach a file to this issue. Will email upon request.
Comment 1 koinov 2005-08-18 17:05:50 UTC
Created attachment 28892 [details]
The example .odt file
Comment 2 koinov 2005-08-18 17:06:24 UTC
Created attachment 28893 [details]
the HTML export of the .odt file
Comment 3 koinov 2005-08-18 17:07:10 UTC
Created attachment 28894 [details]
this is the corrected HTML to make paragraphs look the same way as in the .odt file
Comment 4 koinov 2005-08-18 17:16:09 UTC
Just noticed, that paragraph spacing is not adjusted in the HTML export in
general. The spacing in the paragraphs in the example file are noticeably larger
in the HTML (due to the default paragraph spacing in HTML).

In other worlds, if I have this in my OOWriter doc:

para1
para2

It looks spaced in the HTML:

para1

para2

To correct, need to force paragraph spacing in the html using <p style='margin:
...; padding: ...'> on each paragraph to match the spacing in the .odt file.
Comment 5 michael.ruess 2005-08-19 06:39:00 UTC
MRU->ES: is such feature supported by HTML format???
Comment 6 eric.savary 2005-08-19 09:50:08 UTC
Those "features" can be achieved in HTML when modifying manually the files.
The problem is still and remains the differences between Writer UI defaults and
HTML default. Thus -> duplicate.

*** This issue has been marked as a duplicate of 19690 ***
Comment 7 eric.savary 2005-08-19 09:50:25 UTC
Closed