Issue 53636 - impossible to delete a bibliography entry
Summary: impossible to delete a bibliography entry
Status: CLOSED DUPLICATE of issue 4260
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 680m122
Hardware: PC (x86_64) Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: eric.savary
QA Contact: issues@sw
Keywords: needmoreinfo, oooqa
Depends on:
Reported: 2005-08-22 19:37 UTC by shivan
Modified: 2005-10-27 09:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Document I used to test the connection between "database" and "in text" entry (6.87 KB, application/vnd.sun.xml.writer)
2005-10-13 14:55 UTC, yunkong
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description shivan 2005-08-22 19:37:55 UTC
Currently it's impossible to delete a bibliography entry in the document
in edit --> bibliography entry  --> there's no delete button... only modify,
close, help, new and edit ?!?!?
Comment 1 michael.ruess 2005-08-23 08:05:01 UTC
Reassigned to ES.
Comment 2 eric.savary 2005-08-23 11:35:27 UTC
What do you mean exactly with "delete an entry"?
- from the document?
- from the database?
Comment 3 shivan 2005-08-23 19:42:38 UTC
Sorry I forgot..... 
I mean from the document.

It somehow worked after changing and editing and something more on the "edit
bibliography entry" dialog to get rid of one element.... but I think this was
just a result of the other bug I submitted here.
Comment 4 eric.savary 2005-08-26 13:45:18 UTC
Er... did you try to remove the entry directly in the document using Del/Backspace?
Comment 5 shivan 2005-08-31 21:22:54 UTC
After having a look on the xml inside the odt I saw that a bibliography entry is 
saved each time inserted. I first thought that each entry will be saved once in 
the document and everywhere a bibliography entry is used in the document there 
will only be a LINK to the main data of the entry, not saving all data every 
where X times... 
So I saw if I want to delete an entry, I have to search for all places where I 
added the entry with the same ID and delete each...

So I now changed to the bibliography database to have a central management of my 
bibliography entries. When I change one, then it asks me to change all. This 
works with bibliography entries in DB but not with bibliography entries in the 
document ONLY. (I hope my description was not too confusing... however if yes, 
tell me!)
Comment 6 shivan 2005-08-31 21:28:30 UTC
And I forgot to mention.... I was missing this "delete button" because it is 
described in the german help file of OOo writer.
Comment 7 yunkong 2005-10-13 14:50:35 UTC

Not confusing at all :)

I tried this on my comp (1.6 Ghz, 512 MB RAM, PC, Windows XP Professional, Ooo 
Writer 2.0. RC), and realised that there seems to be (indeed) no connection 
between the bibliography database and the entries in a document. 

This indicates that a change in a database entry is not processed in the 
corresponding document entry (like you said). 

Here's the step by step procedure I did to reproduce this issue:
1. Go to menu Insert--> Indexes and Tables --> Bibliography Entry to Add an 
entry from bibliography database
2. Go to menu Insert --> Indexes and Tables --> Indexes and Tables 
3. In the "insert Index/table" dialogbox tab "Index/table":
   select type bibliography
4. Click OK and Bibliography will appear

5. Open bibliography through menu Tools --> Bibliography database
6. Change title of the database entry that's in the document
7. Update bibliography by rightclicking the bibliography in the text and 
selecting "Update Index/table" 

Result: The changes in the database are not processed in the bibliography 
index in the text

It was expected that the entry in the document would change according to it's 
corresponding entry in the database but it doesn't.


A.Y.K. Jong

P.S. ES, Are we not dealing with two issues here ?
     1. Delete button not in dialogue box "Insert bibliography entry"
     2. No connection between "bibliography entry in text" and "bibliography 
entry in database"

Comment 8 yunkong 2005-10-13 14:55:00 UTC
Created attachment 30398 [details]
Document I used to test the connection between "database" and "in text" entry
Comment 9 yunkong 2005-10-13 15:44:28 UTC

While searching the Issue database for something else with the bibliography I 
found that there are a lot of duplicates of this issue dating back to 2003.

Shivan... I suggest you set this Issue as a DUPLICATE of ISSUE 18595, 50622, 
29705 if you agree with me. I added a comment of ISSUE 18595 for clarification.

------- Additional comments from dnw Sun Aug 24 17:10:09 -0700 2003 -------

This is a design fault, or lack of expected action. When you insert 
a bibliographic reference from the database it is copied into the 
document but no link is kept to the database entry. Each time you 
insert an entry a new copy is made. 
If you need to change a bibliographic entry you need can click on 
the reference eg [dnw2000] and select edit, make the changes to the 
fields. Click OK. You must then select Modify, if you select Close 
your changes will be lost. 
If you now update the Bibliographic table the changes will be shown. 
Also, you will have to make the same change to the bibliographic 
database (there is no automatic link) 
More bad news, if you have a large document with many references to 
a single document, you need to make the changes to each reference ! 
It would if fact be easier to open the save file and do a search and 
replace on the required text. 
We have noted these problems and we are currently redesigning the 
whole bibliographic system. 
If this really annoys you please help us find some developers. 
I will make this issue as a duplicate of our head Bibliographic 
Project Issue, as it is about the same thing - Redesign Required ! 

*** This issue has been marked as a duplicate of 4260 ***


A.Y.K. Jong

Comment 10 yunkong 2005-10-27 08:28:18 UTC
Hello Shivan,

I am setting this issue to status "RESOLVED" because it is a duplicate.
If the problem still remains you can always reopen this issue.


A.Y.K. Jong

*** This issue has been marked as a duplicate of 4260 ***
Comment 11 eric.savary 2005-10-27 09:41:24 UTC