Issue 53677 - Customize Toolbars dialog: move items
Summary: Customize Toolbars dialog: move items
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 680m122
Hardware: All Windows XP
: P3 Trivial (vote)
Target Milestone: OOo 3.0
Assignee: thorsten.martens
QA Contact: issues@framework
URL: http://specs.openoffice.org/ui_in_gen...
Keywords: accessibility, oooqa
Depends on:
Blocks: 90510
  Show dependency tree
 
Reported: 2005-08-23 17:12 UTC by matthias.mueller-prove
Modified: 2008-08-05 22:48 UTC (History)
2 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Customize Toolbars dialog: move items (1.46 KB, text/plain)
2008-02-20 08:47 UTC, zhoubo.shi
no flags Details
Customize Toolbars dialog: move items (1.83 KB, text/plain)
2008-02-22 06:31 UTC, zhoubo.shi
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description matthias.mueller-prove 2005-08-23 17:12:25 UTC
Have you ever tried to move an item in the Customize Toolbars dialog?

Select the item
Press the down arrow
Re-select the item
Press the down arrow
Re-select the item
Press the down arrow
Re-select the item
Press the down arrow
Re-select the item
Press the down arrow
Re-select the item
Press the down arrow
etc.pp.

Please keep the selection to consecutively press the down arrow until the item
is at the desired position.
Comment 1 carsten.driesner 2005-08-24 17:09:15 UTC
cd->mmp: Can you please contact me and we should check this together again.
Currently I am not able to reproduce your problem.
Comment 2 matthias.mueller-prove 2005-08-25 15:11:38 UTC
Silver Theme on Windows XP; a selection in a listbox without focus is invisible.
Comment 3 matthias.mueller-prove 2005-08-25 15:12:36 UTC
removing cj vom cc-list
Comment 4 carsten.driesner 2005-08-26 08:04:36 UTC
cd: Accessibility problem. The focus is always set to the "Save To" combo box,
although the user clicked on the up/down buttons. 
There is no "real" problem with the current entry in the SvTreeListBox, but the
color for the current, non-focused entry is wrong (white on white). See bug
i52027 located in CWS fwk20 for more information.
Comment 5 dankegel 2005-10-28 05:34:04 UTC
Adding "accessibility" keyword
Comment 6 Mathias_Bauer 2006-01-20 15:14:18 UTC
We will not be able to fix that one until code freeze for 2.0.2 -> retargetted
to 3.0
Comment 7 carsten.driesner 2006-07-04 13:39:39 UTC
cd: Set target to OOo 2.x.
Comment 8 carsten.driesner 2006-12-19 14:29:27 UTC
cd: Accepted.
Comment 9 Mathias_Bauer 2007-12-04 16:23:50 UTC
target 3.0
Comment 10 frank.loehmann 2008-02-19 08:49:33 UTC
Please do not disable the up/down button anymore if the selected item reaches
the top/bottom of the list. Then the focus could always stay on the previously
pressed button.
Comment 11 zhoubo.shi 2008-02-20 08:47:23 UTC
Created attachment 51600 [details]
Customize Toolbars dialog: move items
Comment 12 zhoubo.shi 2008-02-22 06:31:58 UTC
Created attachment 51645 [details]
Customize Toolbars dialog: move items
Comment 13 carsten.driesner 2008-02-26 08:12:34 UTC
cd: Changed issue type to "PATCH".
Comment 14 carsten.driesner 2008-02-28 07:57:50 UTC
cd: Patch approved and committed.
Comment 15 carsten.driesner 2008-04-17 07:22:21 UTC
cd->tm: Please verify.
Comment 16 thorsten.martens 2008-04-29 11:13:28 UTC
Checked and verified in cws fwk86 -> OK
Comment 17 lohmaier 2008-08-05 22:48:43 UTC
ok in m28 → closing