Issue 53751 - Glue points not displayed in group of shapes
Summary: Glue points not displayed in group of shapes
Status: CLOSED DUPLICATE of issue 7575
Alias: None
Product: Draw
Classification: Application
Component: editing (show other issues)
Version: 680m122
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: AOO Later
Assignee: Armin Le Grand
QA Contact: issues@graphics
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-24 19:37 UTC by unraveler
Modified: 2005-10-25 11:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description unraveler 2005-08-24 19:37:45 UTC
When glue points are added to a group of shapes, they are not displayed.  To
reproduce :

1 - Draw two rectangle one beside the other
2 - Add a glue point to the upper left corner of the left rectangle
3 - Select and group both shapes
4 - Add a glue point to the upper right corner of the righ rectangle

You will notice that the glue point added in step 2 is still visible, but that a
connector cannot be connected to it.  The glue point added in step 4 is not
visible, but you can connect to it.  

If the "Glue" icon is deselected, the group is not redrawn and the glue point
from step 2 remains.  If the draw window is minimized and maximized, the glue
point disappears.

What should happen : 
- in the group, the glue point from step 4 should definitively appear
- when the glue icon is deselected, glue points should disappear
- Glue points from step 2 should either not be visible, or we should be able to
connect to them.  Both behaviour seems reasonnable.
Comment 1 wolframgarten 2005-08-25 07:39:06 UTC
Reproducible. Reassigned.
Comment 2 Armin Le Grand 2005-10-25 11:20:20 UTC
AW: Double to #i7575#.
AW: In step 4, the glue point is added to the group, not to the 2nd shape
AW: GluePoint and group stuff needs rework.

*** This issue has been marked as a duplicate of 7575 ***
Comment 3 Armin Le Grand 2005-10-25 11:22:32 UTC
.