Issue 53811 - File type association does't work on Windows XP platform
Summary: File type association does't work on Windows XP platform
Alias: None
Product: Installation
Classification: Application
Component: code (show other issues)
Version: 680m136
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: OOo 2.0.1
Assignee: hennes.rohling
QA Contact: issues@installation
Depends on:
Reported: 2005-08-26 09:06 UTC by hatake
Modified: 2007-06-11 08:32 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

reg file to import (1.21 KB, text/plain)
2006-02-06 07:22 UTC, priest_ux
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description hatake 2005-08-26 09:06:41 UTC
to reproduce:

  1. confirm that if you double-click on any Excel file on Win Explorer,
     MS Excel is invoked with Excel file you double-clicked.

  2. install OpenOffice 1.9 m125 with Automatically open option
     for MS Exel Spreadsheet.

  3. double-click on any Excel file on Win Explorer.
     ==>> MS Excel is invoed.  not a OpenOffice.

It happened only Windows XP Platform. When I try to reproduce this
on Windows Me, I could not...
Please verify this on Windows XP platform.
Also, m122 seems work fine on Windows XP. So it seems regression of m125 release.
Comment 1 Olaf Felka 2005-08-26 09:31:18 UTC
I can't confirm: OOo 1.9 m125 is starting after double-clicking in explorer.
Comment 2 hatake 2005-08-30 03:34:25 UTC
Hi, I can still reproduce this..
Do you hava any idea to investigate this issue ?
such as debug option for installer, how to check
registry for file association of Windows..
Comment 3 naoyuki 2005-08-30 05:15:13 UTC
I also be able to reproduce this with m124 on Japanese Windows 2000, althogh
Exel file does not invoke Excel but application selection dialog. (Icon for
Excel file
is not Excel or OO.o, but generic Windows icon.)

This might happen only on Japanese Windows2K/XP, so please check this
on Japanese version of Windows.
Comment 4 Olaf Felka 2005-08-30 12:23:10 UTC
IÄ've tried to reproduce on WinXP (western lang.) and Win2000 (japnese lang.) 
with MS Office 2000 pre-installed.  I've installed OOo beta2 (m125) english and
japanese. All MS document types have been associated to OOo after installation
(OOo document icon). Doubleclick on a document raises OOo beta2.
Comment 5 kammah 2005-09-21 14:45:39 UTC
I can reproduce it too. Since 1.9.122 file association doesn't work as it is
expected. Right after install the files are associated but after a restart the
file associations are lost somehow
(tested on Windows XP SP2)
Comment 6 Olaf Felka 2005-10-06 12:43:11 UTC
I haen't found a way to reproduce with beta nor with RC1
Comment 7 Olaf Felka 2005-10-27 12:12:15 UTC
of: After some further investigations we found out what the problem is: When
installing the office with the 'all user' option and selecting mimetype
association to OOo a custom action writes empty keys for these mimetypes to
HKEY_CURRENT_USER\Software\Classes. Another problem is that these keys where not
removed at uninstall.
Comment 8 Olaf Felka 2005-10-27 12:25:03 UTC
The easiest way to reproduce is to have clean registry ro to remove the .doc,
.dot etc. keys in the registry [HKEY_CURRENT_USER\Software\Classes]. Additional
information: These empty keys for OOo associated MS mimetypes are also not
removed if you make a 'current user' installation of OOo. I think we should
leave a clean registry in this case.
Comment 9 2005-10-27 16:07:44 UTC
The problem is function "UnregisterExtension" in regcleanmsdoc.cxx
(setup_native). The function creates empty keys ".doc", ".dot", ... in
HKEY_CURRENT_USER. But this empty keys are merged together with the created keys
Extensions can only be unregistered in HKEY_CURRENT_USER by removing the keys,
not by creating empty keys. With this method the extensions ".doc" and ".dot" in
HKEY_LOCAL_MACHINE are unregistered, which is the opposite of the desired behaviour.
Comment 10 hennes.rohling 2005-11-01 11:10:51 UTC
Comment 11 hennes.rohling 2005-11-03 12:30:20 UTC
Use SHDeleteKey to delete complete subtree for user registered extensions.
Comment 12 mnoyce 2005-11-29 23:20:00 UTC
I had this problem with OOo 2.0.0 on WinXP SP2 and was eager to see if this was
indeed fixed in the up coming OOo 2.0.1.

As a precaution I uninstalled OOo 2.0.0 first and then installed OOo 2.0.1 RC1.
My administator account has all the correct OOo and MS Office file associations
as expected. However, the normal (non-administratir) user accounts only have the
OOo files associated--the MS Office files are still not correctly associated!

For example: double-clicking on a .doc file opens Wordpad, and double-clicking
on a .xls file causes Windows asks you to find the program that created the file
so it can be opened.

I even tried uninstalling and then reinstalling OOO 2.0.1 RC1 several times
being sure to tick the file association options during the installation, but
nothing I do would created the correct MS Office file associations with OOo.

As a result none of the other users using the same computer can open MS Office
files using OOo by simply double-clicking on the file icon. Most annoying!
Comment 13 mnoyce 2005-12-03 21:55:18 UTC
Sigh! Just tried OOo 2.0.1 RC2 and this profoundly annoying bug still isn't
fixed!?! This is blocking any possible rollout of OOo 2.x as users cannot open
their existing MS Office files by simply double-clicking on them.
Comment 14 priest_ux 2005-12-06 13:21:44 UTC
People@oo.o! Please REOPEN the issue according to comment from mnoyce Tue Nov 29
15:20:00 -0800 2005! Thanx.
Comment 15 phil_s 2005-12-06 20:47:11 UTC
I agree with above comments. Contrary to resolution status, this issue is not 

Installing OOo on Win XP SP2 as a multiple-user installation from an 
administrative account associates filetypes correctly for that user, but all 
other users (limited users) on the machine who subsequently complete the 
installation have no filetype associations, despite "Install for anyone who 
uses this computer" having been selected during initial installation. 
Comment 16 phil_s 2005-12-09 16:28:09 UTC
Another report of this bug:
Comment 17 priest_ux 2006-02-06 07:22:43 UTC
Created attachment 33869 [details]
reg file to import
Comment 18 priest_ux 2006-02-06 07:29:02 UTC
This issue seems to relate to previous installation of OOo version 1. I had
1.1.4 before. Uninstalling did not clean some registry enties (no surprise!).
And new installation seemed to detect that entries present but did not validate
them. That's why we had broken associations.
WARNING: you should check and fix pathes according to your installation path.
Please approve the workaround and fix installation programm. Thanks.
Comment 19 hennes.rohling 2006-02-15 09:22:11 UTC
Comment 20 merlin_skinner 2006-04-19 09:52:29 UTC
I had exactly this problem.  Everything was fine for the administrator account 
from which OO was installed, but no associations worked for users.  The 
registry fix (id=33869) didn't help.

Un-installing OO, removing the relevant registry keys and then re-installing 
did fix it, however.  Like "hro", I was using OO V1.1.4 previously.
Comment 21 evansmm 2006-05-06 19:34:58 UTC
I have been using 1.1.5 Swedish. Did an "alluser" install of 2.0.2 Swedish as
administrator which worked correctly. Then tried to use it from a normal user.
Double-clicking and Excel file started 1.1.5. 

I saw nothing in the setup guide for 2.0.2 about being forced to uninstall
previous versions.

IMHO the defect is still present.
Comment 22 Olaf Felka 2006-05-08 08:32:56 UTC
OOo 1.1.5 is register for 'current user'. Windows is designed to use the
'current user' settings before using the 'all user' settings. That's not not a
bug in OOo, that's how Windows works.
Comment 23 dan400man 2006-11-06 05:14:00 UTC
I just installed 2.0.4 over 2.0.2, which was installed over 2.0.0.  I am now
experiencing the problem where .odt files are not "registered" to OOo for any
user except for the installing administrator.  File associations for Microsoft
Office extensions work fine - they open right up in OOo!  But not the .od?
Comment 24 Olaf Felka 2006-11-30 11:11:20 UTC
I can't confirm. I've installed OOo 2.0.2 for 'all user'. File association is
set to OOo 2.0.2 for Administartor and for all restricted users. Afterwards
installed OOo 2.0.4. It has detected OOo 2.0.2 and updated it. I haven't changed
anything in the given installation settings. After updating to OOo 2.0.4 every
filetype association is bound to OOo 2.0.4 and works for all user and Administartor.
Comment 25 freemant 2007-06-11 05:43:37 UTC
We installed OOo 2.2 while keeping existing OOo 1.1.5. The associations work fo
the administrator (pointing to OOo 2.2) but not for others. To fix it, I had to
copy HKCU\Software\Classes from the administrator to the user.
Comment 26 Olaf Felka 2007-06-11 08:27:39 UTC
@ freemant: That's not a defect, that's how Windows (and other OSs) work. OOo
1.1.5 has written it's systemintegration for the current user. When you install
OOo 2.x for 'All Users' these keys will be "overruled" by the current user
settings of OOo 1.1.5.
Comment 27 freemant 2007-06-11 08:32:38 UTC
So for the other users they will get stuck to 1.1.5? When if 1.1.5 is
uninstalled later after 2.2.0 is proven to work fine? I think the per-user
installation should reset those keys (possibly after prompting).