Issue 54369 - Impress gets confused when applying slide design with same name
Summary: Impress gets confused when applying slide design with same name
Status: CONFIRMED
Alias: None
Product: Impress
Classification: Application
Component: formatting (show other issues)
Version: OOO 2.0 Beta2
Hardware: PC Linux, all
: P4 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-08 16:53 UTC by loeffel77
Modified: 2017-05-20 11:09 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description loeffel77 2005-09-08 16:53:23 UTC
- start an Impress
- create a template with two master slides (one Master slide has to be named
Default)
- import this template to the OO templates
- create a new presentation
- make sure that the master slide is called "Default"
- create two slides with the slide design "Default"
- open "Slide Design" menu for the second slide
- click on load and load the slide design from the teplate created above
- make sure that "Exchange background page" is unchecked
- select the "Default" Design from the template

The following will happen:
- All pages in the "Default" design of the new presentation will get the
templates "Default" design
- Undo (Ctrl-Z) will change the background to solid blue
Comment 1 rjohnsto 2005-09-10 03:49:21 UTC
Rob Johnston 
September 9, 2005

OOo version: 1.9.125 (Clean installation)
OS: Windows XP SP2
Processor: P4 3.4 Ghz
Mem: 1 Gig

Here is an alternative set of replication steps:

1. Start new instance of Impress
      - select 'Empty presentation' radio button
      - select 'Create' button
2. Change 'Slide 1' background to another background besides 'Default'
3. Select File -> Templates -> Save
      - type "Default" in 'New Template' text box
      - select 'OK'
4. Close Impress and Start a new instance as in step 1
      - If 'Slides' pane is not open Select it from the View menu
5. Create two or more 'Default' slides
6. Right click on one of the slides in 'Slides' pane
      - Select Slide Design -> Load
      - Select 'Default' (template that was just created)
      - Select 'OK' 
10. Two slides named 'Default' should be shown in the 'Slide Design' pane
      - slide on the left should be the actual Default slide
      - slide on the right is the newly created Default slide
11. Select slide on the right, Select 'OK'
12. All slides will change background to selected slide

This problem is not restricted to just the 'Default' slide, for example it can 
be recreated using the 'lyt-darkblue' slide.
Comment 2 wolframgarten 2005-09-14 08:29:35 UTC
Reassigned.
Comment 3 christian.guenther 2005-10-18 16:28:52 UTC
Set to new and change the target.
Comment 4 christian.guenther 2005-10-18 16:29:54 UTC
I can reproduce the bug.
Please have a look.
Comment 5 Marcus 2017-05-20 11:09:00 UTC
Reset assigne to the default "issues@openoffice.apache.org".